"USB device" not showing up in My Computer

I just got a IDE to USB adapter, and it seems to be working except for one annoying issue. The drive that I’m connecting doesn’t appear in My Computer.

my hard drives are at my apartment and I’m at my parents house so I haven’t been able to test it with hard drives yet, but I’ve got an old CD-RW connected at the moment.

the computer recognizes that new hardware is attached and installed the default drivers.

anydvd even recognizes the disc that’s inside the drive and adds an extra tab. I can play the disc from my media player…I just can’t get the darn thing to show up anywhere where I can access the contents.

I plan on using the adapter mainly for hard drives, and a hard drive is rather useless if I can’t access the folders themselves. any advice on how to get this sucker to come up in My Computer? Am I missing a setting or something?

Things I’ve checked/tried:
jumper is set to master…not sure if that matters
Nothing has any yellow exclamation marks in the Device Manager
Tried uninstalling the device in device manager and rebooting
tried manually “adding new hardware” but it claims the device is already working properly
Tried different USB ports on the front and back of my computer

Most bridgeboard chipsets have problems with optical drives. This could be your problem. The only way to check it out is with a hard drive.

i don’t know much about chipsets. at least I know that the thing works (or at least seems to). I’ve been at my parents house for the holidays. I’m back to college and back to my apartment with all of my nerd toys by the end of this week so I guess I’ll just have to wait until then to test my hard drives.

Thanks for the response!

What brand is the adapter and, if possible, what name is on the chip?

this is the adapter i bought. Newegg lists it as “Koutech” but that name isn’t anywhere on the packaging. the box says “SOHOUSB.” I got it mainly because it had an on/off switch and the power cable/IDE connection were connected. I liked the design better than some of the “brand name” ones.

i have no idea how to tell what the chip is…I don’t think it’s specified. The box doesn’t mention anything, and the device itself is rather plain. just says “easy IDE USB 2.0” and the bottom has a sticker that says “Ver:108B0 Made in Taiwan”

there’s nothing else written anywhere on the device.

Koutech, says this adapter supports DVD burners, but as we all know there can be some problems. Wha brand is the drive?

it’s a samsung 616. it’s a CD-RW/DVD-ROM. it has the latest firmware (not sure what off the top of my head, but I flashed it just before removing it from my computer a couple weeks ago)

to its credit, the dvd inside is recognised by anydvd and I can play it in VLC. The drive is listed in teh device manager and everything.

it’s just absent from the my computer window.

come to think of it i just remembered a similar problem. I don’t have a USB thumb drive, but my roommate does, and he wanted to do some work on my computer. He mentioned to me that he plugged his drive in and the computer recognized it, but he couldn’t access his files.

This was a long time ago though, and I’ve reformatted my system and done a clean windows install at least twice since then. I’m now beginning to wonder if these issues are connected and if there’s a problem with my system. I didn’t look into it at the time because it was his problem, not mine :stuck_out_tongue:

Could be a Windows problem but I have not encountered it yet. Given that some software sees it but not others, you might have your system set to not assign any more drive letters.

i just found a driver on the manufacturer’s website, but it doesn’t seem to make a difference. oh well, worth a try.

Check in you disk management and see if it shows up there. It is under the system administration tools.

anydvd recognizes it as an H: drive and when I play it in VLC, I go to “Open Disc” then input the H drive

where would i find the system settings related to drive letter assignment?

i hat not knowing what i’m doing! haha sorry that these questions are so basic

EDIT: nm, I should be playing in the disk management window, right?

EDIT again: in Disk Management, the drive is also present and recognized as H: hmmm

control panel/administrative tools/computer management/disc management

Well I am at a loss. Maybe someone else has experience here.

Good luck.

i can explore the drive and see the files on the disc from the disk management window. this is a little progress at least.

this pretty much sums up my confusion:


I suggest a restart of your computer with the usb pluged in and see if it is recognized. Sometimes usbs are not getting enough power -if tooo many are installed. Hope this works for you.

i only have one usb device installed, but a restart won’t hurt…commencing restart NOW!

restart didn’t help, and I don’t suspect it’s a power issue because the adapter has a separate power cord. that must be plugged in for the adapter to turn on. (there’s an on/off switch right on the adapter)

Right now my temporary fix is sharing the drive on my home network and “map network drive” to create a shortcut to it on my desktop. I can’t access it any other way!

if anyone else reads this and has any advice I’d appreciate it.

ok how weird is this.

i started reassigning drive letters. my Z drive I created when I installed the hard drive a long time ago. other than that one, My Computer won’t display any drives further along in the alphabet than “G:” even though they are recognized and properly installed on the system.

I changed my data drive to I: and changed my usb connected dvd drive to G and BAM it’s there, but the Data drive is missing.

so i guess at this point does anyone know why this happens or how to make my computer display more than 6 drives?

(I have 2 optical drives, a virtual drive, one hard drive with 2 partitions, and another hard drive = 6)

i have no A: drive…i removed my floppy in a fit of rage one day, but I can’t reassign to A:

from everything I’ve googled it seems like windows likes to assign the higher drive letters (beginning of alphabet) to connected drives. If a mapped network drive is already taking up one of these letters, the connected drive will not work.

that seems to be everyone’s explanation…but I unmapped ALL network drives and I’m still not getting anywhere :frowning:

i think i might be in the mood for a reformat.

almost sounds like a limit set in mmc to limit the letters shown.

microsoft management console?

any idea how I’d modify these settings? For however much i do know about computers, this problem has had be finding parts of windows I’ve never dealt with before haha