USB 2 External Wont Recognize Blanks

vbimport

#1

I’ve been troubling over this for about 3 days now. I recently (no more than a few months ago, mabee 6) purchased a Mad Dog Multimedia Dominator USB 2.0 External CD-RW / DVD combo drive. I have had few problems with the device to this point, It reads data and music cds, programs and dvds without difficulty… including burned cds (from other burners). I just recently tried to use it to burn a cd, and much to my surprise, it does not work. Despite the brand of medium, and / or burning software / utility, or any itteration of the two, I am stricken with the same problem: “Please insert a blank cd or compatable media into the drive” ; “Drive is empty, Please insert a blank cd” ; I have seen others with this problem and scoured forums long and hard (and please if you’re reading this thinking ‘of course it can’t read a blank!’ or ‘Is the cd in shiny side down?’ [yes someone asked me that] save your breath, I’m not a f*cking moron, this is a legitamate problem). Much to my amazement, I did not have an ASPI layer install whatsoever, so I did install and confirm all 4 components with that adeptec aspichk.exe or some such; version 4.6 If i remember correctly, thats the one everyone claims the least problems with, and the version forceASPI uses… Still the same deal. There are no firmware flashes for usb externals as far as I know ( I may be speaking from ignorance here ) but the drive is only a few months old and I have read pleanty of forum posts raving about the dependablity of this drive (!?) thus I doubt greatly it is a driver issue. I do have the latest USB 2.0 drivers installed. I scanned my computer with Ad Aware and Spybot S n D, yet my plight persists… I am out of ideas, and I am not very keen at throwing more money at this problem, I just bought a new drive! It should work! Please help me!

System Specs:
M-Tech Notebook
P4 2.5ghz 1gb ram 36.4gig hd, internal combo drive (no longer functioning and deactivated) etc. I’m not sure what else you’d need

I’ve tried these burning programs: Windows XP, Nero Express 5.5