USB 2.0 PCMCIA controller card in an old notebook

vbimport

#1

Hi!

I have got a Fujitsu-Siemens Lifebook B 2130 (subnotebook with Celeron 400 CPU and 192 MB Ram). I would like to add USB 2.0 support over a PCMCIA card.

The problem is that I already tried two different cards with NEC chipset (no other chipset seems to be available) and it does not work properly. The card is correctly recognized by Windows, but when I connect my external HDD, the device manager crashes when the drive is detected. Then I tried the latest drivers for the card, and the HDD is correctly recognized and works fine. However, as soon as I restart the computer, Windows does not boot and hangs. When I disconnect the USB 2.0 PCMCIA card, Windows loads, but the card is not recognized when I connect it again.

I already tried two different cards (with the same NEC chipset) with an additional power supply, but the problem persists. My notebook has been updated to the latest bios and I am using Windows 2000 with Service Pack 4. For testing, I once installed WinXP with Service Pack 2 - but the problem remained. Furthermore, I managed to change the IRQ of the PCMCIA controller card in bios, but that did not help either.

Is this a well-known problem with this notebook? Do you know how to solve this issue? Do you know of any USB 2.0 card which has been tested and approved with this notebook?

Thanks a lot for your attention. Have a nice Sunday.