Urgent!plextor 755a Read Problems

I have recently purchased a plextor755a dvd writer.The problem is that it only reads at 2 speed regardless to the speeds being changed. I use dvd fab dycrpter, dvd shrink, and nero burning rom. Everytime I put dvd or cd media into the drive it will ony read at 2X speed. Even if I change the speed it doesn’t work. When I go to plextor tools and change the speeds it doesn’t make any difference. Ther drive burns info to the hard drive as if it’s playing it. when I go to nero drive tool it registers as 2x max speed.I own an 8xspeed burner and it registers at its correct speed.If I burn a dvd5 which should take 5-10 min it takes 30. If I burn a cd file it will take 10 minutes instead of 2. However, the drive will write to blank cd and dvd media at the speeds you set it but not the other way around. This is the second 755a plextor have sent me and still the same problem. I have used these burners in several pc drives and get the same results. I have sent this info to plextor who seem less interested in the performance of the drive and more interested in if I’m trying to copy, copy protected media.Can anyone help?

Before inserting your DVD, depress the eject button for five seconds to deactivate the riplock.

dear tropic. Thanks for your help. I will follow the instructions and see what happens. thanks a million.

dear tropic. If the above instructions work. does this mean I will have to deactivate the riplock everytime I insert a dvd and everytime I turn on my PC?

No you don’t.
It remembers :clap: .

Dear tropic. did what you said on both 755a drives and it didn’t make any difference. When I put a film in it ripped fast, but once you reload the film again it defualts back to a slower speed. For example, I put in a dvd which clocked at 25 minutes on shrink, and when I re inserted the film it said 50. The drive was no longer able to perform its fastest read speed. I went to change speeds but same problem. I put in the other 755a and same the nonsense. I then depressed the eject buttons on both for 10 seconds and they still wouldn’t read at top speed on dvd fab, dvd shrink 3.2 and nero burning rom.I did this on a friends computer so he could see I wasn’t going mad, and to witness the problem first hand. Please help!What’s going on? What shall I do?ANYONE!

Dear tropic. Did what you told me, but it didn’t make any difference. I used a friends computer and ran both burners one after the other and they only read at full speed a few times.I did this so he could witness the situation first hand, and so I know I’m not delusional.

I put in a dvd on shrink which clocked at 25 minutes encoding. Then I ejected it and repeated only to hear the drive slow down to be clocked at 50 minutes encoding. I did thison both drives with different media on dvd fab decrypter, dvd shrink, and nero burning rom. constant nonsense. One minute they would spin fast and whistle then they would slow down and hum at around 2 to 4 read speed.I have never experienced this with any other burner. Whats going on? What should I do? Please help! ANYONE!

Dear members. I am still in the same situation with 2 brand new plextor 755a writers that won’t read any media over 2x speed to the hard drive. I have tried various things including advise given to me above. Plextor are now dealing with the problem, but don’t seem to want to accept what is going on. Has anyone out there experienced the above problems with any plextor burners? Can anyone help me find a solution? As plextor seem the least knowledged in tackling this weird occurance. I thank you all in advance for any help and advice. Thanks.

I’ll transfer this to the excellent Plextor forum we have here…

What are your system specs? Have you checked the device manager to verify UDMA4? Are the discs you are playing commercial pressed discs? If copy protected, they will not play over 2x unless you enable speed read via PlexTools Pro or by holding down the eject button (with tray empty, press the button until it blinks green 3 times. Release and load the disc. It should read up to 16x. You can try this with DVD Speed)

Dear members.I have finally conquered this problem, but not with the help of plextor. I was told on cdfreaks.com to disable the quality/speed read smart technology. There are 2 drive speed/quality functions called POWER REC AND AUTOSTRATEGY.You have to disable the power rec so you can change the read speed settings of any media inserted in the drive. The same applies to autostrategy which develops it’s own database in order to categorise the best writing strategy for different media types. Why plextor didn’t explain this is beyond me! It was a 30 second job (that plextor still haven’t got an answer for) and now at last, the drives work at the maximum speeds regardless to the pc they are connected to. I thank you all for your advice and and support. Thanks a million

By disabling PowerRec and Autostrategy you’re risking to create coasters easily. Especially with cheap, lower grade media.

They only affect the burn process.

The 2x limited read spead you encounter is called ‘rip-lock’. Others say a ‘quiet’ feature :wink:
This can easily be turned off via PlexTools, ticking the checkbox for ‘enable SpeedRead’.

Powerec and Autostrategy are write only features. 2x read with pressed commercial media is either Speed Read as mentioned above or a system issue. Using CD Speed, burn a DVD +/- disc of your choosing. Then run the transfer test. If you get way less than 12x at the top end, you have the following possibilities:1) SATA chipset or driver issues, 2) a bad drive, 3) rotten media, 4) some system issue. Simple test…give it a try. If it reads 12x for DVD+/-, run your ROM and graph the results. If you get 2x for pressed media, you either have Speed Read not enabled, crappy discs that require the drive to slow down, or some other copy protection feature that cannot be overridden.

I have put powerec and autostrategy back on. I have enabled read spead and the drive is working perfectly. Thanks to everyone who responded to this thread. POWER TO THE PEOPLE! Now at last this thread can be closed.

Hi everyone. I have a plextor 755A DVD BURNER. I recently ripped some copy protected cd’s to my hard drive and some of them would only burn to the hard drive at 1,200, kb 8x speed. The burner would spin whistle and lead in at full speed I set it but would drop down to the above as soon as the ripping would begin. I took out the media and tested their read speeds in plex tools as well as nero and the same cd’s in question would only read on the hard drive at the above speed. All the media concerned was copy protected and a few years old ,so they didn’t have the new digital copy protection. They were not badly scratched or used, so I find it strange that they took 6-8minutes to rip to the hard drive instead of 3-4. I then put in copy protected dvd media and they all ripped to the hard drive at full speed. Speed read power rec and autostrategy are on as above. Giga rec is not enabled so why are some copy protected cd’s ripping at low speeds and others not?

Media quality. Media degrades over time, and factors such as flatness (focusing) or eccentricity (tracking) influence how fast the drive can read the disc. Copy protection is only one logical (reading/decoding) factor. There are the physical factors to think about also.

dear bob11879 and anyone else that can help.
I understand what you are saying concerning the above. However, I put the same discs in another drive and they burned to the hard drive between 2-3 minutes instead of the average 8 to 10. I was using a toshiba dvd writer that is 50percent slower than the plextor 755a, so what’s going on? Does the plextors 755a ‘enable read speed’ setting differ for commercial cd and dvd? Why will all my copy protected dvd’s burn at maximum speed while 50percent of copy protected cd’s burn at miniumum? This problem is unique to the plextor 755a.
If you would suggest a good burner for the future, what would you reccomend?

Thanks, and sorry for the long ramble.

THE ROCK

Confused about what you want. “The Toshiba is 50 per cent slower” Does that mean it is a 8x writer or a 8x reader? You want a good burner for the future, but your problem is reading/ripping, not burning. The disc was copied to a HDD faster from another drive, but was it accurate? The 755 test I mentioned will tell you if it is a drive issue or disc issue. If you get maximum write speed with +/-R and maximum read speed of 12x, then the drive and interface are okay. Any slowdown with pressed discs is usually due to disc quality, not the drive. If ALL your pressed discs read consistently slow, then a possible drive issue. If some read slow, then it is media.

The toshiba is 8x read and write. All the discs copied from it are perfect.I will perform the tests you mentioned and get back to. Thanks.

I have the same, the drive is reading/verifying at 1.9speed (using Nero).
But even more annoying: The drive is burning at 1x. It takes approx. 72 minutes to burn a DVD and around 40 minutes to verify it. That takes 112 minutes to burn a DVD…
I will try the unlock-trick as soon as the DVD that is in the drive is finished.

BTW: I am not using bad or cheap media: Plextor, Verbatim, TDK, all the same slow results.


I just tried to unlock the drive but writing a disc still takes over an hour. Weird thing is the ‘Buffer Level’ as shown in Nero is on 42% constant. As I remember right this was always around 100% while the drive was working correctly. The ‘Used read buffer’ is showing 100% as it should. Nothing changed in hardware or software on the machine.
DVD’s are recognized correctly (showing 16x in Nero). Status is showing ‘Writing at 6x (8310 KB/s)’ this is because I chose 6x for the burning.