Urgent! Installed wrong firmware from dell!

vbimport

#1

Hi I really need help!

I hsve a samsung cd-rom only (SN-124p 24x slim I guess but in device manager it’s wirtten SN-124 Boot Rom). My computer is a dell latitude C640 (laptop) and I went to dell site and downloaded the wrong firmware (wrong drive—> the name of this firmware and drive is Samsung SN-324S Slim CDRW/DVD ROM). Now everytime I my driver is plugged in the bay and i power on my computer It says that the drive is not firmely in the bay and i have to put it firmily… My computer loads windows when i remove my cd-rom! I tried everything like fromdos but i don’t understand how to use it. I And i know there is a floppy to put my firmware but i dont have a floppy. Can I remove the firmware i intalled from dell and put the original. Please help my computer have some problems and I need to format!!!:sad:

Sincerly,

Problems001 (sorry for mistakes!)


#2

Hi and Welcome!

have you already searched Dell support website if there are solutions?

My rough guess: the 324 firmware has different “master/slave” setting. That’s why there are problems like that. But I am wondering that the firmware update did not check the hardware that is present :confused: Or have you overridden the hardware check?

You need:

[ol]
[li]A desktop PC
[/li][li]An adapter to connect your slim drive to a normal IDE connector (you may have to remove the drive from the bay)
[/li][li]Correct firmware for your drive.
[/li][/ol]

With these, you should be able to recover the drive.

Michael


#3

hello everyone again,

I called dell support and they can’t help the only tthing they can do is a diagnostic they say and they will charge me a lot even if I told them the proposition of Micheal, they say they don’t know if it’s going to work because a firmware is a program that stick and stay in the cd-rom memory!!! Do anyone have any other idea so I can erase the firmware and put so original one, before I try the suggestion of Micheal. If not can you tell me where can I buy this adaptor to convert??

P.S: Do anyone know how I can order my recovery cd for Dell latitude c640, if yes, is it free? (First answer the question about the firmware please, it’s urgent!!!)!!!

Thank you!


#4

Do you see SN-124 Boot Rom in device manager the first time after you reinsert the drive while windows has already booted ? That ment the drive is in safe mode, accessable and probably can be reflashed in your laptop.
Did you simply start the R109456.EXE file to flash the drive ?


#5

Hi

Yes I see in device manager SN-124 boot rom and no I never try R109456.EXE but it<s for another version of cd-rom, i will try even in safe mode, i’ll tell you if it works!

Thank you, you’re a great man, God bless you!


#6

Ah! appologize! When I flashed the cd-rom with the executable you said there was like a bin coming with it and I did loaded to install it!!

Thanks, please help.


#7

So you used SFDNWIN.exe to flash U306.BIN, both files from the R109456.EXE package ?
You do not see SN-124 boot rom if the drive is not inserted in the Laptop ?


#8

I have the same problem and appreciate if you could give few instructions on how to get it resolved… I did use (and probably the same as the original query poster) SFDNWIN.exe to flash U306.BIN… I do not see SN-124 when the drive is not inserted. Problem is, if I insert it before I boot the laptop, an error appears:

drive is not firmly attached in the modular bay… (something like that)

But if I disconnect it, the system loads to windows automatically… is there anyway where I can reinstall the cd rom (if I put the cd rom after windows boots up, windows automatically detects it and reinstalls it as the samsung SN-124 – and will not work…)

Thank you in advance for any help you can give… :slight_smile:


#9

Which firmware revision was installed before ?
Can you boot from a DOS floppy or USB stick ?


#10

I dont have any idea what firmware was installed before…

I cant boot from a usb and floppy… also, when the cd rom is in place before I turn on the computer, I cant even do an F2 for setup or F12 for boot menu…


#11

Have you tried to boot the Dell SN-124 update floppy, then insert the drive, then flash ?


#12

We don’t have any floppy drive to flash from the floppy. And I don’t know whatsthe name of the old firmware I think it was BR73386—> N104.obj (Samsung SN-124P 24X Slim 1.6 Firmware). I even tried to extract the files onj floppy and to put them on C: so I can run from safe mode with command prompt, but when I type
"C: Flashdos;
flashdos n104.obj" ----> they say there is no drive!! And my drive is connected! Or if i simply write “d:” they say that drive is not ready to use!

Thanks please help!


#13

I do not think it can get worse than it is now, so try the package I sent you in a PM from windows. In the worst case the drive will be completely dead.


#14

How big are the chance that my driver still function??? Do i have to run it in safe mode!

P.S: Can you give the link where i can download it!


#15

I tried in normal mode and in safe mode and the problem persists, when I load windows the same error message and the driver name still sn-124 boot rom.

Thanks for your help ala42!


#16

After finishing downloading they say : Download Fail!!! Restart computer! Save and close all applications!

Thanks ala42 I really need a reply from you

P.S: Maybe this bin would be better N102MMI but I don’t find it. Look at this site: http://www.station-drivers.com/page/samsung.htm


#17

I have send you a PM with the N102 firmware.


#18

Hey, even this one is not working in normal mode as in safe mode! Can you please help, I really need this cd-rom!


#19

Try to set up a USB stick to boot real DOS to be able to use the DOS flasher.


#20

My notebook can’t boot from a usb flash!