Upgrading 1004 firmware with Linux

I have no way to get into windows. I would like to flash my firmware but I am having difficulty figuring out a way to do it in Linux. Running LiveUpdate or the firmware I downloaded from BTC’s site in wine only gives me a “No BTC hardware” message. If anyone can give me some idea of how to proceed I would appreciate it.

Boot to DOS and use mtkflash.

I’m in a similar situation except that I have a Windoze box networked to my Linux server and I have a 1008 rather than a 1004. The latest versions of dvd+rw-tools has a program call btcflash which MAY be able to flash your drive. It worked fine on my 1008. The notes within the program state it SHOULD work on a 1004, but YMMV.

I used the live update program to get a copy of the latest firmware downloaded to the Windoze box. You may have that already, seach for V0059.HEX in you Windozes temp file directory in Wine.

Then you need to get dvd+rw-tools here: http://fy.chalmers.se/~appro/linux/DVD+RW/tools/?M=D
Unpack and compile the package with ‘make +btcflash’
Then typing "./btcflash /dev/cdrom V0059.HEX’ will flash the drive.
You need to reboot after that.

Good Luck!

I run Gentoo so I always have the latest dvdrtools. I will give it a shot and see how it goes.

Excellent. I got it to work.

I needed to create a Temp file in my windows directory inside my fake_windows (the wine windows.) After that the utility came up and actually found the drive and the update button was not greyed out. I was to scared to click it though heh. I did as you said and grabbed the hex file and used btcflash. It seems to have done the trick.

If anyone has more guts then I do… see how well the actual tool works under wine. :bigsmile:

Glad to hear btcflash worked for you!

I thought about using Wine, but I think that would be asking too much of it. After all, they’re just trying to get the applications to work. Low level IO like flashing firmware is not on their todo list.

I did not want to rip open two computers just to flash the drive. So I googled around until I found btcflash.

Maybe btc could make this an offical tool. I suspect this could run on quite a few flavors of *nix and maybe even the Mac.

I did e-mail BTC support last night asking for a solution to my problem. They emailed me back to inform me that they dont support Linux. I sent replied with a link to this thread and a request to make the actual firmare (*.HEX file) available seperate from the Windows packages. This would allow us to bypass the wine step and be able to perform the operations 100% native.

As far as making btcflash official, if they made any changes to the source they would have to put it back out there. It is GPL.

you can also download the rpc1 firmware from dangerous brothers and flash with the .bin file. using mtkflash under DOS.

I did it!

  1. wine and IDE1004_0151_MCU.EXE
  2. make +btcflash
  3. reboot

So as I understand that’s all about the .exe flasher within wine?
Well I’m happy to meet some gentoo users here.
My gentoo is on ppc, so wine is no alternative.

btcflash? Can’t find that on gentoo. Can you give me a hint where to find the .HEX firmware and if that can work?

  1. question: My 1004 is mounted to a firewire case. Could flashing over firewire actually work?