Upgrade firmware LTR-12101b

vbimport

#1

Hi, I’m italian guy (sorry for my terrible english :bow: )
I have a big problem with my Liteon LTR-12101b.
I try to upgrade my firmware with windows firmware flasher downloaded from Lite-On (LS3J23).
The program run, the led is red/green, and I think that I updated my firmware (pop up the message: succesfuly,etc…)
…and then I clik on “yes”, and I restart my pc.
Windows xp run, but now the O.S. and the BIOS don’t recognise my CD-R liteon and my CDplayer LG!!!:rolleyes:
I remove my liteon and lg run.
I remove LG but Liteon don’t run…is dead ?! :confused:

I put a jumper in a down contact near the alimentation, and the O.S. and my bios recognise my liteon as
liteon LTR-BOOT
My liteon is recognised but it’s closed, don’t run, and the led don’t light.
I download pflash and LS17 dos FIRMWARE with batch MS-DOS from here:
Link
Then I create a floppy with LS17 and pflash, I restart my os in dos mode with win 98 floppy, and I use the disk with ls17.
My liteon was in “primary master”, and I use the batch file for this…

The program run, and the liteon led is red/green…wow…:smiley:
Succesfully?!
…no:
ERROR in ATAPI command. :Z
??? :confused: ???

I try with windows firmware flasher downloaded from Lite-On (LS3J23), but:

ERROR:

Can’t found LTR-12101b firmware: LS00-LS2Z drive!
This flash utility only supports LTR-12101b firmware: LS00-LS2Z

Detected drives:

0-0-0: LITE-ON LTR-BOOT 0024

HELP PLEASE :bow:


#2

What version of the firmware did you have previously?

LS17 won’t work for all versions of the LTR-12101B. I found this out with my LTR-12101B. Also, are there any CD-ROM drivers on your bootable floppy disc?


#3

Also make sure to remove the emergency boot rom jumper after flashing.
It looks like it’s still active.


#4

Hi !

LS3J23 used to be the best FW for LTR1210B. It’s hard to guess what went wrong with your flashing.

Here’s my proposal :

get LS38 [COLOR=blue]here , set an extra jumper as shown below and using PFlash take your drive through the flashing procedure in DOS.
Don’t forget to type the right value :

pflash ls38.bin /pm /np /all - for primary master
pflash ls38.bin /ps /np /all - for primary slave
pflash ls38.bin /sm /np /all - for secondary master
pflash ls38.bin /ss /np /all - for secondary slave

Remove the jumper on rebooting.[/COLOR]


#5

First I Remove the jumper and reboot the system
My Bios, xp and Nero recognise my liteon:bigsmile: LiteOn LTR-12101b
…but it don’t run :confused:

Then I set extra jumper, and I use pflash with Ls38…I remove the jumper and I reboot
…the system recognise my lg and firmware version but it don’t run

I try again with ls38:
A:>pflash ls38.bin /ss /np /all
LiteOn IT CDRW drive flash utility version pre-0.5 date 04/10/2002

VENDER ID : LiteOn
PRODUCT ID : LTR-12101B
REVISION LEVEL : LS38
DATE CODE : 2001/02/

Please wait 35 second …34 …28 …22 …16 …10 …4 ERROR IN ATAPI COMMAND

???

Then I tray with windows firmware flasher downloaded from Lite-On… (3j23 and then 3i23) Now the program recognise my liteon and ls38 firmware… :smiley: I start this:

The program run, the led is red/green, and I think that I updated my firmware (pop up the message: succesfuly,etc…)
…and then I clik on “yes”, and I restart my pc.
Windows xp run, but now the O.S. and the BIOS don’t recognise my CD-R liteon :a


#6

up


#7

If you’re lucky, you’d still be able to find MInfo 1.6 and LtnFlash 1.2.0 using e.g. Google search / Search @CDF.

Try using LtnFlash to flash the firmware onto your drive (with the jumper mentioned above attached to the drive). Then, turn off the PC, remove the jumper, and boot up. You can use the same .bin file you used with PFlash with LtnFlash.


#8

Originally posted by LiteOnGuy

You can use the same .bin file you used with PFlash with LtnFlash.
He-he-he. Are there different .bin files for different flashing utilities ? :confused:


#9

Originally posted by BoSkin
He-he-he. Are there different .bin files for different flashing utilities ? :confused:

I didn’t intend to say that there were different types of .bin files. :o This wasn’t always clear to me, so I wanted to clarify that the same files would work for the different utilities. :bigsmile:


#10

My liteon don’t run.
:confused:


#11

Details? What did you try to do, and what happened?


#12

LtnFlash 1.2.0+ls38.bin
The program run, i see the red/green light on my liteon…then the program displayed this message: “done”
I restert my pc, but Liteon don’t run.


#13

Did you remove the jumper?


#14

yes…


#15

Could you try flashing the drive on a different PC?


#16

Ummmm… NO.


#17

What chipset does your motherboard have?


#18

ASUS A7v
JumperFree PC133/VC133
200Mhz FSB AGP Pro/4X
Socket A Motherboard

VIA Apollo KT133 Chipset


#19

I don’t know what difference it would make, but you could try using WFlash to flash the drive. Follow the directions for WFlash.

Other than flashing the drive on another PC, I don’t have any more ideas.

If these suggestions don’t help, maybe you could post this question at The Firmware Page. I am sure that many people there know far more about this than I do. :wink: