Upgrade Firmware - 411s@811s - problem

vbimport

#1

Pardon my ignorance in this matter…Here’s my problem

I have a 411s@811s via the Z-mod. The drive is successfully recognizes as an 811s. The current firmware version is HS0K. However, whenever I try to flash with a newer firmware version (HS0P, HS0Q), the drive will blink orange. A hard reboot will not fix the problem. I eventually have to resort to reflashing back to HS0K.

Is the something that I’m supposed to do to the binary before flashing?

TIA


#2

You must patch the firmware to remove the EEPROM check.


#3

A couple of things I can suggest.

i) Take your ORIGINAL EEPROM and run the v4 patcher over it. This will patch the EEPROM with the correct checksum generation for you - so it will accept REAL, non hacked firmwares

ii) Try sending it back to a 411S, popping the new, patched EEPROM on, then attempt to put the new, flashfixed version of HS0Q on.


#4

Zebra,

I tried your first suggestion…

It WORKED! Yeeeeeeehhhhhhaaaaawwww!!! I’m in business!

I luv…ahem

Thanks! :bow:


#5

:-D. Wonderful! :cool: