Updating firmware

vbimport

#1

Ok i have a NEC 3520A drive.

I was having some problems with this drive not reading CD-ROMS

Therefore i want to update the firmware, i currently have 1.04

Now i have got the binflash from http://binflash.cdfreaks.com/

When i double click the exe nothing happens…and when i go to a DOS window and type the C:>necflash -dump C:\OldFirmware.bin 1.0.0 command, it shows:

// aspiStartup.LoadLibrary: x7E (126) The specified module could not be found.
// “WNASPI32.DLL” was the “specified module”
// sptxOpen.CreateFile: x2 (2) The system cannot find the file specified.
Error opening SCSI device

OK

also before this i downloaded http://www.micheldeboer.nl/firmware/3520_3.22_RPC+RL.rar

i extracted it and have the .Bin, but dont know how to flash it to the drive, that is why i tried the binflash thing, as i read it flashes the drive with the latest firmware automatically.

Any help would be cool,

thanks.


#2

F.A.Q.


#3

Thank you for your reply…and i have looked at the FAQ’s, but i cannot see a point that is specific to my problems…would you mind showing exactly what point you are pointing out to me?


#4

What firmware do you want to flash to?


#5

Wel firstly i wanted 3.22 from http://www.micheldeboer.nl/firmware/3520_3.22_RPC+RL.rar as that seemed the best one? :S

but as i didnt know how to flash it, i got the binflash which i read had the 1.UA firmware built in…so i thought i would settle for that i didnt know how to flash with the other one


#6

I just flashed with 1.UA and you should have no problem with it. Uninstall your IDE/ATAPI, UDMA drivers by rolling back to the default Microsoft drivers, Flash and restart your system. Any problems let us know.:slight_smile:


#7

Ok i will try that tomorrow when i get home, but what if i encounter the same problem as before? When i double click the binflash .exe nothing happens, is it supose to happen like that?


#8

Get the 1.UA F/W here:http://club.cdfreaks.com/showpost.php?p=948937&postcount=493. Just unzip and select the quiet or riplock removed F/W you want to flash. Just ensure you have the proper drive selected before you flash. Don’t think you will have a problem. Report back if you do. Liggy and Dee have made it pretty simple once you get the hang of it. :slight_smile:


#9

yes that is what i got before…the binflash .exe but as i said when i double click it a window comes up for a split half a second then goes, so basically i cant select anything!

and then when i follow the instructions on the site with the commands, i get the error msg that i posted in my first post in this topic.


#10

Maybe you are not extacting the file properly. When you unzip the file there should be an additional folder with the same name. You have to start the flash from the extracted folder.


#11

Maybe you haven’t got ASPI properly installed or not installed at all. Search on the net for ForceASPI and install it.


#12

… and just to make sure, did you dl the “Win32 GUI” version of Binflash? Might have better luck with that one. HTH


#13

Probably it’s the best solution to use the -scan option BEFORE doing anything else. -scan will probably show you a different value to use for drive identification.

Changed the documentation on the website a bit, maybe it helps the next user…


#14

ooops forgot to come back here and say…thats what sorted out the problem, now i have the 3.22 firmware flashed :slight_smile:

thanks for all the help