Updated firmware on LDW-451S and now I can't play DVDs

vbimport

#1

Hello all,
searched for some answers, but I couldn’t find any… So my drive was burning a lot of coasters so I updated the firmware, and now I still burn the occasional coaster, but I can’t watch DVDs. When I put in a disc it says that it is an “unsupported format” (I tried a number of discs). I notice the device driver in the device manager is 4 years old… but am I right in assuming that that makes no difference? If it does, where can I get a newer driver? Any ideas? Thanks in advance.

I’m running an Asus P4C800E Deluxe, 3 Ghz P4, 2 Gig RAM, regular everything else.


#2

Have you selcted DVD region again after flash.


#3

sounds like a software problem, what are you using to playback the DVD? try installing a DVD playing program like Power DVD


#4

Thanks for the quick replies! THe DVD region is set to region 1 and I am trying it with Power DVD and WMP. Any other ideas?


#5

Go back to your previous firmware for a test to check that the drive still can read the DVDs.


#6

How do you go back to the old firmware?


#7

By reading the FAQ.


#8

Hi Ala,
I see how to Crossflash there, but not how to revert, am I missing something? Should I try crossflashing to the 832S?


#9

No, just read the part of the FAQ I linked to again and try to understand it :slight_smile:

The official flashers will also not allow you to downgrade your firmware (e.g., it will not let you flash the VS0B firmware onto a drive with VS0E). This protection is implemented in the flashing software and works by simply checking the drive name and firmware version. There are two ways to get around this problem. One way to do this is to FlashFix the firmware flasher so that it will not perform the drive name and firmware version checks. Most of the flashers found on the codeguys firmware page have already been FlashFixed! Another way to get around this problem is simply to flash using another piece of software, such as LtnFW or MtkFlash.


#10

Sorry for my ignorance… so I DL’d Flashfix, and just found an old version of firmware, but after using Flashfix, it says “Unable to Flash Firmware”. Any ideas? Should I go to the 832S?


#11

IT WORKED! Thanks so much, I was just missing a step… so should I play it safe, now I’m all interested in the 832S update… glutton for punishment :confused:


#12

To check if the drives still behaves as before you need the same firmware as before. If flashfix does not like you, flash a binary .bin firmware available here with ltnfw and select the update bootcode option when flashing.

Edit: as you solved to problem already, ignore this post