Unrecognised / Unreadable CD


#1

Hi. I’ve agreed with my brother to see if I can extract a couple of holiday video files from a CD of his; but I’m not having any more luck than he was. Some PCs don’t recognise a disk has been inserted, on mine it seems to want to write desktop.ini to it.

Any chance of identifying the original burning software or using the original PC is long gone. He doesn’t think it was unfinished, it used to be readable; and is a data disk I’m told. It’s a CD-R80.

I’ve downloaded and tried various free disk fix type software to no avail, and then uninstalled them. All run in Windows 10. I’m wondering if the Windows drivers get in the way, maybe.

Anyway, anyone any pointers on what might work ?

TIA.


#2

If it were me - who has mountains of drives lying around, I’d keep carefully clean the business side of the disc and keep trying different drives until one of them recognized it. Once that happens, I’d switch to a recovery tool like IsoPuzzle which will attempt to rebuild the disc structure as an ISO - starting with the readable sectors on the first pass; followed by the unreadable ones for as long as you are willing to wait.


#3

Thanks. If I find such a drive I’ll try IsoPuzzle.

(Doesn’t seem to find WNASPI32.DLL :frowning: )


#4

There are a zillion places to download that DLL; just put it in the same folder as the executbale.


#5

Thanks. Not in a position to try again for a few days but I’ll give it a go.

Was loath to download drivers from sites I didn’t know so didn’t trust. I got the impression that it was Nero proprietary, but didn’t find it on their site though.


#6

You can try some of the links in the download section of the Imgburn support web site.
Also, some of Nero’s freebies have the ASPI dll buried in the install files.


#7

Try Badcopy. It can read anything.


#8

Thanks. Badcopy found 2 tracks which I assume relate to the 2 videos, but since it didn’t show any files in the right hand window it wouldn’t recover anything on mode 1. Trying mode 2 now. Taking ages…

Looking grim. Been ages on the first, smaller track. Presently progressed 19.2%, Data loss is 19.2%, and bad sectors 21075. Probably write-off.

Did get the dll so intend to try IsoPuzzle after, but at the rate this present scan/“recovery” is going that’ll be next week.

UPDATE: BadCopy Pro scanned all and recovered nothing. IsoPuzzle denied that the disk existed. :frowning:
Thanks anyway, but I’m open to more suggestions. Looks like it may be a lost cause though.


#9

If you can run linux (doesn’t have to be on a physical machine, you can use VirtualBox), and your CD drive can at least recognize the disc (it will spin up once it does that), I’ve developed some tools for reading very bad discs. Probably somewhat similar to what Badcopy does, but the reading of bad sectors can be attempted in different iterations and on different drives, which definitely helps. Lmk, if you’d like to try them.


#10

Cheers. I may pass the information on to my brother, whose disk it is. I don’t think either of us has a linux installation available, but if the videos mean enough he might be interested. I’ve tried to extract the data but think I’ll hand the disk back to him when I next see him.


#11

@ Tyr,have you already tried IsoBuster ?


#12

Hi. Don’t think it rings a bell. But I’ve passed the CD back now. I’ll pass on the tip, thanks.