UNREAL 2 General Protection faults!

I have managed to successfully copy the play disk and hve installed it but it randomly displays errors such as the following:

General protection fault!

History: UUIConsole::PostRender <- FPlayerSceneNode::Render <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop

Build: Jan 7 2003 18:16:21

OR

General protection fault!

History: UObject::ProcessEvent <- (U2PlayerNetTestController TutB.U2PlayerNetTestController3, Function U2.U2PlayerController.PlayerTick) <- APlayerController::Tick <- TickAllActors <- ULevel::Tick <- (NetMode=0) <- TickLevel <- UGameEngine::Tick <- UpdateWorld <- MainLoop

Build: Jan 7 2003 18:16:21

OR

ReadFile failed: Count=0 Length=1048329 Error=Data error (cyclic redundancy check).

History: ULinkerLoad::Serialize <- TArray<< <- TLazyArray::Load <- FStaticTexture::GetTextureData <- PM_CineT.Sanctuary.SancSkybox_103 <- FD3DTexture::Cache <- FD3DRenderInterface::CacheTexture <- FD3DRenderInterface::HandleCombinedMaterial <- FD3DRenderInterface::SetSimpleMaterial <- FD3DRenderInterface::SetMaterial <- (Texture PM_CineT.Sanctuary.SancSkybox_103) <- FCanvasUtil::Flush <- PrecachingTextures <- Precaching <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop

Build: Jan 7 2003 18:16:21

Has anyone had these problems before ??? I dont think its anythng to do with the copy as I think the game has bug isssues…

PLEASE PLEASE PLEASE can someone help me I am desperate to play this game.

:bow: :bow: PLEASE HEEEEEEEEEEEEEEELLLLLLLLLLLPPPPPP :bow::bow:

Originally posted by Franco_cov
[B]Error=Data error (cyclic redundancy check)

Has anyone had these problems before ??? I dont think its anythng to do with the copy as I think the game has bug isssues…

PLEASE PLEASE PLEASE can someone help me I am desperate to play this game. [/B]

Seems there may be your problem, CRC. It may be your media, how it was done etc etc.

The game is quite solid on my system, but I can save you some suffering. The game isnt what its cracked up to be in my opinion, but this isnt an Unreal bashing post.

How was it done/what hardware?

Hey Savannah,

My error also happens at the last % of the installation, just before the DirectX files start installing. What’s odd is that once the installation abouts there are no files on my PC (or at least the FAT doesn’t think there is).
The installation was sucessful on a desktop Athlon 800, mostly generic parts.
The install failed on a “refurbished” Sony VAIO PCG-GRX500P. Yes, most of the refurbishing done was changing the File system over from NTFS to FAT32.
What do I need to do to the HDD to get iit to install right?
Thanks for the time

This post really doesn’t pertain to CD copying, this is all happening off an original disk and CDkey…

I doubt it has anything to do with the hard drive, that is, unless you are frequently suffering from such errors. If so, the hard drive may ver well be dying.

If not, then the 3rd CD (no protection) stuffing up, seriously seems like it is either a media problem, or a burn problem. Try copying it again, and then try the install.

Also, you said that there were no files left on the hard drive after the installation was aborted, thats because the Install Sheild deleted them becaus ethe installation wasnt complete and thus may not have worked.

I do not think this is CD burning related as I have the same problem. But, only with a computer I built for a friend. My computer never crashes this game. But the same disk I use on mine which works fine crashes with similar errors on my friend’s computer. Our systems are very different. My computer is Athlon 1600xp oc’d to 1700+ with 512 mgs ram, Soyo Dragon Plus MB, Leadtek Ti4600, SCSI hard drives, Liteon 5224a, Plextor 482448a, Toshiba SCSI DVD, Plextor CDrom SCSI 40x.
My Friends is Epox RDA+ Motherboard, Athlon 2500 Barton oc’d to 2800, 512 mgs ram, Western digital 120 gig drive, Liteon 5224a, Leadtek Ti4200.

Both computers have 10 cooling fans. so Overheating not problem. All hard drives are under 6mos old, don’t think failure problems. If you visit the unreal 2 boards you will see that different specs on computers cause this game to freak out. Even the patch does not help. Higher end computers seeem to have more trouble. It does not matter if disk is copy or original. My friends crashes even if install is off original and played with it. This is not a burning issue. Hardware issue. Sorry.

this may help it has for me 100% with general protection faults with UNreal engine build games.

go into your bios : bump up the AGP Voltage from Auto to 1.7 or 1.8

try 1.7 first.

trust me this will not harm your grafix card what its doing is giveing it more juce to breath…

hoep this helps. :o

My english sucks but here we go. In my computer after 4 month with this problem and thounsands of unsusseful tries, in my case the problem was a incompability of RAM. All games with the unreal engine give me the same general protection fault (postal 2, splinter cell, unreal 2, …), then i was almost suicide me ; ) when a friend told that maybe was a RAM problem. Then we try, i had 3 ram 128=384, He gave me a 256 to make a try and guess what, EVERYTHING RUNS FINE. We until drunk some beers to celebrate. Good luck!!!

My english sucks but here we go. In my computer after 4 month with this problem and thounsands of unsusseful tries, in my case the problem was a incompability of RAM. All games with the unreal engine give me the same general protection fault (postal 2, splinter cell, unreal 2, …), then i was almost suicide me ; ) when a friend told that maybe was a RAM problem. Then we try, i had 3 ram 128=384, He gave me a 256 to make a try and guess what, EVERYTHING RUNS FINE. We until drunk some beers to celebrate. Good luck!!!

P. S.: IF THIS WORKS SEND TO OTHER PEOPLE, BYE!!

I had the exact same horrible errors/crashes/computer resets. With Unreal II xmp, America’s Army and Unreal-based games. This is how I fixed it: I have a gf4 4200, so I updated the nvidia drivers to the new 53.03s… they seem to have fixed the nightmerish bugs in 52.16s. Enable vsync in your game options so your card ain’t overloaded making your game crash. If you have an AMD processor and update your motherboard’s AGP driver (which I suggest doing) make sure HyperThreading is off (your processor doesn’t support it) and that no little utility that forces it on like htpatch.exe (SiS motherboards!) is runing in the background. You can use mike lin’s startup control panel (free at www.mlin.net) to clean up your registry of unwanted buggers such as this one.

Also, EAX (sound blaster positioning/echo thingy) is known to cause these crashes too when your video card is not top-notch and a bunch of things are exploding/flashing at once so you may want to turn this off as well for testing purposes. Turn it back on again after doing the suggested changes and see if it causes your game to crash.

That was it. I did that and everything ran great again.