Universal remote only partially works for Panasonic DVD-S1

I hope this is the right forum. Well, it is as the topic says. I tried to set my universal remote to control my new Panasonic DVD-S1 DVD player and it only partially works. Play, pause, stop, and power all work. However, the skip track buttons on my universal remote appear to do nothing and the ff/rw buttons do what the skip track buttons should do. Does anyone know if I need a different code or what? The book listed codes for Panasonic DVD players as 003 and 009. 003 was basically the same as 009, except pause didn’t work. When I changed the code to 009, pause worked but skip track still did not.

some universal remotes have a “learning function” which could be the answer.

Mine doesn’t.

I have never had 100% success with Universal Remotes; some do not have the needed codes, lack memory or the correct keys. Big problems with [U]Liteon[/U], [U]Apex[/U], [U]replayTV,[/U] my Cable Box, and some Panasonic & Sony units. After many tries I gave up. My best luck was with a cheap RS learning remote (did take lots of time and memory ran out).