Unhappy DVD playback

Hi! I have a compaq presario v2000 running XP SP2, which until recently was perfectly happy playing DVDs. However, now when I try to play DVDs on it (in VLC player), the playback is choppy, and the sound is terrible… Although it will occasionally play short parts of DVDs.

Having done a little bit of reading up online, i checked and the DMA is set to ‘if available’, so i don’t think that’s the problem. I have the k-lite codec pack installed, but have removed ‘Power DVD’ which came with my laptop. Also, DVDs will no longer play at all in WMP11, where i get a message about my system settings maybe being wrong (resolution etc.).

Also, recently, when i was burning a Data DVD, the burn process was much slower than usual… This has led me to wonder if it is simply the drive/lens that has become less effective… although it is still fine reading data DVDs.

I have re-installed VLC, on the off chance that this would help. But it didn’t. This is very frustrating, because i know my computer is capable of DVD playback (although i don’t remember the last time i played a DVD successfully)… and it easily plays divx files etc.

Does anyone have any ideas?

sounds like something is interfering with your system resources like a hardware/software conflict or your badly infected with viruses/spyware.

I have AVG running, and run ad-aware now and then, and everything else works pretty reasonably… so i’m inclined to think it’s a hardware/software conflict. Any ideas how i might find out what this is?

Post you system specs give me an idea what your running. First thing you can try is running msconfig by clicking the run on the start button.
Just type in msconfig in the run box. you will see under the general tab Diagnostic Startup. Select that and reboot then try viewing the DVD again. You might have too many programs rumnning at boot and this should temporally help. Let me know how this works.

I know more or less what system processes I have at startup… but i’ll try reigning them in a little, and see if it helps…

Below is a really really comprehensive system spec list (courtesy of SandraLite…).

System
Host Name : MATTHEW
User : Matthew Creber

Processor
Model : AMD Turion™ 64 Mobile Technology ML-28
Speed : 1.59GHz
Model Number : 2588 (estimated)
Performance Rating : PR2866 (estimated)
Cores per Processor : 1 Unit(s)
Threads per Core : 1 Unit(s)
Type : Mobile, Low Power
Internal Data Cache : 64kB Synchronous, Write-Back, 2-way set, 64 byte line size
L2 On-board Cache : 512kB ECC Synchronous, Write-Back, 16-way set, 64 byte line size

Mainboard
Bus(es) : PCI IMB PCMCIA CardBus USB FireWire/1394 i2c/SMBus
MP Support : 1 Processor(s)
MP APIC : Yes
System BIOS : Hewlett-Packard F.0A
System : Hewlett-Packard Presario V2000 (EC190UA#ABA)
Mainboard : Quanta 3093
Total Memory : 383MB DDR-SDRAM

Chipset 1
Model : Hewlett-Packard Company RS480 Host Bridge
Front Side Bus Speed : 2x 796MHz (1592MHz data rate)
Memory Bus Speed : 2x 199MHz (398MHz data rate)

Chipset 2
Model : Advanced Micro Devices (AMD) Athlon 64 / Opteron HyperTransport Technology Configuration
Front Side Bus Speed : 2x 796MHz (1592MHz data rate)
Total Memory : 512MB DDR-SDRAM
Memory Bus Speed : 2x 159MHz (318MHz data rate)

Video System
Monitor/Panel : Default Monitor
Monitor/Panel : Default Monitor
Monitor/Panel : Generic Television
Adapter : ATI MOBILITY RADEON XPRESS 200

Physical Storage Devices
Hard Disk : IC25N060ATMR04-0 (56GB)
CD-ROM/DVD : PIONEER DVDRW DVR-K15 (CD 47X Rd, 63X Wr) (DVD 6X Rd, 8X Wr)

Logical Storage Devices
Hard Disk (C:) : 56GB (9.6GB, 17% Free Space) (NTFS)
BIG_FISH (D:) : 7.4GB (UDF)

Peripherals
Serial/Parallel Port(s) : 1 COM / 0 LPT
USB Controller/Hub : Standard Enhanced PCI to USB Host Controller
USB Controller/Hub : Standard OpenHCD USB Host Controller
USB Controller/Hub : Standard OpenHCD USB Host Controller
USB Controller/Hub : USB Root Hub
USB Controller/Hub : USB Root Hub
USB Controller/Hub : USB Root Hub
FireWire/1394 Controller/Hub : Texas Instruments OHCI Compliant IEEE 1394 Host Controller
PCMCIA/CardBus Controller : Texas Instruments PCIxx21 Cardbus Controller
Keyboard : Quick Launch Buttons
Mouse : Synaptics PS/2 Port TouchPad

MultiMedia Device(s)
Device : Conexant AC-Link Audio

Communication Device(s)
Device : AC97 Data Fax SoftModem with SmartCP

Printers and Faxes
Model : Brother DCP-130C USB Printer

Operating System(s)
Windows System : Microsoft Windows XP/2002 Home 5.01.2600 (Service Pack 2)

Network Services
Adapter : Realtek RTL8139/810x Family Fast Ethernet NIC
Adapter : Broadcom 802.11b/g WLAN

Thanks a lot!!!

Maybe a codec issue since installing K-lite pack…But are you having probs with new and burned DVD’s? try with MPC see if works for you…
Could be your drive going “kaput”…

I mis read your first post. I thought you were having problems with video on hard drive as well as the DVD drive. How does video play right off the hard drive?

Video off the hard drive is absolutely fine… This happened to me once before, and i seem to remember resolving it by doing a system restore… i tried that this time, but for some reason the restore failed, which was frustrating…

Alright. I have run adaware, and i seem to be spyware free. I have also started in diagnostic mode, but the DVD still didn’t playback properly. I have been through my startup processes in startup inspector, and cut out anything unnecessary, still with no luck.

The upshot of all this, of course, is that my computer is running much smoother apart from the DVD playback… But it’s aggravating me! I think it’s probably a driver clash of some sort, perhaps colliding with my ATI video drivers (does that sound reasonable?)… but i have no clue as to how to start fixing it…

What happens with media your having trouble playing? Does that media work in another system. Also would try to see if any firmware updates are available for the drive. It sounds to me like the DVD drive is faulty

Are you having probs playing new commercial DVD’s , burned or both?..
If you can play video fine from HDD then it could be your drive on it’s last legs, or as I stated above “going kaput”…
If you’re having probs with burned discs then explain your process…

Hmm. Well, i just tried playing some video (in data form) from a DVD, and it works fine… It’s commercial DVDs i’m having problems with (and possibly burning - i haven’t tested that properly yet).

I don’t think the drive is kaput - it’s it’s not making suspicious noises when it’s ‘trying’ to play the DVDs, and i suspect it’s a system problem rather than a drive problem. But that’s just a hunch.

Like i said, this happened before once, and a system rollback cured it (i might try that again…). But it would be handy to know what’s making it go wrong.