Unable to update firmware of SH-183L

vbimport

#1

Trying to update a Samsung SH-183L to the latest version (SB01) and I am unable to. When I run winquiry.exe to get the information on my drive everything seems correct, except for the OEM version which shows a 0.

I have manually downloaded the firmware and program for doing the update, but program says that the firmware is not compatible with my drive.

Any Ideas?

Thanks,

Paul


#2

I believe I read somewhere that this drive is a Dell oem drive. In the past, when Samsung has provided oem drives to Dell (the cdrw 252s series), they were finicky about how to apply firmware updates. I recall that you had to use the updater from the Dell website, but could apply newer firmware updates from Samsung. I suggest you do a bit more research and proceed carefully here.


#3

I bought the drive new at bestbuy so it is not an oem version.

Thanks,

Paul


#4

That means nothing really.

What more counts: Which firmware is on the drive??


#5

The update worked for me. I’m just waiting for a region-free firmware now…


#6

According to the (slightly outdated or not) compatibility list available on Samsung website, there are some SATA controllers, where firmware update is not possible. One of those is the VIA 8237 series.
I could not verify this, as there never was a newer firmware for my 163.

Let’s hope, you live that long :wink:

Michael


#7

Thanks.

The firmware that is on the drive is SB00.