Unable to remove virtual drive =(

I had a virtual device set up with daemon tools but decided I wanted to upgrade my current version. Unfortunately I did not have the foresight to first disable my original virtual device when I upgraded, and now after the upgrade I have a virtual device that I cannot mount, unmount, or even remove from my computer. I can’t even go to my computer and disable the device. Please help :frowning:

Have you tried removing it from system devices?
Control Panel/System/Hardare tab or something

yes, all it does is…nothing. It asks to reboot and the thing is still sittin’ there after I finish rebooting. Really annoying :(. And then if I try to disable the device, device manager will freeze.

Ok. No easy way out. Now i have to think :stuck_out_tongue:

So what you did was install a newer version of DT right? And what was the problem that actualy arouse? I never disable the DT’s virtual drive before upgrading. If you want to remove the virtual drive you could just uninstall DT from add remove programs.

When I was upgrading I just installed over the previous directory. After doing that, it sadly did not recognize the virtual drive from the previous version. I uninstalled it and the drive is still there too =(

Have you installed any other software such as Alcohol120% or CloneCD - maybe the virtual drive that remains isnt DT’s. I find it very odd that DT didnt recognise the previous version and that it didnt uninstall correctly.

I am 100% positive it is not some other software’s virtual device…mainly because there are no other programs installed that will create a virtual device.

Originally posted by l1fe
When I was upgrading I just installed over the previous directory. After doing that, it sadly did not recognize the virtual drive from the previous version. I uninstalled it and the drive is still there too =(

Dunno if DT works the same way some other software does, but sometimes, when you upgrade, you need to uninstall in the order of newer first, then older version. Software is sometimes even listed twice in add/remove programs. Try re-installing latest version. Reboot. Then uninstall again. Check in Add/Remove Programs to see whats listed there and if two entry’s are per chance made.

Report back.

there was only one version to uninstall and now I cannot even reinstall since it comes back with an error.

Try cleaning the registry off the DT’s traces. You can use a program like RegistryCleaner for that. Then try installing uninstalling again (hopefully the error while installing will go away after the reg cleanup).

It is the first time i here of DT making of such a mesh.

I can install it again after clearing my registry, but that still doesn’t help with the older virtual drive that still just sits there uncooperatively =(

l1fe can you post a pick of the list from device manager?

Maybe deleting both IDE controllers and rebooting will remove it.

I found the registry entries for generic dvd-rom device and tried to delete them all (specifically listed in the scsi devices). Sadly I cannot modify these regions because…surprise surprise windows is using the devices. currently figuring out how to do it in a windows recovery setting.

I’m assuming Windows 2000 or XP.

Can you not see the devices in Device Manager when logged on as an Administrator and choosing the “Show hidden devices” option. If so, you can uninstall them that way.

Ripping devices out of the registry directly is not entirely straightforward - you have to delete both item you’ve found by searching (which should, obviously, be in CurrentControlSet) and the class key it relates to. You won’t have permissions to manipulate one of those two keys - you need to grant Full Control to Everyone before you can delete the key.

Apologies that this description is very terse - it’s not only hard to describe but it really isn’t a recommended way to do things.

David

The problem isn’t uninstalling the virtual drives (since I can), but it’s that they come back with each reboot. I have logged in as the administrator to rip out the registry entries, but to no avail.

when i had to remove a virtual drive i found that it had installed a virtual scsi controller. And unless that scsi controller was deleted (after deleteing the virtual drive) then it would just come back.

Does your system have something similar (i forgot which virtual drive program the person had though)

Instructions take from Daemon Tools forum.
I guess you could have searched for it yourself… :wink:

http://www.daemon-tools.cc/dtcc/portal/viewtopic.php?t=2287

Latest versions of Daemon Tools allow users to assign any random names for drivers during installation to make blacklisting task for stupid protections much harder. But this also implies that before installation setup must insure these new names will not cause any conflict with other drivers in system.
If user gets driver conflict error during installation then it means that some
drivers with same names are already in memory or on disk.
If some previous version was installed with same names then it is possible old drivers were not removed completely (eg. user did not reboot) or some problem occured during uninstall (eg. crash etc.).
Normally when user removes Daemon Tools via Add/Remove applet in Control Panel and reboots all drivers should be gone. But if something unpredicted happened or user did not use standard uninstall procedure then above mentioned error may happen.
In this case user should follow the instructions below in order to completely get rid of Daemon drivers in his system.
Same steps also should be taken if user cannot uninstall in a normal way
due to some reasons. If you set some random driver names during setup then it is always good idea to write down their names somewhere, so you know what to delete in case of emergency. In the steps below it is assumed that you already know the names of drivers you need to remove
(they are referred to as ‘Daemon drivers’).

  1. Open device manager (SCSI/RAID Controllers section) and delete SCSI controller with name corresponding with name of Daemon driver
    (miniport driver name). If you have problems doing it (eg. system crashes) then start from step 3 (skip steps 1 and 2).

  2. Open device manager (System devices section) and delete device with driver corresponding with Daemon driver (bus driver name). In current versions of Daemon Tools it is ‘PnP BIOS Extension’ but most likely it may change in next versions. Again, if you have some problems doing it, skip this step

  3. Find Daemon driver files in Windows\System32\Drivers folder
    (in Win95/98/ME also check Windows\System\IOSUBSYS folder).
    Make sure your system is configured to display system files (ControlPanel->Tools->FolderOptions->View) in order you can see them. Delete Daemon driver files.

  4. In WinNT/2000/XP/2003 open registry editor and check HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services for entries with same names as Daemon driver files. Delete these keys.

  5. Reboot your system. If you executed steps 1 and 2 then you don’t need to do anything anymore. Otherwise proceed to next step.

  6. Go to device manager - you may see some device with yellow mark.
    This is most likely Daemon device which cannot start because it’s drivers are deleted. Delete this device from Device Manager.

The same procedure may be used also for complete removal of Alcohol drivers from system.

I went into my Device Manager, scrolled to SCSI/Raid controllers, and uninstalled both of them. All of the virtual drives in My Computer then disappeared, and I could finally delete some images I had mounted that I couldnt previously.

Hi !
I deleted the whole driver pack that i found by manualy open the install/setup package of virtualdrive (10).

I copied and pasted the file (SYS, DLL, INF, OCX and so on) names (like the file: “Fvdscsi.inf” in to the search option of windows and found the files in “system” or “system32” etc.

After that i delted manualy all VCD-files not removed by normal uninstall.

I used the following search string:
Fs*.dll; vdr*.; CDIO32X.VXD; RCACHEX.VXD; fvdscsi.sys; fcdabus.sys; Fcdabus.inf; Fvdscsi.inf; VDI08X.dat; VPlay801.exe; fsRamDsk.*

Then i proceed to the registry and could delete the SCSI entries like describes above…

The ugly Virtual CD was gone after that… :slight_smile:

Regards & sorry for my poor english
Superblond

I’m also having this problem and I couldn’t really follow those instructions. I tired installing 3.47 of Daemon Tools on Win XP and in the middle of installation it gave me a blue screen of death. I installed it on other computers with Win XP and this never happened before… The problem is that it created a virtual drive already even though the installtion didn’t complete. I tried removing it by opening daemon tools but it said no language support so I just deleted daemon tools. I couldn’t find the thing to uninstall it. I then removed the device with device manager. THe problem like that guy is having is that the device comes back every time the computer restarts.

The instructions from Daemon Tools aren’t really helping because I can’t find any of the files or anyhting. Under SCSI/RAID controllers there is only a thing with this name “D347PRT SCSI Controller” I don’t know if this is the virtual drive controller or not and I don’t want to just remove it in case it’s soemthing else. Under system devices I did find ‘PnP BIOS Extension’ but I’m afraid to remove that too. Why would it be called bios extension? Is it really what I need to remove? And as for deleting Daemon Driver files, what are the files? I can’t find those either, even with that search string the guy above me used. It’s as if none of the stuff applies to me…

I can’t reinstall Daemon Tools cuz it must think it’s still installed. I probably need to delete soem registry keys or soemthing… But which ones? And it’ll probably just give me the blue screen of death again and create another virtual drive that I can’t remove. Should I try installing 4.08 and remove the drive? I remember I tried installing 4.08 before and it wouldn’t work, but that was on a diffferent computer that also had WinXP. It just kept telling me the computer needs to restart so the thing could initialize over and over. SO I installed 3.47 and that worked beautifully. Not on this comp tho!!!

Awwright!!! Never Mind, I figured it out!!! :clap:

The daemon tools forum has even better instructions now on how to remove the dirvers. These instructions actually have the names of the files I need to delete if it installed a default named driver. And as it turns out, yes, “PnP Bios Extension” is the thing to remove. And “D347PRT SCSI Controller” is also the correct thing to remove.

Better Isntructions