Unable to read DvD+Rs and DvD+RWs on a Toshiba SD-6265 drive

vbimport

#1

I have a HP z5102ap laptop that came with the Toshiba ODD SD-6252 DvD ReWriteable Drive. For some reason, the drive is unable to read most of the DvD+Rs(Imation | Maxell). However it is able to read generic DvDs like original movies and software DvDs. It also works fine with CD-R and CD-RWs. I have not tried buring DvDs with the drive.

The Drive has the latest firmware installed. It also has the right driver and an additional software called Sonic Drive Letter Access(DLA) installed. DLA is a software that allows drag and drop burning in windows explorer.

The problem is that when I insert a DvD+R or DvD+RW, the drive seems to read for a few seconds, then stops. Nothing changes in windows explorer and no error messages too. When I double click on the drive, explorer just shows an empty window. The DvDs that I use are working DvDs and are able to be used in my desktop.

I would appreciate if someone could suggest a way to fix that annoying problem. Thanks for your time!


#2

Do you have Alcohol 120% installed by any chance?

Personally I don’t like Sonic DLA. The only app of this type I used with success was Roxio’s DragtoDisk. Now I prefer to use none of them.

Perhaps you should disable DLA & then try.


#3

Thank you for ur reply.

I’ve tried disabling the DLA and reading the media. But the media is still unreadable. I believe Sonic’s DLA is causing the problem.