Unable to properly play Audio CD's created using Exact Copy on Sonic

I also posted this to the main Optical forum but since its related to a Philips drive figured I’d post here to.

This is real strange problem and I am pulling my hair out not mention wasting blank CD’s. I am working on a friends computer because when copying audio CD’s with Sonic Recordnow v7 using the Exact Copy feature it burns fine and plays fine on the computer but I get different issues when playing the disk on different external players. Car CD players will play all the tracks but always display just track 1. If you go to track 2 or 3 the display goes to that track and then back to track 1 yet still plays the track you chose. On a newer Panasonic Home stereo it will only play track 1. If you go to any other track it just sits at that track number and does nothing. On my home Panasonic home DVD player it will display the track you are on but the time counter will only count when on track 1. If you go to track 2 it plays fine but the counter never moves past 0000. Freaky thing this happens only on one of the computers with Sonic on it. On my computer the Exact Copy feature works fine. Up until a few weeks ago his machine was doing it fine but for some reason just stopped. I have tried this with different brands of disks so its not the disks. Checking Disk Info on the burned disks shows that they are closed and everything else. Compared the burned disks against the original disk and all Disk Info is identical. Session 1 and Closed and all that stuff. The machine has a Philips 8701 burner in it which I just flashed with the Benq 1640 firmware and that didn’t make a difference. Same problem. If I create a CD using Sonics Audio CD for Car or Home option instead it works perfect. But it always worked fine with Exact Copy before. What the hell can be wrong. Oh and the computer is running WinXP with SP2 if that helps.

Thanks in advance