Unable to Initilize or Finalize DVDs on LG LRH-880

As of late I have been having some problems with my LG LRH-880 with regards to Initilization and Finalization of DVDs. I have tried several discs, including DVD-Rs, DVD+Rs and DVD-RWs to no avail. I have done a soft reset (hold power for 5 seconds), I have done a factory initialization (through the Home menu). I have also done a hard reset (unplug the device, wait and re-plug it back in) so that it was as if I had just purchased it and set it up. It can still read DVDs (finalized or unfinalized) and play them.

Up to yesterday it was working fine, I was able to do anything that it could do normally. It could have been a partially bad spindle of DVDs but I tried from two separate spindles (one of which was unused) but after losing several DVDs I decided to look elsewhere for answers. The very last action I did before trying to copy a file was edit it.

Any help or information on this issue would be greatly appreciated. I have also emailed LGs support and am waiting to hear back from them.

Thanks.