Unable to deactivate DMA in win98SE

vbimport

#1

I have a Liteon 40x12x48 CDR/RW writer installed on an AMD PC
running Windows 98 SE. The problem is every time I shut down Nero Burning ROM, Nero crashes with a kernel32.dll error. The solution, according to Nero is to deactivate DMA.
Problem: When I uncheck the tick mark for DMA in device mgr. for the Liteon writer and close the dialog box, it comes right back.
In other words, I cannot “uncheck” DMA access for this writer and Liteon’s website offers no clues. How can I deactivate DMA then when I can’t do it from device mgr.? I have other burning software
including Video Pack 5 which may be preventing me somehow from removing the DMA access; any ideas anyone??


#2

You can turn off DMA in the bios forcing the device to use pio mode.

Look for its usually called “intergrated peripherals” and look at the primary and secondary settings their most likley set to auto so select PIO mode or set Ultra DMA mode to disabled and that should do it.

It’s far more likey that theirs nothing wrong with Nero or the hardware just that Win98 itself is the source of the problem.


#3

Disabling dma isn’t a good idea.

As rocky already said. Probably its a typical M$ Win98 error.
I would try reinstalling nero and aspi drivers and so on. if that doesn’t help -> Reinstall windows.


#4

Switching from DMA to PIO is not recommended. The kernel32.dll problem explains the problem in the name itself. Its something in the O/S and its part of the core of windows. I would heavily suggest a reinstall. Especially with a kernel.dll problem, othe rthings can go haywire. Back when I had 98 I reinstalled once every month just to keep it healthy.