Unable to burn a dvd using any burning software in ubuntu 11.10

vbimport

#1

A few weeks ago I was running Ubuntu Studio 10.10 amd64 and was able to burn dvds successfully with both Nero Linux 3 and Brasero. My dvd drive is an Iomega internal IDE that supports +/-/RAM discs. I recently upgraded to Mythbuntu 11.10 amd64 which uses the XFCE desktop instead of Gnome and while I can still read any format of disc with my Iomega drive, I can no longer burn any discs. I know this is a software issue because I just burned a dvd prior to making the upgrade.

I’ve tried burning an iso with both Nero and Brasero and both end with an error while burning the lead in. Nero exits with a “illegal disc” error. I’ve used dvd-rw (maxell), dvd-r (verbatim), dvd-ram (verbatim) and nothing works. I’ve also tried selecting the video dvd option in Nero and manually selecting the .ifo, .bup and .vob files and it still ends in an error.

I can’t even successfully erase a dvd-rw disc. It will display the progress indicator as if it is erasing the disc and completes the operation without any errors. Unfortunately when I attempted to burn an iso to a disc that I had just erased I tried reading the disc after the error occurred and the old data was still on it.

Any idea what is happening? Is this a driver issue? What was changed relating to cd/dvd drives between ubuntu 10.10 and 11.10?

EDIT
I forgot to add that I also installed a new SATA hard drive prior to making the upgrade. I have 2 IDE devices (master hard drive, slave cdrom) and 1 SATA device (hard drive) and I boot from the IDE hard drive.

Here’s the output from “lshw -C disk”

   *-cdrom
       description: DVD-RAM writer
       product: DVDRW4224INQ-D
       vendor: IOMEGA
       physical id: 0.1.0
       bus info: scsi@0:0.1.0
       logical name: /dev/cdrom
       logical name: /dev/cdrw
       logical name: /dev/dvd
       logical name: /dev/dvdrw
       logical name: /dev/scd0
       logical name: /dev/sr0
       version: A110
       capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
       configuration: ansiversion=5 status=nodisc


#2

Hi and welcome to the forum :slight_smile:

To be sure that is a software issue, can you try to use ImgBurn with WINE? Here there is a nice guide about how to do :slight_smile:


#3

In order to install WINE I’d have to install 500+ mb worth of packages and I really don’t want to mess with installing and then uninstalling WINE. Instead I booted a livecd of Puppy Linux and tried burning a data dvd with pburn. I used the Nero quick-erase feature on a different computer to blank the dvd and then burned a single file to the dvd using pburn. Everything was successful. I then tested the dvd on a different computer and it worked perfectly.

This bug is clearly related to Mythbuntu or XFCE because I’ve never had any problems with this cd/dvd burner before. I’ve attached the log file from the last dvd-rw that I tried to burn with Nero. One interesting note regarding the log is that it lists the media manufacturer as ritek when it is actually maxell. Not sure if maxell is just a rebranded ritek disc.

Disc Manufacturer ID: <ritekw>

Log.txt (9.28 KB)


#4

Not a linux user, like keeping my hair too much for that, but can tell you about the Ritek/Maxell thing. Ritek is the name of the manufacturer, Maxell is just the brand.
Maxell stopped producing their own optical disks in 2008, and buy from other sources.


#5

[QUOTE=laserwired;2614160]In order to install WINE I’d have to install 500+ mb worth of packages and I really don’t want to mess with installing and then uninstalling WINE.[/QUOTE]

There is a general agreement about Linux being a lot better compared to windows when installing and uninstalling software, i.e. no mess in registry or in the operative system. BTW, I agree with you that if possible is always better avoid to install useless stuff :iagree:

However, it seems to me a bit strange that to install wine you need 500+ MB :eek:

WINE package is only 20 MB, and even if it will require some dependencies to be installed I can’t believe that 500+ MB of data must be installed :eek:

There must be something wrong


#6

Mythbuntu uses the XFCE desktop instead of Gnome. I’m guessing that the majority of the required packages are related to Gnome. I ran “apt-get install wine1.3” and a message was displayed stating that over 500mb would need to be downloaded. Since pburn clearly works with my dvd burner I know it’s not hardware related. I’m attempting to port pburn to Ubuntu 11.10. Since it worked in Puppy Linux I’m hoping it will work in Ubuntu.


#7

Obsolete burner, so the used media counts here.


#8

[QUOTE=chef;2614659]Obsolete burner, so the used media counts here.[/QUOTE]:iagree:
It’s time for a new burner. The media you are using is not supported by your Iomega (a rebadged LG 4040 burner).

BTW, take your time and browse this great forum for a while. :flower:

dvdrw_a110_speedsettings.txt (2.44 KB)


#9

The problem isn’t the burner or the media. As I mentioned in my first post I was successfully burning the same media with the same burner using Nero Linux 3 and Brasero in Ubuntu Studio 10.10. It was only after I upgraded to 11.10 that I began having problems.

I don’t usually burn dvd-rw discs but since I didn’t want to continue creating coasters I decided to use the only dvd-rw disc I had (and granted it is rather old) for testing purposes. I generally use Verbatim dvd-r 16x discs and have never had a problem using them with this burner. I understand that it is an old burner but I had never encountered an “illegal disc” error in Nero Linux 3 until after the upgrade.

I finally gave up on finding a gui to burn discs with and have resorted to the command line. For anyone else who is having the same problems in Ubuntu 11.10 you can use the following commands to burn an iso image. I successfully used the applications below to burn iso images to dvd using my Iomega burner and a Maxell dvd-rw disc.

sudo apt-get install growisofs
#blank the disc
dvd+rw-format -force=full /dev/dvd
#burn the iso
growisofs -dvd-compat -Z /dev/dvd=/path/to/dvd.iso 

#10

There are different revisions even fro media like CD-R and CD-RW. CD-RW is a tricky cause because of the not-interchangeable standards.

Older burners cannot deal with UHS CD-RW, eg.