Ultra DMA on DVD drive freezes computer

I just purchased a new LG DVD/CDRW ( GCC-4520B) and a western Digitial 60 gig drive. The system board supports up to ULtra dma 33 and both drives are detected and utilize this mode of dma from the bios. The hard drive works great i just mention it cause it seems relevent.

I can read and explore the dvd drive, and the harddrive works no problem however when i try and play a DVD or Burn anything the HDD light comes on and the system stalls indefinatlly. I have go into the Controller in device manager and change the DVD to “Pio only” after the reboot to be able to use the drive, obviously this makes dvd playing very choppy burning could be slower but at least it works.

Does anyone have any suggestion for what else i can try to get the drive to operate properly in Ultra dma mode, the weird thing is that when i start the computer the drive will read the disk and i can even explore its contents but once i launch either nero or powerdvd and try any signifigant use of the drive everything fails.

Hi, and welcome to the forum.

  1. What IDE drivers are you using? What OS?
  2. Is your HDD and optical drive on the same cable?
  3. What kind of cable are you using (I’m assuming that it’s an old 40-conductor cable, judging from how you say the HDD is limited to only UDMA-2)

The chipset for the board is the ali m1541 and i’ve downloaded the latest drivers, 2.05 from ali’s website. I’m using windows 2000, i’ve tried the harddrive as master and the lg dvd as sec-master, i’ve also tried them on the same cable, it doesn’t seem to make a difference.

At first when the drive was in ultra dma mode you would open my computer and see the name of the cd, but the icon would always be generic, it wouldn’t have reconginzed it was a dvd, and when you went to read the drive you got an “… i/o device error” you had to take the dvd out of the drive and restart before you could read any disks.

On the advice of another post here i removed the drive, and the controllers from device manager and had them reinstall themselves, that worked in the sense that now i dont’ get the “i/o device error messgage” the icon on the cd rom changes to the powerdvd one and i can explore the cd itself. It’s just when i actually launch powerdvd and try and play the dvd that it freezes, or when i try and launch nero and it’s “scanning for recorders”.

I tried an 80 pin cable and the hdd worked fine, but when i connected it to the dvd as well they both failed, as did the dvd when i connected the 80 just to it, right now i have both the dvd and the hdd on seperate 40 pin cables as there was no advantage in using the 80 pin, i was just messing around by trying it.

it doesn’t support DVD , just a burner, but it does the same problem ! , the HDD is lighted and the CDRW is like gone, restarting and it’s back.

but listen ! , u using WINXP right ??

try turning off AUTO PLAY !

START > RUN > Gpedit.msc > USER CONFIGURATION > SYSTEM > Turn off Auto play, it’s to the right there down,

i think it worked for me, just tried like 20 times and didn’t had the problem, TRY THAT

did u flash it or anything ???

did u did anything that could be causing to that?

any hint could help me too understand what went wrong after awhile

Its windows 2000 actually, and the drive was like this since i put it in, i just tried a lite-on and it does the same thing so it seem to me it a hardware conflict with the motherboard ide and the drives themselves when in ultra dma mode 2.

Nothing was reflashed, there is no firmware upgrades for the lg

Be sure that the drive is correctly recognised in the BIOS.

same problem with NEC2500A, Win XP. MSI KT3 Ultra MB (Via KT333 I believe)

Anyone fix this problem? There ARE compatibility problems between manufacturers. Some combinations of drives just do not work. In which case you put each device on its own cable. Maxtor hard drives cause problems with western digital hard drives. Switching master/slave sometimes fixes it, sometimes not…

LG seems to have some weird problems… IE put in a disk and all the files do not show up. swapping master/slave sometimes fixes it.

Sometimes in a system, software drivers which gets loaded early sends inquiry to the device which confuses it and later on locks up the device… Having a fresh operating system installation with nothing else running, IE no other devices, CD Roms, modems etc might help you track down the problem. My LG was getting confused and using DMA mode 1 which used to cause read problems with the device, I just assumed the LG was like that. Now on a new system it says its a DMA mode 2 device and works better.

Complex hardware software problems are very hard to diagnose and only option is to go to a fresh bare bones system and go on from there. So if it does not work all by itself without a lot of other programs running, You know it just wont work.