Ultra DMA issue with W2K

vbimport

#1

My issue is with W2K using PIO mode for my ATA100 Maxtor 30G drive.

I first noticed the problem when my Liteon 48X drive was always going into "burnproof" mode. It would happen so often that the drive drop to a lower speed and even then it would still occur. I was concerned that the drive might have a problem, but I went looking for other issues first. I thought I might have too many apps open, so I did a clean boot and tried again. Same crappy performance. Then I took a look at my hardware settings. I have two drives, an older 13G Quantum as Primary Master, and the Maxtor as Primary Slave. The Quantum shows up as Ultra DMA mode, but the Maxtor showed up as PIO mode (explaining the sloooow performance). Both devices have "use DMA if possible" selected. To test to see if this was the issue, I did a burn with the source data coming from the Quantum. Success!! So I could tell that the Liteon was fine, it was a question about the Maxtor. So I tried to find out if the Maxtor was ok or not.

I also happen to have a dual boot with Win98 (that I rarely use, but it is handy sometimes) and I tried using that. I checked the DMA boxes on the hardware config, rebooted, and bingo the Maxtor was working fine for Win98 (tested it with some drive benchmarking software on both W2K and Win98). When I rechecked W2K, it is still showing up as PIO and working slowly. So this tells me that the drive is likely fine and the real issue seems to be W2K not configuring the Maxtor as Ultra DMA like it should. BTW, I checked in the BIOS and it is being detected as a drive that supports DMA. I looked on Maxtor's site and found that there had been an issue with ATA100 drives and W2K, but that SP2 for W2K had fixed it. Well, I have SP2 and it is not fixed.

So sorry for the long message, but I wanted to give the full background. Any ideas how I get W2K to set the Maxtor to DMA? It is driving me nuts.

Thanks,


#2

Try removing the drive in Win2k, from device manager, reboot and let Win2k re-detect it. I’m assuming that you have the DMA switched on under the primary IDE controller.


#3

He meant uninstall the busmaster controller (whether VIA, Intel, etc) then the inidividual IDE controllers. Then restart your PC. Go back to the device manager and make sure that DMA is ticked off, and restart again, now all your devices that is capable of doing UDMS should do it now

Hope this helps
DFourthHorseman