Ultra DMA and PIO

vbimport

#1

I Posted a while back that I was having buffer problems and unusally long rip and burn times, and I was told to check my atapi settings in control panel. well, I still have the same problems. I switch to ultra DMA, uninstalling the primary and then secondary drivers. but the primary keeps switching back to PIO mode. Any ideas on how I can lock it in DMA?


#2

Here’s the step by step :

Slow reads & PIO mode!

Go to

  1. My Computer

  2. Control Panel

  3. System

  4. Hardware

  5. Device Manager

  6. IDE ATA/ATAPI controllers

  7. Open the installed IDE channels (Primary and Secondary)

  8. Click on Advanced settings

  9. You will see the transfer mode. If any are PIO you need to un-install the channel (right click and choose uninstall) and re-boot. Windows will reinstall the device and return it to DMA mode.

  10. Be careful when using this procedure because if you have an older hard drive or storage device that does not support DMA you could corrupt your data.

http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

Step by step /with pictures.

DMA Transfer Mode


#3

Here are 2 links for you to look at.

This one is here on CD Freaks.

However, this one is more complicated & you might need to feel a bit more brave as it involves registry editing.