Ulead Movie Factory: No Sound

This isn’t the normal problem that lots of people seem to have (no sound on the written DVD). My problem is that I get no sound when previewing in Movie Factory. (When the DVD itself is written and played, it’s fine). Not having any sound when previewing makes accurate placement of chapter marks impossible. Anyone seen this before?

  1. Which version are you using?
  2. Is this the trial download?
  3. Is the audio AC-3?

I’m using version 4.0.

It’s not a trial - it’s a genuine retail copy. In fact, the sound worked OK when I was using the trial, but not now I’ve actually bought it!

Yes, the audio is AC-3, 2-channel.

Hmmm… have you got the update packs installed?

There’s a listed AC-3 issue with WMP, but it might be worth installing these if you haven’t already done so.

OK, thanks for the suggestion. I downloaded and installed the patch, but the sound is still missing.

Looks like this isn’t a problem anyone else around here has seen. If I ever get to the bottom of it, I’ll post a follow-up for the benefit of anyone else it happens to.

Just a thought: are you editing on-disc or loading MPEG2 into DVDMF…?

I’m loading MPEG2. The DVD source was given to me by a friend (a Pink Floyd concert recorded from the TV), and lacked any chapter marks, which I want to add. So I copied the DVD to hard disk, then used VideoReDo to concatenate the VOBs into a single MPEG, which was then loaded into DVDMF. My only use for DVDMF is to set up chapter marks and menus, then create an ISO image.

I’ve just sent a question to Ulead tech support about this, and am waiting for the response. In the meantime, I was browsing the Ulead forums and it looks as if perhaps DVDMF simply cannot play AC3 due to a missing codec (licensing issues, perhaps?)

If you try using DVD Decrypter in IFO mode (File Splitting set to none) to rip the title and then load this into DVDMF, is there any difference? I’ve used this with AC-3 recordings and it works fine in previewing.

I don’t think I understand how to do this. I tried DVD Decrypter’s IFO mode, and checked the File Splitting was set to none. I ended up with two files: VTS_01_0.IFO and a single enormous VTS_01_1.VOB (4.3GB), but when I tried to import that into DVDMF, I got the error message “Failed to read DVD information”.

On DVD Decrypter’s IFO settings, I have the following checked:

  • Select Main Movie PGC
  • File Splitting: None
  • Copy IFO File
    • Remove RC Protection
    • Remove RCE Protection
  • Patch M2V Timecode
    None of the other options are checked: should they be?

Thanks for trying to help me out on this - I really appreciate it.

(NB. no response yet from Ulead tech support).

You’re doing the ripping stage correctly. You should get a single large .vob which is actually an MPEG2 video file and comprises the main movie/title. You can even just rename the ‘.vob’ file extension to ‘.mpg’.

When you try to import into DVDMF, its naming scheme is a bit idiosyncratic but seeing as your DVD title is now a video file, can I just check you are using this option:
.


Ah, right. After ripping to the single VOB, I had tried both the “Add Video Files” and “Import DVD-Video” option. The “import” function reported “failed to read DVD information”, and the “add video files” option said “file format mismatch”. However, once I changed the suffix from VOB to MPG, the “add video files” option worked - it successfully loaded up the data. But there was still no sound :frowning:

I just did another test using a DVD where the audio is mpeg-1 rather than AC3, and this time DVDMF did play the sound. So I think this has to be something specific to AC3. I found an old thread on Google Groups where someone said that Movie Factory Standard Version (which I have) doesn’t support AC3, but that the Disc Creator version does (although they were talking about version 2; I have version 4). Have you heard of that?

OK glad the import worked…

The DVDMF “Disc Creator” being the only of the two versions to handle AC-3 was certainly an issue with the early ones, but IIRC it wouldn’t handle it at all, both with previewing and after burning. Anyway, I’m almost certain that both v.4 Standard and -DC versions were stated as having AC-3 handling as a common feature.

Still no response from Ulead tech support. In the meantime, I’ve found a workaround: use VideoReDo to find the chapter positions and write out a chapter mark file, then manually set the chapter marks in Movie Factory by absolute time rather than by watching and listening. Not ideal, but it works. Thanks for your help.

Just thought I’d report on the final outcome, in case it’s any help to others. After much exchange of emails with Ulead technical support, it finally started working after doing the following:

  1. Uninstalled Movie Factory.
  2. Downloaded and ran this special program:
    ftp://ftp.ulead.com/pub/Updates/DVDMovieFactory/4/tbyb_uninstallpatch.exe
  3. Reinstalled Movie Factory.
  4. Installed the latest patch (from http://www.ulead.com/tech/dmf/dmf_ftp.htm).

Once that was done, AC3 sound now works in Movie Factory.

That’s great that you got it sorted, and many thanks for reporting back! :flower:

I just got a Sanyo Xacti CG6 camcorder. It came bundled with the Ulead DVD Movie Factory 5 and for some reason the video content must be uploaded to a special file Sanyo_Pex before I can import them into the Movie Factory. When I imported them to the Movie Factory the sound plays fine, as it does in QuickTime but when I went to the preview pane, no sound. Unfortunately, I can’t get direct e-mail support from them, as they informed me that bundled software doesn’t get free support (gee thanks), but I’m welcome to try to self help. Anyway, evidently, some of the problem seems to be that this is MPEG 4 technology, and they said I probably don’t have the right CODECs to make this work, but I have to research it on my own. I’m lost without a clue!

Preview comes without sound in many many apps.