Uh-oh..computer stuffed after FW upgrade

please help :bow:

i have a lite-on 812S. couple of days ago i upgraded the firmware to US0Q match more media (not a hacked, this was one of the patches from liteon website. i didn’t use any patching utility because it was just an .exe file). the patch appeared to go fine, it completed and asked to reboot…since then, my computer reboots continuously - i.e. just when windows finishes loading it loops back to bios. ack!

i searched through these forums first and read through this and this thread but haven’t been able to fix the problem. i tried killaspi, i tried using safe mode and unistalling/reinstalling the hardware and the IDE channel drivers, still reboots…
windows starts fine when the 812S is unplugged from the system, so i was able to get into the control panel uncheck the automatic reset thing which win2k does. then i was able to see this error message before having to hard-reboot again

i searched on the msdn for the error code but just found stupid useless answers like

Check the Microsoft Hardware Compatibility List to verify that the hardware and its drivers are compatible with Windows 2000. For information about the hardware, contact the supplier. If you are installing Windows 2000 for the first time, check the Windows 2000 system requirements, including the amount of RAM and disk space required to load the operating system. Also, check the Hardware Compatibility List to verify that the system can run Windows 2000. (what!)

does anybody have some ideas i could try (short of reinstalling windows)? :confused:

Does the BIOS detect the drive properly?

Try swapping your drive from master to slave or slave to master depending on it’s current position.

This stop error (26) usually stems from trying to read a corrupt CD or DVD. Occasionally it is caused by conflicts among drivers and programs that mess up the CDFS (CD File System). CodeKing’s suggestion is as good as any, but here are a few more:

  1. The firmware could actually be incompatible with the Windows 2000 CD driver, CDFS.sys. A repair install of 2000 or a fresh install may be the only hope. If that doesn’t work, an upgrade to XP might be in order. You could also uninstall the drive, reboot and select “Last Good Boot” from the boot options.
  2. Try installing the drive on another computer running Windows XP and see if it is recognized properly or if it generates the same error.
  3. Windows 2000 & XP both constantly check for corrupt system files, so that cause is not too likely. For example, cdfs.sys, the IDE driver files or some other driver that is loaded at boot is corrupt and could be generating the error. Just uninstalling the device or IDE driver won’t fix this, because the driver files are not reinstalled from the Windows system setup CD. The system just keeps using the driver files in the appropriate system directory (System32, etc.). See item 1 above.
  4. Take the offending optical drive out of the boot sequence, if it is in it. Mostly people have a boot sequence of the floppy (A: ), the hard disk with boot partition (C: ) and then the first CD drive (D:, so you can boot from the original system setup CD if needed).
  5. Disable all unneeded programs that are run at boot, like Nero InCD, anti-virus software, etc using MsConfig.

@CodeKing, Could this be another symptom have having multiple registry references to the same physical drive? This problem is rare and usually goes away after a reboot or two at most. (But it did happen to me once using a firmware from the Lite-On site and there are also previous threads in this forum about it.) No one has mentioned the stop 26 error before to my knowledge, though. That’s why I think it is good practice to upgrade the firmware, uninstall the drive and then reboot.

@jabloomf1230
Good post :). I’ve also explored the idea of rebooting before and after flashing, to avoid this issue. It’s happen to my system once as well, but I have flashed hundreds of times, so it has to relate to the state of the system at the time of the flash.

@C0deKing

Here’s an example of the “temporary lockup on reboot after firmware flash” problem:

http://club.cdfreaks.com/showthread.php?t=108174

Here’s another thread that describes a problem that sounds similar to problem stated above in this thread. The solution was to use the generic Microsoft IDE drivers, rather than using the IDE drivers provided with a specific brand of motherboard (in this case, an NVidia NForce):

http://club.cdfreaks.com/showthread.php?t=109240

:cop: I had the same problem. The only solution was to can Windows 2000 and go to Windows XP. There is something buggy in Windows 2000 that does that once in a while. Files get corrupted or turn up missing…go with XP. It’s much better especially with SP2!!!
Just my opinion!!! :slight_smile: :bow:

:stuck_out_tongue: ok it’s fixed now

thanks for the help guys! :iagree:
this is a very useful forum, been lurking here for a while and i have solved many problems just by reading here…haven’t needed to ask for advice until now

so - i tried C0deKing suggestion and i have no idea why this worked, but heres the low down:
unplugged master and slave on secondary IDE channel and just boot up the 812S as lone master. this worked. put the slave back on, and all booting normally again.
i saw that blue screen about ten times before trying this, so it can’t have just been a few reboots needed for the problem to “fix itself”. it must just be some weird windows thing shrugs (anyone care to explain how this could make any difference, because i don’t understand at all)

one quirk i noticed, i had the drives set as V: and W:, and the procedure above reset all these settings (so they were back as E: and F: ) and i had to change the letters again - well that worked fine. but i also had to recheck that “Enable digital CD audio for this CD-ROM device.” box (i have digital speakers and can’t hear CDA playback unless this box is checked). i reenabled this for the slave drive no problem, but if i check the box for the 812S i get that same blue screen as soon as i click “OK” :confused: i wonder if there is an indirect way to enable this checkbox maybe by a registry key or something?

It just forces Windows to completely re-install the driver.

Not sure what the story is with the digital audio problem. Hopefully someone else can help you with that. :slight_smile: