UDMA MODES DROPPED FROM 5 to 2

vbimport

#1

History:

June: Built new system and installed PIONEER A07 & PLEXTOR 52/24/52A.

IDE controller reads UDMA MODE 5 on both Primary and Secondary.
Nero’s burns cd’s in 2 minutes, and dvdrs in 12-14 minutes.

Only NERO recognizes both plextor and pioneer.
However needed cdrwin and stomp (.img)
Found corect versions and installed.

Current:

Ok, so i went to burn a cd and it took 5-7 minutes, checked IDE controllers and they had both dropped to UDMA 2!
I attempted to remove both stomp and cdrwin to figure out who was the guilty party but UMDA mode is STILL stuck on 2!

any ideas?
Many thanks in advance

tb

ps: i did read that perhaps you should remove the ide controllers from hardware devices and reboot but i am unsure about that.


#2

Update: Ok, i have tried everything I can think of, i’ve removed all burning apps, aspi drivers, everything relevant.
Tried installing new aspi drivers with no success, tried FORCEASPI no success.
In Nero Infotools CD/DVD Speed the plextor fails at 27.8x with a write error.
Currently I can write at 16x that’s it.

I un-installed the drive, the driver, un-installed the atapi/ide controller, nothing.

Tearing out my hair here!

tb


#3

UDMA2 is plenty fast to burn CD’s at 52x.

I’d check that cdrwin & Stomp haven’t installed their own aspi layers?
What can they do that nero can’t?

I switched from CDRWIN to Nero years ago, because nero was (despite being bloatware) easier to use & more functional, hence better software.

Most CDRW/DVDRW drives are still stuck at UDMA2.

Only HD’s will ever be UDMA5.


#4

Um, although I mention UDMA modes my problem is the SPEED that the burner is writing at.
Its’ only burning at 16x.

In my previous post i mention removing both cdrwin and stomp, and also employing killaspi to guarantee that any aspi layers were gone.

I now believe that when i updated my firmware to 1.03 the eprom got corrupted.

tb


#5
  1. If you have VIA chipset on your board there is a tool on their website (IDETool or sumthin) that will help you.
  2. Also there is a XP reg hack that prevents that degradation. It is due to poor I/O handling safeguards in XP.
  3. Make sure that your BIOS is set correctly.

Happy hunting.


#6

Oh. And there is also a tool on Nero’s website that will make Nero read the speeds off the firmware instead of calculating it itself. That will take care of the 16X as topspeed problem.


#7

WHat bios settings do you mean exactly?

many thanks

tb


#8

In my BIOS there is a toplevel category called “Integrated Peripherals”.
Under there you’ll find settings for IDE Channels and thereunder settings for Primary / Secondary Master / Slave PIO --> Set to Auto
and
Primary / Secondary Master / Slave UDMA --> Make sure these 4 are set to Auto or yes.

OV


#9

I assume that you are using Windows XP with SP1. Take a look at the Microsoft Knowledgebase Article:

http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

Windows will drop the DMA mode down notches as errors are encountered on the device, eventually reaching PIO mode altogether. You can only easily reset the DMA mode by uninstalling/reinstalling either the IDE device or the IDE controller (!!!). Service Pack 2 (not out yet) includes the patch to prevent this dumb behavior or if you are impatient (like me) you can get the patch directly from MS. It’s not an online download unfortunately (at least it hasn’t been).