Udma 6?

bought a new Maxtor 40gig hard-drive.
shows in the bootup screen that it is running at UDMA 6.
but in the Windows device manager it only shows that it is running at UDMA 5.
is there a way to enable UDMA 6 in WinXp?

The WinXP Service Pack 1 provides support for ATA 133 (UDMA 6).

If you have a VIA chipset and your controller supports ATA 133, the fix for WinXP support is at Ultra DMA Mode 6 Devices Are Not Enabled on VIA Motherboards After You Install Windows XP SP1

Do you have the VIA chipset and if so check this…

     http://www.viaarena.com/?PageID=66

hope this works for you, worked for me. but read the instructions

nope, don’t have a VIA chipset

What motherboard do you have ?
and I hope you don’t have anything with an SIS chipset !!!
I had exact same problem (via chipset) that the via driver fixed.
You will need to tell us your M/b or the ide-controller type, is it onboard or add on card, etc.

Originally posted by arthurking
and I hope you don’t have anything with an SIS chipset !!!

I take offense at that. For your information DMA works great on my SiS chipset.

:bow:
no offense was intended to anyone by that remark,
but when three computers that I am trying to get working properly all have SiS chips (730&630). I just can’t get them to use dma in XP pro.
The computer I am on now is a Gigabyte 7vrx which uses the VIA chip and had no trouble finding a working driver from VIA, then getting the computer to work as it should!
I’ve never had any experience with SiS648 chipset and I’m guessing that your comp is working as it should.
But SiS has terrible customer support (in my dealings with them) whereas VIA has worked well for me.

I thought you were referring to their recent chipsets. Pretty much everything SiS made before the 735 sucks. I actually have this exact problem (well, I’d be happy with any DMA) under 730s. Still have this probelm, though luckily it’s not my primary computer.
http://club.cdfreaks.com/showthread.php?s=&threadid=49261&highlight=DMA

Cool.
So you know what I’m going through. But did you resolve the problem with this board’s dma problem ? or did you just do what I have done and got a new system ? How did you install XP.

 by the way this is not a huge problem for me as this computer belongs to my mother-in-law. I just don't like to see this sort of crap. And I also totally avoid anything that has SIS chipsets now whether they work or not.

edit: I have just received a reply from someone else with a similar board to (in-laws) and he gets dma. and just saw that my brother’s board (un-known brand) with 730 chipset that gets udma !! so I’ll keep tinkering for a while.

Not resolved, and using Win2k. Strangley enough, I can get it to list optical drives on UDMA - my CDROM gets UDMA 2, my writer gets DMA (no U). Though NeroinfoTool only sees the writer as having any DMA. Like it says in my linked post it’s a matsonic (cheap!) and there is a cryptic Q/A from SiS about DMA in NT/2000 (and XP too, though no mention). I think Perhaps only Windows 9x can use DMA on mine at least.

my motherboard is:

ASUS P4S533

hope that helps.

arthurking

I too had problems enabling ultra dma on a friends SIS mobo.

The option was greyed out under device manger after a fresh install of XP Pro . I tried everything …removing the controller from device manager various BIOS settings… I wrote to SIS for support and never got a reply. Strangely enough, I reinstalled XP Pro a 2nd time and the option was no longer greyed out. I was getting udma options under device manager. And drive performance was back. I think it was a 745 or 765 chipset I am not exactly sure.

ntloser,
yeah, I’m thinking that a re-install is the only option at the moment, but I have read somewhere that if you get too many read/write errors to your hdd, winXP/2000 will set itself to PIO mode, and there is a work around involving the registry. But I’ve heard of too many instances of this with SIS chipsets and I’m currently with a VIA chipset now for 3 months doing lots of disk intensive stuff and no probs.

accel7,
have you updated your drivers from the asus website after sp1? I’ve had a look at SIS website and there is a patch for the 645DX chipset you have for the AGP so maybe give this a go b4 you try to set windows to udma6. A re-install of windows may be the way to go too. I just looked up the asus site as I’m writing this and I notice that there is a mini ide driver for 2000/xp. have you installed this?
here’s the link;
http://download.asus.com.tw/mb_dl_menu.asp?l1=1&l2=15&l3=6&mid=1

  you do need to update regularly, stuff like this, when you have problems. also check to see what updates the bios involves and maybe update this too. if its only for faster processor support, then there's no point.

come back and tell us how you go with updates, I’m curious to know.