TSSTcorp TS-L632D in Vista?

vbimport

#1

Hey, I got a Dell E1505 laptop this past december, I got the Dell Vista Upgrade for it a couple weeks ago, I guess early March, late February. So, now I dual boot Vista and XP Media Center, and out of nowhere, my TSSTcorp TS-L632D drive just doesn’t work in Vista, it works fine in XP though. But I seem to be one of the few that actually like Vista more than XP, so I don’t want to have to go back to XP everytime I want to use a disc.

In the Device Manager it says "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

Click ‘Check for solutions’ to send data about this device to Microsoft and to see if there is a solution available." I try to check for solutions, but it doesn’t do anything, and it says the drivers are updated. Anyone know what I could do? Thanks.

On a side note, can this drive burn DL DVDs? The Packing Slip just says “8X DVD+/-RW Drive for Inspiron 6400/E1505” but the TSSTcorp’s site says it can do DL. Just wondering.

Thanks again.


#2

Hi,
I also have a similar problem with a TSSTcorp CD/DVD TS-L632D drive but in Windows Xp media Center.The CD/DVD was working okey before but has suddenly disappeared.Its now showing a yellow exclamation mark.I have tried to reload the drivers for the device but all in vain.I restarted the system in safe mode and the CD/DVD drive works okey.Would anyone know what has happened to this drive.When i go to the properties of the device it shows an error "Windows cannot load the device driver for this hardware.[Error 39]"
If someone has resolved this problem before please help me.
thanks
:bow:


#3

Hi,

Vista users please check http://support.microsoft.com/kb/929427
Also have a look at http://support.microsoft.com/kb/314060 (XP users)
You may also try ImgBurn, as there is a graphical interface (“Tools/Filter driver load order”) to perform the manipulations described in the aforementioned MSKB article.

Michael


#4

Hi,
I would like to thank Micheal for providing the solution to my problem.I really appreciate.I followed the instructions provided in the link you gave me.
Thanks again
Jeke


#5

I have XP Home, and was about to upgrade to Vista Ultimate, but I wanted to have all drivers in hand first before taking the plunge. My HD’s a little “dirty” so I wanted to do a clean install. Anybody know of any Vista driver for this TSST TS-L632D beast that I can download BEFORE installing Vista?


#6

Hi and Welcome!

There is no such thing like downloadable drivers for optical drives.
As you want to do a clean install on a freshly formatted partition, there shouldn’t be any problem. But make sure, you are only using software, that is known to work with Vista.

Michael


#7

Hi there. I’m having the exact same problem, except my laptop is an Acer, not a Dell. Drive vanished in “Computer” (formerly known as “My Computer” in XP), but shows up in Device Manager, along with the aforementioned yellow exclamation warning. I d/l’ed http://support.microsoft.com/kb/929427 as recommended by mciahel, but after it d/l’ed and I tried installing it, it said that “The update does not apply to your system.”

What do I do now? I really want to be able to play DVDs and such again.


#8

Hi and Welcome!

you’ll have to edit the registry manually according to the instructions given in the aforementioned MSKB article. And it’s obvious, that a tool designed for XP must not necessarily run on Vista, isn’t it?

Also, as this problem is mostly caused by incompatible CD/DVD software, make sure you use only Vista capable versions.

Michael


#9

Um… what?


#10

Where does it say how to edit the registry manually?


#11

Actually, cancel that. I did a System Restore, and it’s all good. Thanks for your help. :smiley:


#12

Done.

I did a System Restore, and it’s all good. Thanks for your help. :smiley:
Fine, you found a solution that works for you :clap:

Michael


#13

I have a problem too with tsst corp ts-l632d. I am trying to install windows Vista and after the first 2 or 3 steps i cannot continue because it tells me that I need a driver for my optical drive to continue and I can’t move on. since I already searched the net trying to solve this problem and found no sollution I’m asking for your help. I have a Dell Inspiron 6400.