TSSTcorp SH-S162L can't burn a dvd

Mine will read dvds, burn regular cdrs, but every time I pop in the Legacy 8x dvd-r, drag and drop some data files (movie files, mp3’s, game iso’s), it just keeps returning a “can’t write error” but windows won’t tell me what is wrong. I’ve used all sorts of burning software programs and they all return some weird error.

I’ve read these forums and tried everything, new 80pin ide cable, switched jumpers around, firmware is now at ts06, etc.

I did read that someone mentioned a problem with nforce and nvidia chipsets causing problems for this burner but the previous threads didn’t elaborate.

I have an MSI nforce2 motherboard using an nforce v2.6 software that goes with it. I tried updating that but it seems that Nvidia has not been updating it since sept. 2004.

I’m pretty sure my media or drive is not defective but I’m really out of ideas.

Both drives are set to UDMA 33/100.

Any godsend help would be appreciated. Thanks.

Nm. Problem was that windows has crappy dvd recognition software. Using nero 7+ and it’s burning my data just fine. Yay.

No, you have used crap media.