TSSTcorp CD/DVDW TS-L532U not working

The title says it all…

I turned on my Laptop one day and it wouldnt read any CD or DVD…:frowning:

Laptop Details:

Model: Acer Travelmate 2413LM

System: Windows XP
Home Edition
SP 2

CD/DVD Drive: TSSTcorp CD/DVDW TS-L532U

If you need any more details… please ask

thanks in advance

Hi [B]Punky The Fisg, [/B]welcome to CD Freaks!

You may wish to try to boot from a bootable CD or DVD (Windows or Linux installation disc?) to check whether it is a hardware or software problem.
Speaking of that, have you changed any software (especially burning or virtual drive software) or hardware recently? :slight_smile:

Good luck! :slight_smile:

Max

[quote=kg_evilboy;1954068]Hi [B]Punky The Fisg, [/B]welcome to CD Freaks!

You may wish to try to boot from a bootable CD or DVD (Windows or Linux installation disc?) to check whether it is a hardware or software problem.
Speaking of that, have you changed any software (especially burning or virtual drive software) or hardware recently? :slight_smile:

Good luck! :slight_smile:

Max[/quote]

I do not have a windows disk that came with my laptop:(

…BUT! I do have a recovery disk which i used to re-boot my laptop 2 days ago

should i use this?

also…I did recently have a program on my laptop that makes it look like windows vista…I dont know if this had anything to do with it?

and i haven’t installed any new burning or virtual drive software since the reboot…

installed on there though is NTI CD and DVD maker 7

EDIT: I have tried my Recovery Disk…but the drive wouldnt reconise it

VistaCG or similar styles should not affect disc drives.

Have you checked the boot priority in your BIOS?
If it worked before with the very same settings though, then it may well be that your drive has died. It just happens.

[quote=kg_evilboy;1954076]VistaCG or similar styles should not affect disc drives.

Have you checked the boot priority in your BIOS?
If it worked before with the very same settings though, then it may well be that your drive has died. It just happens.[/quote]

Have I checked the what in my what? :confused:

and it did work yesterday enough for me to copy 3 songs onto my itunes…then it stopped working again

EDIT: I googled that BIOS thingy…I’ll look now

Just sneaking in here ;)…you might try uninstalling iTunes for troubleshooting purposes, it’s been known to cause problems.

Hmmm… iTunes it could be… I’ll give it a try :stuck_out_tongue:

nope its not iTunes…

So did you change the boot priority, to boot from your DVD drive, as Evilboy asked?

I have indeed :iagree: