TSSTCorp CD/DVDW TS-L532M troubles

I experience some troubles with my DVD writer. It reads DVD disks, but it doesn’t read CDs. The DVD Writer is new. I bought it with my laptop , when i was in USA. When i insert a CD, it tries to read it, and i think it does, but Windows Explorer recognize it like an empty cd. When i insert a DVD disk nothing like this happen. It reads it.

I have to mentioned that sometimes it reads cd disks, but this is very very rarely.

I haven’t installed any drivers, except the driver for the lightscribe technology.

I am using Microsoft Windows XP Professional with Service Pack 2.

Can anyone suggest what to do ?

Thank you in advance :slight_smile:

PS. Please excuse my bad english. I am not american. :slight_smile:

Maybe the unreadable CD disks are not liked by the TSST drive.

i tried to read discs that the dvd writer has already read …

i tried

  • original driver discs
  • sony, verbatim, traxdata, memorex …
  • rewriteable discs…

and nothing…

Hi,
I have TSSTCorp CD/DVDW TS-L532L on my notebook, and have similar problems; the computer locks sometimes when inserting a blank CD-R, burning DVD’s and installing something with more than one disk. Have you resolved the problem you had, and if I may ask, how? =)

sincerely,
Runar Nilsen

Of course the optical drive will “lock” for a short time when you insert a BLANK media!

READING a BLANK media is just a futile attempt.

It makes only sense when you run a burning app and want to burn stuff on it.

My TSSTcorp CD/DVD TS-L532M drive got lost right after uninstalling Roxio and MyDVD (Sonic). System can’t find it. Code 39.

 Thanks a lot, Fred_ (old guy)lol

Sorry, forgot to mention storprop.dll was missing and I DLed and dropped it in Windows\sys32\drivers.

Guys, I have the same exact problem…Did anybody solve it? I can’t read CD’s or install programs. This is really bad

Uninstall & reinstall 1 of your burner softwares.

I suspect that after installing both Roxio & Sonic software, you have also installed both packet writing solutions as well.

Uninstall all packet writing software & don’t install it unless you really need it is. Packet writing software can be a nightmare.

Heh :):slight_smile: i bought my TSSTcorp CD/DVDW TS-L532M with laptop in USA last summer too.
But i have different problem.everything works except writing dvd 8x - i tried every kind of dvds(about 10 kinds) from benq to tdk,verbatim. all dvds 4x are writing good,all cds are good.(unfortunatelly there are no more dvd 4x in shops) even i have used different programs to record and different speeds, i defregmented my harddrive.believe me i’ve tried everything. so what is up when i record and it seems to be ok:

  1. i don’t see anything on dvd
  2. i see but i can’t copy anything (CRC appears)
  3. i see and i can copy some of the stuff from dvd (CRC appears)
  4. one or two dvd were completely good. it was 1…2 from 40 i messed up.

PS. DVDRW are still writing good …but they are 4x

ps2.i am about to change a firmware …will i loose a guarantee then?

What firmware did you change to and how did it work afterward? Mine came with HR04 and I can’t find a later one even though I understand the L532M is now shipping with HR08.

You first have to find out if your drive is OEM or not, and if yes, which OEM.
You can use DISCINFO to find that out.

Probably your drive is HP OEM, and I have read that HPs support site hosts this firmware for users!

http://support.microsoft.com/kb/314060/EN-US/

I have a similar problem as described above… I have had Philips DVD+R 8x on a spindel and burned a lot of movies without any problem. Now I bought new ones, Philips DVD+R 16x (8x were out of stock).

When I burn movies or PS2 games on the new DVD+R’s, I cannot play the movies in any DVD-player (LG, Grundig, Sony, etc), when I burn movies on either 8x or 4x. There does not seem to be a problem playing the DVD’s in my laptop.

I’ve looked up the firmware and it is HR04. I cannot find any firmware updates on the HP-site (the drive is used in a HP Pavilion ZD8290), but it seems that there is an HR08-update out. Where can I find this one?? I really hope this will solve my problem, cause I have already ruined 50 DVD’s! :frowning:

I hope someone can help me and a lot of other people out. :slight_smile:

Through all the problems I had with this DVD drive, it turned out dvddecrypter was the program responsible for me making 100 coasters out of dvd’s.

I don’t know why but as soon as I instaledl dvd decrypter and tried to burn ISO files, it made sonic and nero freak out and churned out bad dvd’s no matter what I did. As soon as I uninstalled it, the problems went away and I burned all my ISO files that were building up. This drive works fine NOW with the formware HR04 on 16+ speed dvd’s and I’ve used a variety of brands. I don’t know if Sonic is set up to crash when DVD decrypter is installed or if dvd decrypter corrupts burning software. I would get px.dll errors in sonic and no reports in Nero, it would just make bad dvd’s. When I would use dvd decrypter to burn, it would make coasters as well. As soon as I uninstalled it, my problems went away. There is DEFINATELY something up with Sonic and dvd decrypter on the same system.

hey all first time poster
ive got a similar problem… im using the TS-L532M cd/dvdw drive in my HP Pavilion dv4000 down here in melbourne australia.
it worked fine reading both cds and dvds of all types, but about 2 months ago i noticed that when i popped in one of my music cd’s it wouldn’t read. i then tried many different types of cd’s including burnt cd-r, cd-rw, games of various publishers and many music cd’s but none of them worked.
however, whenever i pop in any DVD, it works 100% perfectly. i havent tried burning dvd’s yet but i dont want to risk wasting the money in which im in a position of being broke.
im using the HR04 driver.

a mate of mine told me i should try uninstalling the device, then restarting the computer. this didnt work.

also, i havent installed ANY type of burning software. but i have been using daemon tools. whenever i use daemon tools the files opened do not work at all. its like its replicating the problems i have with the cd/dvd drive. i have tried unistalling daemon tools but this has come to no avail.

any suggestions???

Try this:

I.ve been searching this problem(s) with ts-L532L which is also called sp6572M by Toshiba(not impressed with that company).

I could burn DVD or CD but constantly got crc errors on the discs.

Solution is a firmware upgrade.

Please see http://forum.rpc1.org/dl_result.php?kaj=1&isces=SDR6572M

If you like region free see http://hijacker.rpc1.org/toshiba/

After 6 months this is the fix. I now have Ultra DMA 2 for transfers instead of the dreaded Multi-word 2.

Hoping this helps.

Cheers

Siggy

can this firmware be put on the ts-532m drive?

thanks

I AM LSO HAVING THE SAME FAULT CODE 39 AND IT OCCURED AFTER I INTALLED A NEW HARDDRIVE IN MY ZD8000??? CAN THIS BE FIXED