TSST TS-632D no longer wants to burn DVD+RW

vbimport

#1

[qanda]This thread is about the Samsung TS-L632D. Click here to see full specs[/qanda]Hi. This is not my first post here, but i’m unable to retrieve my password (email issues), so i had to create a new account :slight_smile:

I have a Dell Inspiron 6400 (purchased in late 2006), which came with a TSST TS-L632D DVD+/-RW burner, and i never had experienced problems with it… until yesterday. I was copying a DVD to a DVD+RW under Linux (using K3b), when suddenly, the burn failed near the end…

After that, i’ve tried to blank the disc, but it FAILED! Then, i rebooted to Windows and used Nero CD-DVD Speed to format the disc (it was a Memorex DVD+RW), and it worked… but when i tried to burn again on that disc, the burner REFUSED to recognize it!

Things got worse: after declaring that Memorex DVD+RW as a coaster, i’ve tried again with K3b, this time using a fresh, new Philips DVD+RW. The disc burned fine the first time (trying with a bunch of garbage data), but after a second burn, burning different files, it failed AGAIN near the end! Now each time that i try to burn that DVD+RW, K3b attempts to format the disc, then it dies with a I/O error. Trying the same disc on Nero yields almost the same: disc writes, but it fails with an I/O error when writing the lead-out.

Tried with ANOTHER, used Philips DVD+RW from the same batch: same results! Now i have three expensive coasters! On those failed burns, i’ve noticed that the drive produces a tic-tac noise, similar of those old floppy drives, when burning the disc…

The drive still reads and writes DVD+/-R without any problems or odd noises, it’s just DVD+RW that fails now… Is my drive starting to die? :eek:

BTW: I have NO crapware/bloatware installed. On Windows, it’s just a plain XP SP2 install, just Nero installed; no InCD, no Daemon-Tools, no Alcohol, no nada! On Linux it’s an old Fedora Core 6 64-bit setup. Both “bricked” discs worked without problems in the same burner before this mess.


#2

Hi,

since there is the same issue with Windows and Linux, I suspect there is either something wrong with the drive or with the media. They might be differently branded but from the same manufacturer.
On Windows, run Nero CD/DVD Speed, insert one of these discs and check the “Disc Info” tab. Do the same with a disc from the other brand you were using. If they are the same, you might try something totally different like Verbatim discs.

Michael


#3

I don’t think that the problem is in the media: it ruined a perfectly new, blank Philips disc, and two discs that have been used earlier with the exact same burner (a Philips and a Memorex). The Memorex discs were pure garbage, but the Philips disc was a very good one (excellent compatibility with other drives)

Verbatim discs are nowhere to be found here in my country… save for some random DVD-R lots :slight_smile: The Philips discs are made by Philips (checked in Nero CD-DVD Speed), can’t remember right now who made my Memorex discs (the burner is now in another city right now…). Also, the pickup tic-tac noises are NOT normal for any drive!

I have mixed experiences with TSST drives: most of them tend to fail quite early (i have two combo drives that sometimes don’t want to read anything!). Nothing like the old Samsungs :slight_smile:


#4

Okay. If the discs were different MIDs, then it’s probably the drive. What about warranty on the notebook?
You might also try to carefully clean the lens. Not sure if that helps, but worth trying.

Michael


#5

The notebook had a standard 1-year warranty, and since i purchased it on December 2006… then i’m out of luck :frowning:

Everything else on the drive works: it reads and burns normal DVDs…


#6

Should i need to replace that drive… What options do i have?

I’m looking right now this one: Samsung SN-S082H. It’s the cheapest one that i can find right now, but i trust on Samsung. Not on Toshiba, but on Samsung :slight_smile:

Or should i go for an LG or a NEC?