TSK 321040B X7S2 Firmware

vbimport

#1

Can someone please make an updated version of firmware for this drive since it is a Lite-On?

Thanks!


#2

maybe you can find it here


#3

I tried the X7S3 firmware .EXE file, the application opens, I get a screen that says “Select the Lite-On it drive you want to update” and there is not drop down window, no text to select. This happens under 2000 and Win ME


#4

Complain to TDK :stuck_out_tongue:

1: try to disable DMA and try again
2: Make sure that you use the MS IDE drivers shipped with the OS and not some from the mainboard/mainboard chipset maker. (Via, intel sis, ali amd, nvidia…)
3: make sure that the drive is connected to the main ide controller and not to an extra ide controller…


#5

Complaining to TDK?..I might as well bang my head against the wall - LOL

I tried all of the and it didn’t work so I converted the .exe to a binary flash and used mtkflash.exe to save the old X7S2 and flash the newer X7S3.

Could someone point me to instructions on hacking the code in a Lite-On It flash so that my drive name would remain TDK and the model number so I can be self-sufficient at this as well as be able to contribute to this forum in the future?

Thanks!