TS-L633L SC01 Burning Speed

My HP Laptop came stock with TS-L633L SC01, the HP OEM F/W version. I was using Memorex media at the time and I was burning A LOT of bad DVD Videos. They would autoplay on my PC but were undetected by my Xbox 360. I was using UltraISO at the time.

Thinking this was a So, I decided to change a few things. I started using Imgburn, I bought new media, and I flashed my firmware from TS-L633L SC01 --> SC02 --> SC03 (I had to use -nocheck when doing the initial flash from SC01 --> SC01 as I was going from OEM to Official Samsung F/W). The media is TY02 and CMC MAG AM3, the latter sold under HP Lightscribe.

I haven’t had any playback issues since the revolution. However, I have had one possible firmware related issue, my recorder does not abide by my selected burn speed. In fact, when burning my recorder will zip right past 3x, 4x, and 6x all the way up to 8x (side note: regardless of the selected speed, my recorder is slow to build up to 8x, usually averaging 5.5x). I am unable to verify this sporadic behavior in UltraISO.

This may be irrational but I “feel” that since my device imitates an old man pushing a boulder up a steep hill trying to reach 8x that it probably is doing poor work there. I want my speed to be 6x, sound logical? So, I flashed my drive back to SC01, ODD Samsung version. For about 6 DVD’s my device was under my control, she pleased me well. However, during my last burn she started trying to run up that hill again! I just tried to burn a disc and I received the Invalid CDP (Power Calibration Error). I’m sure the error will be gone on reboot (I’ve tried different sources and different discs and the error persists during this windows session). I’m just wondering if anyone thinks these two atrocities are interrelated? Some sort of power issue causing the wrong burn speed?

Or is there something wrong with my firmware/hardware? If one looks at mciahel’s faq (http://club.cdfreaks.com/f105/mini-faq-samsung-dvd-writers-220607/), I am encountering the cosmetic glitch by CDSpeed, Opti, and DVDInfoPro, all saying my discs were written by TS-L632N. So, I’m thinking…should I try out that drives firmware? The OP here, http://forum.rpc1.org/viewtopic.php?f=2&t=44504 was successful in using the TS-L632N firmware on his TS-L633L even if it was just an intermediary resting place.

Sorry for putting you guys through this hell hole of a post, I thought I’d add a trivial amount of humor to get you past the half-way mark. Thanks a lot!

Thoughts?

P.S. I am contemplating buying an external. I probably will. I’ve got around 150 discs to burn and I think I can shell out $30 to make the process both FASTER and smoother. Especially considering this drive does NOT do quality scans even halfway decent, which would make testing firmware a hell of a lot more fun. I’ll have to do more research, but I’m biased towards Lite-on as they really tickled my fancy when they introduced their 52x CD-RW :bow:

Hi and Welcome!

at the moment I have no idea why your drive ignores the speed settings of your DVD writing software. Have you already tried ImgBurn?

And, please do not flash to any 632 firmware. These are drives with PATA interface, and yours is SATA. Perhaps this crossflash may not kill the drive, but there might be some other unwanted side effects.

Since you intend to burn another 150 discs, getting a half-height (not a slim!) external drive is a good idea.

Michael

Thanks for your hasty reply, Michael.

Yeah, I use Imgburn right now. I’ll look into some drives and post back :slight_smile: I love shopping for techy stuff!

If anyone has a hunch as to why I’m having this burning speed glitch, please lend me a helping hand. I would GREATLY appreciate it.

Oh and Michael, do you know anyone who has done quality scans with the TS-L633L? I haven’t scanned my TY02, but the CMC MAC AM3 come out HORRIBLE and I think the results I’m getting are primarily due to my drive’s poor ability to scan.

The following are quality scans of three different DVD’s. I will post each set of scans separately to circumvent any confusion. I used the latest DVDInfoPro and Nero CD-DVD Speed 4.7.7.16.

This disc was burnt at 8x from an ISO and read at 4x. (set speeds not the avg)

Notice the PI Failure difference. This write was done before I had the speed burning variation problem. I wonder why my Quality Score for the media is good even though my PIE/PIF is bad?




The following was burnt at 3x and read at 4x.

When I burn at 3x, the write speed is more steady, so would this be better write quality? I can’t tell because my scans are, as I believe, inaccurate. This write was done before I had the speed burning variation problem.




This was burned at 6x and read at 4x. This write is after the problem started, notice I chose 6x but the write speed goes up to 8x? 8x is the max for my drive so it is as if I chose maximum speed, which I did not.



What does ImgBurn list for the ‘Supported Write Speeds’ in the disc info panel on the right?

Perhaps your drive just doesn’t support the ones you’re trying to set it to - in which case it’ll round up/down to whatever it feels like using.

3, 4, 6, 8x

TSSTcorp CDDVDW TS-L633L SC01 (ATA)
Current Profile: DVD-R

Disc Information:
Status: Empty
Erasable: No
Free Sectors: 2,297,888
Free Space: 4,706,074,624 bytes
Free Time: 510:40:38 (MM:SS:FF)
Supported Write Speeds: 3x, 4x, 6x, 8x

Pre-recorded Information:
Manufacturer ID: CMC MAG. AM3

Physical Format Information (Last Recorded):
Book Type: DVD-R
Part Version: 5
Disc Size: 120mm
Maximum Read Rate: Not Specified
Number of Layers: 1
Track Path: Parallel Track Path (PTP)
Linear Density: 0.267 um/bit
Track Density: 0.74 um/track
First Physical Sector of Data Area: 196,608
Last Physical Sector of Data Area: 0
Last Physical Sector in Layer 0: 0

Performance (Write Speed):
Descriptor 1…
-> B0: 0x00, B1: 0x00, B2: 0x00, B3: 0x00
-> EL: 2297887 (0x0023101F)
-> RS: 5,540 KB/s (4x) - WS: 4,155 KB/s (3x)
Descriptor 2…
-> B0: 0x08, B1: 0x00, B2: 0x00, B3: 0x00
-> EL: 2297887 (0x0023101F)
-> RS: 5,540 KB/s (4x) - WS: 5,540 KB/s (4x)
Descriptor 3…
-> B0: 0x08, B1: 0x00, B2: 0x00, B3: 0x00
-> EL: 2297887 (0x0023101F)
-> RS: 5,540 KB/s (4x) - WS: 8,310 KB/s (6x)
Descriptor 4…
-> B0: 0x08, B1: 0x00, B2: 0x00, B3: 0x00
-> EL: 2297887 (0x0023101F)
-> RS: 5,540 KB/s (4x) - WS: 11,080 KB/s (8x)