TS-552B Dont burn cdr's anymore. Can I flash to fix?

vbimport

#1

I have the TSSTCorp TS-H552B. About amonth ago it quit burning cd-r media and cd-rw. It does not appear to be an OS/Driver problem because my old Lite On CDRW works fine. The TSST burns DVDR fine, though.

Can I upgrade the firmware to something else to repair? It had 04, I tried 07,08,10 from the odd site. Wondering if there is another option or cross flash to a different mfg???


#2

Install on another PC or install on a newly bought and newly formatted HDD. Whether another drive on the existing installation works well doesn’t mean your TS-H552B is causing the problem. If you already flashed to various official firmware for TS-H552B, no need to flash anymore. It’ll only void the warranty. If it still doesn’t write to CD media on another system, go to an official service center.


#3

Yeah tried it in my old HP pc and it doesn’t recognize cdr in it either. Still plays store bought music cd though (both computers) I reckon I will request an RMA from Samsung.


#4

If it can burn DVD media and can play commercial CD Audio disks, it’s most likely the CD-R media you tried were not good enough for TS-H552B. Run DVD Identifier to identify the CD-R type. Generally, Lite-On CD writers support more CD-R types.


#5

Hi Guys,

I’ve got exactly the same problem. Tried updating the firmware, changing writing software no joy.
The other day I wrote a CD with Audio OK Great.
Next day i tried to write a CD of Data and it tried but said Error unable to fix the image on the disk (or something like that)
Now it won’t recognise any CDR or CDRW blank or written (even with this burner !!)
It does play pre-reccorded Disks though.
It Has no problem at all with DVD’s !
I use Verbatim disks and they worked fine for six months or so…till now!
I’ve got TDK CDRW’s and it just keeps flashing away for ages… no result.

If i leave a disk in the drive and restart the PC it won’t get past the IDE check. Therefore i’m supposing that its not software ??
The only thing i changed between writing the music and it not working was installing Nero Vision Express and the latest Windows Update. I’ve uninstalled all Nero stuff and even tried restoring Windows to a previously good date… Still no joy. I’ve got a french version of windows on partition, same thing.

Anybody out there with the answer? Any other tests we can do ?

LONE WOLF…Did you get anywhere with Samsung ?

I’d be real happy to know if you fixed it !!!

 Cheers guys... Gigaboy   :confused:

#6

If you just want a new drive, you can get it easily if you bought a Samsung or LG drive with manufacturer’s warranty. If you want to find out what the problem is, better visit a real service center and talk to an official engineer for Samsung ODDs. (They’ll first test the drive, explain to you, and then ask what you want.) If you just call or email them and ask how to fix, you’ll get nothing.