Trying to get a scan for errors for WD hd

I just tried to run a windows disk error check on a new WD hd (WD5000AAKB, 500 GB, EIDE ), and it would not make it past phase 4. Then I downloaded Western Digital diagnostics software. It was creeping with an estimated finish time of 60 plus hours…so despite the basic Smart disc info and checklist that indicates the drive is indeed working fine, I can’t get the WD diagnostics to do a complete scan for errors–not unless I have those roughly 60 hrs to spare where I know I won’t be using the computer. (The smaller drive (80 Gig) Windows does without trouble for some reason, but with WD diag. would accordingly take 8 hrs if I let it continue.) Is anyone aware of some software that does this HD error checking a bit more time efficiently for a large drive?

(Again, the Windows disk error check also seems to not want to do it–at least not in a timely fashion…though I did attempt to run the window disk error check without either of the two sub-options of 1. Automatically fix file sys. errors and 2. Scan for and attempt recovery of bad sectors. But without either of the options checked it seemed to run the utility far too quickly, in seconds, so I don’t think it did anything.)

Everything also seems updated for this device–so I’m really at a loss how to get a scan for errors.

Edit: honestly, I’m not trying to bump this–I just keep reading and discovering things about the drive. First in avsforum.com there’s this post (http://www.avsforum.com/avs-vb/showthread.php?t=1072920) discussing that “WD drives with the suffix “AA” do not work” (though perhaps that was more addressing some particular A/V software mentioned therein) and then a critical comment in a newegg customer review about the Preemptive Wear Leveling (PWL). Also I read that quickformat with windows for a new hd is not at all recommended, which for the life of me I can’t remember back 5 days ago if that was the option I choose…I’m suspecting possibly, since it seemed to format such a large hd pretty quickly (minutes). Then when I try to play for example a video file from this new hd the sound is “crunchy,” but if I move that file back to my old hd and play it the sound is fine. So I’m ignorant about what may cause this–such as are other “drivers” needed for video and media related playback? Then I read that in addition to the WD diag. that WD has hd formatting tool (“data lifeguard tools”) for free download. I wonder if there’s danger in just deleting my backup files from the disk and trying to (re)format the hd with this tool to see if there’s better performance (for a/v file playback, scanning disk for error utility, etc.) I guess this is all a lot of noob wariness, but thanks for any advice.

(also, again, this is set as the “slave” drive)

Going by the lengthy test times the tools have reported, it seems like your hard disk is running in PIO mode. Could you check in the device manager:

[ol]
[li]Go into the start menu, right-click on ‘My Computer’ and click ‘Properties’[/li][li]Go into the ‘Hardware’ tab[/li][li]Click ‘Device Manager’[/li][li]Go into the section “ATA/ATAPI controller”[/li][li]Double-click the Primary IDE Controller[/li][li]Go into the “Advanced” tab[/li][li]Check if either device shows “PIO Mode”. Note that “Not Applicable” means there’s no drive attached to this channel.[/li][li]Click ‘Cancel’ and repeat steps 5 to 7, but for the “Secondary IDE Controller”[/li][/ol]

If any device is showing “PIO Mode”, then this is likely the culprit.

Another tool worth running is HD Tune (download link). The free version will be fine. In HD Tune, go into the “Surface Scan” tab, select your hard disk from the drop-down list and click “Start”. If the scanning speed is running at a very low figure, e.g. <35MB/s and your there are no drives running in PIO mode, check that you’re using an 80-pin IDE cable to connect the hard disk to the motherboard. This tool will likely take 3 to 4 hours to complete a surface scan of your hard disk, assuming it’s running at a reasonable speed (>50MB/s)

First, thanks for replying. Yes. Secondary IDE Channel says that Device “0” is Ultra DMA Mode 2, BUT that Device “1” is “current transfer mode” of PIO Mode, though right above it says “DMA if available.” Do you know how I can fix this?
Edit: also, it looks like this is 40pin (not 80) cable, same as my primary hd.

You can try resetting it as follows:

[ol]
[li]Go into the registry editor (Start -> Run, type in “Regedit” and click ‘OK’)[/li][li]Go into HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> Class -> {4D36E96A-E325-11CE-BFC1-08002BE10318} -> 0002[/li][li]Right-click on “SlaveIdDataCheckSum”, click “Delete” and click ‘Yes’ to confirm. [/li][li]Reboot the PC[/li][/ol]

With some luck, Windows will try to redetect the DMA mode during boot up.

If it returns to PIO mode, then you’ll likely need a different IDE cable.

Unfortunately, the PIO mode heavily limits the data transfer rate, which is why when the hard disk is in this mode (or even an optical drive), it causes video playback to stutter.

Crap–no, it didn’t work. Regarding the IDE cable: do you think it’s damaged? B/c it worked fine up until now. Or are you thinking about me needing the 80 pin cable, which I’m also confused about b/c it looks to only accept 40 pin…Additionally, the driver listed in that “Secondary IDE Channel” says it has a “Driver Date” of 2001. I clearly have no expertise at all here, but is that a bit old? Lastly, I have this hd on one of these IDE cables that is simultaneously hooked to the CD/DVD drive–but I doubt that’s a problem, right? Thanks again for your help.

The 40pin and 80pin cables have the same connectors at each end, but there are twice as many wires between each connector.

This image on Wikipedia shows a 40-pin cable next to an 80-pin cable. Click the image to zoom-in.

Another way to check if the IDE cable is 40pin or 80pin is to check what Ultra DMA mode your main hard disk is operating in. If it’s in Ultra DMA mode 2, then it’s likely connected with a 40-pin cable. Otherwise if it’s Ultra DMA mode 5 or 6, then it’s connected with an 80-pin cable. Most CD/DVD drives operate in Ultra DMA mode 2. From my experience, generally CD/DVD drives and Hard disks work fine on the same cable. However, even with a 40-pin cable attached to a hard disk, it will generally operate in at least Ultra DMA mode 2 rather than the legacy PIO mode.

As your CD/DVD drive on that cable is running in Master, one thing to try is disconnecting both the CD/DVD drive and hard disk from that cable, set the hard disk jumper to “Master” and connect it using the cable’s IDE connector that was connected to the CD/DVD drive. Leave the CD/DVD drive disconnected for the moment, boot the PC and check what the IDE mode shows up for the secondary master. If this shows up as “Ultra DMA Mode” now, try shutting down the PC and switching to the other IDE cable connector (leaving the CD/DVD drive still disconnected and HDD as master) and boot up again. Finally, if it still remains in Ultra DMA mode, change the jumper on the CD/DVD drive to set it as ‘Slave’, connect it back on the connector and check the IDE modes once again.

If the HDD only operates in Ultra DMA mode while on one connector, but not the other, then the IDE cable is likely damaged. However, if the hard disk only operates in PIO mode with the CD/DVD drive also on the cable, then there’s likely a problem with operating both drives together the same IDE cable. If the HDD still remains in PIO mode even on its own on the IDE cable, the last thing I can suggest is swapping the IDE cables.

You can try an updated Ultra DMA driver (if available), but from my experience, generally Microsoft’s own old ATA driver works fine even with recent hard disks. However, just in case it’s the driver, you can try looking up the website for your motherboard and seeing if there’s an updated Ultra ATA driver available for it.

You are fantastic. That’s exactly what the problem is: the two drives do not want to be connected together without one of them working in PIO. In addition to that test, I’ve tried some other combinations (cabling and master/slave switches) but to no avail–one combo didn’t even get the computer to boot b/c it didn’t recognize a primary drive! So…I’m lost again. The easy solution of course would be if I had 3 instead of 2 motherboard connections, so each device could be hooked up singularly–but that’s not going to happen. What are my options now?

One option would be to pick up a PCI IDE controller card, which will give two extra IDE ports, which would let you run each device on its own cable. The catch however is that the controller card typically adds 10 to 15 on to the total boot time. The IDE controller cards typically cost €20 to €30 ($20 to $30) and they usually come bundled with one or two 80-pin IDE cables.

If you haven’t done so, it’s also worth trying a new IDE cable just in case the IDE cable you’re using is damaged.

I tried a new cable, but it didn’t work either. The controller card option doesn’t sound too appealing with that boot time. I’m a bit surprised at this problem with this popular drive from Newegg. And I do think it’s the WD hdrive specifically that doesn’t want to work when on the cable with second device (b/c I tried it with other devices…the other hd and another cd/dvd drive, so it seems isolated to that WD drive). I guess I’ll wait a while and maybe get one of those external hd cases and run it via USB. But I’m still kind of disappointed in this difficulty, b/c I wanted it to be an internal drive. Oh well…Still thanks for all your help. I do appreciate it.

By the way, regarding how to get my three devices (2 Hd and 1 cd/dvd drive) running on this one computer with only the 2 motherboard connections: Apart from getting a external USB enclosure for the cd/dvd drive, is there any other easy way to hook up an Internal cd/dvd drive via usb to the tower’s back exterior? Like an adapter cable/connector or the like? Doubt it, but I thought it worth asking.

Also, I never did try the controller/motherboard update…How do I find where I get the latest drivers for my EIDE controller on the motherboard? How do I find in the Control panel what brand/make my EIDE controller is?

Check the manual of your mobo.

Which brand and model of motherboard do you have? If you go to the manufacturer’s website’s support section and look up your motherboard model, you should be able to get up to date ATA drivers there.

The diagnostic tool SIW (download link) will usually determine it. When the tool starts, go into Hardware -> Motherboard on the left. The Manufacturer and model # will appear at the top of the right info listing.

Alternatively, you can find out by looking at the motherboard. On most motherboards, the brand is written on chipset heatsink and the model # is usually written next to the CPU.

I found out the motherboard (Dell) and there are no updates for it… Moreover, I got a reply from a question to WD. They actually say no more than one drive per jumper. Is this pretty typical? If not, I feel that this should be made known to customers in the product info/specs. at purchase. I can’t think my mere two-connection motherboard is that rare.

Actually, I ended up copying my old hd to my new hd, so I can use the new hd now as my main one. I’m not sure if I did everything exactly as should have, but mostly it seems to have worked. the bottom windows tool bar looks a little different, some very minor change in the Outlook display, but the Audio does not want to work right now. I get a general Windows message that “there is a problem with the sound device…” I can play videos, but the sound still won’t play. The sound devices all seem to be where they should be, though. And they are all “working properly” according to the sound devices window. Everything else so far seems fine, but I haven’t tried too much yet. I also tried to play files with from the old hd (since that is hooked up still but as a slave/backup disc), but no sound and the same message occurs. Any ideas? Thank you.

Edit:(Also, the audio set up on my system is a bit different than normal: I have M Audio Delta card with mixer hooked up to that…but I don’t know why that would cause any problems for the copied drive to recognize.)

Never mind–must have been a sys. hiccup. upon that first reboot. Seems to have fixed itself upon multiple reboot attempts now!

Sorry to keep adding posts, but I keep discovering little quirks and errors since copying and switching my main hard drive. (It’s always more complex than I think it’s going to be.) The audio problem fixed itself somehow, but I keep getting an occasional error message for many applications. It seems that it occurs most when closing a given application–so it’s not particularly disruptive. Applications also take a bit longer to start the first time, but on subsequent attempts they start easily. But the most confusing thing is that my system is not booting on my new, hard drive copy alone. The new hd will only boot successfully when the old primary hd is also connected (on the other jumper). Otherwise, the new hd will get to the blue windows xp start screen and just linger (the cursor moves though). I had thought I did everything right with the ghost copy hd tool. (I selected set drive active, copy MBR, and both source and destination drives were checked for errors and passed.) So I’m confused why it looks like the new master hd seems dependent on the old hd for booting (and maybe other things)?


What is likely happening is that the new hard disk your OS has been cloned to is being given the wrong drive letter during boot. For example, if your original drive is letter ‘C’ and your new hard disk came up with letter ‘E’ when connected, then when you boot from your new hard disk after the clone, the OS is likely assigning this drive letter ‘E’ during boot and still giving the original hard disk the letter ‘C’, since Windows assigns the drive letters based on the hard disk ID’s and each hard disk has a different ID. Going by your screenshot, this appears to be what is happening. :doh:

As a result, when you remove the original hard disk and boot, the drive letter ‘C’ is missing and the OS will either refuse to log in or just hangs at the “Welcome” screen due to it trying to access files from a non-existent drive letter. This has happened to me before a few times when I cloned HDDs, especially if the original hard disk was booted and detected the new HDD before the clone. However, I’ve come up with the following workaround which has worked at least each I’ve encountered this issue.

Preferably to start with, I would recommend doing the clone again so both the new and existing hard disks are identical again.

With the two hard disks connected, boot up the original hard disk and carry out the following:

[ol]
[li]Go into “My Computer” and take note of the existing and new hard disk drive letters. Your current one is most likely drive ‘C’ and your new one appears to be drive ‘E’.[/li][li]Go into the registry editor, i.e. Start->Run, type in ‘Regedit’[/li][li]Click on “HKEY_LOCAL_MACHINE”, go into the File menu and select “Load Hive”[/li][li]Click “My Computer” on the left and go into the drive letter of your new hard disk, then into Windows -> System32 -> Config, click on “System” and click “Open”. If ‘System’ is listed twice, click the one without the Notepad icon.[/li][li]Type in “SystemNew” for the key name and click ‘OK’.[/li][li]Go into SystemNew -> MountedDevices[/li][li]On the list of values on the right, scroll down to where you see “\DosDevices\A:”, etc. [/li][li]Rename the one with the letter that machines your current OS drive to a different letter not already taken. For example, if you OS drive is ‘C’ (which is likely is), rename “\DosDevices\C:” to “\DosDevices\Z:” (assuming ‘Z’ is not already taken). You can do this by clicking the item and pressing the ‘F2’ key on the keyboard.[/li][li]Rename the drive letter that machines your new hard disk letter to what your OS drive letter currently is. For example, if the new hard disk has the drive letter ‘E’ in My Computer and your OS drive is letter ‘C’, rename “\DosDevices\E:” to “\DosDevices\C:”.[/li][li]On the left column with the registry directory heirarchy, click on “SystemNew”. Then go into the File menu and select “Unload Hive”. Confirm by clicking ‘Yes’.[/li][/ol]

Now power off the PC, disconnect the original hard disk (change the jumper on the new one to ‘Master’ if necessary) and boot the new hard disk.