Trouble with WALL-E (Region 3/Taiwan)

vbimport

#1

Been having some trouble with this disc. AnyDVD recognizes it and seems to rip it OK. After I import it into DVD Remake Pro, however, DVD Remake Pro tells me there was an error, and I get this:

Read DVD from: D:\DVDs\WALLE_TWN
Read VMG
The system cannot find the file specified.

(171:dataAccess.cxx)
Can’t open VIDEO_TS.IFO. (963:VMG.cpp)
can’t load VMG.
Read DVD from: D:\DVDs\WALLE_TWN\VIDEO_TS
Read VMG
Read VTS1
Read VTS2
Read VTS3
Read VTS4
Read VTS5
Read VTS6
Read VTS7
Read VTS8
Recovering C_ADT & VOBU_ADMAP tables. (818:VobData.cpp)
Read VTS9
Read VTS10
Read VTS11
Read VTS12
Read VTS13
Read VTS14
Read VTS15
Read VTS16
Read VTS17
Read VTS18
Read VTS19
Read VTS20
Read VTS21
Read VTS22

Also, there seem to be a lot of errors on the disc structure, so DVD Remake Pro looks like this:

After I edit it and save it and try to play it, I get a lot of errors. Even though I stripped the Chinese angles, I still get Chinese parts of the movie. Some parts just repeat and repeat until I press the next button. Basically, the DVD is pretty messed up after ripping.

Does this seem like an AnyDVD problem (I posted on their forums, too) or is there something I can fix with DVD Remake? Like I said… it doesn’t play correctly after ripping and editing.

If you’re curious, my entire process looks like:

  1. Rip with AnyDVD
  2. Edit with DVD Remake Pro
  3. Go through PGC Edit
  4. Rebuild with DVD Rebuilder
  5. Burn

I even tried FixVTS, but it didn’t help much. After running the disc through FixVTS, DVD Remake Pro no longer shows an error when importing, but the disc still comes out messed up afterwards.

Any help is appreciated.


#2

There are too many variables in your process. Hard to pin down the cause.

The second screenshot is before the editing or after? If before, then AnyDVD does not clean up the invalid referenced commands. But seeing that VTS3 size is only 0.04Mb, these commands are probably junk and are safe to delete. What are the errors on the other VTSs?

As for the angles, are you sure that this DVD is truly multi-angle? If you right-click on VTS node and you see “Strip angles…” option is enabled, that means this DVD is multi-angle. Keep the angle you want and click OK.

Try to run the exported DVD before running through PgcEdit and DVD-RB and see if everything plays correctly.

Another alternative is to not modify anything and run through the AnyDVD files through DVD-RB and see if there’s any errors on the result. Are you using the Pro version of DVD-RB or the regular version?