Trouble with the LiteOn SSM-85H5S

First off, I must apologise profusely for my inevitable noobishness. My DVD drive on my notebook has been acting strange for some time, but due to the fact that I hardly burn things, it’s never bothered me too much. However, I cannot abide with my own ignorance any longer, and after trying for numerous hours to understand the inner machinations that could be causing my issue, I have to admit that seeking help may unravel some of the mysteries I’m confronted with.

I have a LiteOn Slim Lightscribe 8X DVDSM SSM-85H5S on my notebook, with the following issue:

-It’s burning speed is incredibly slow. As the name implies, I expected it to burn at 8x speed, but Nero identified it as a 4x burning drive. I’ve tried it on different 16x “certified” media, with same results. Now here’s the fun part.

While it claims to burn at 4x speed, what ACTUALLY happens is that the process clogs up my entire computer (And it’s a rather powerful notebook, I may add) and the process of burning one DVD+R takes an average of 3-4 hours. Especially the latter is annoying…

The clogging up of resources could be due to my comparitively weaker CPU(It’s a Pentium M 2,13, which I’m aware is the bottleneck in my system, as the Geforce 7900GTX and the DDR3 2gb’s is generally sufficient for quite a bit of power), but it’s the extensive time it takes that annoys me. Now, reading an faq on this forum, I note that on 4x speed, it should take only about 15 minutes.

15 compared to 3 and a half hours average? Hmm…

I’ve been introduced to the term Firmware, and have eagerly read up on its applications and how to flash a new version on there, and I think that even with my inexperience, I should be able to sort it out without a big problem.

However, I can’t find a new firmware for my drive, even on the unofficial sites that the FAQ offered… And who knows, maybe it’s not a firmware problem?

I double checked that DMA is enabled, and it should be, if I followed the guide on this site correctly, that is.

In all honesty, I’m running out of ideas what the problem is… I’ve even replaced it once a couple of months ago, with no change whatsoever.

Any help would be appreciated.

Not sure if it will be off use, but I’ll poste the KProbe query information at the bottom of the post. It’s slightly too technical for a noob to really get much information from, except maybe about my burst rate.

VID Slimtype
PID DVDRW SSM-85H5S
F/W Revision FS04
Date Code 2006/09/25 11:01
FlashROM Manufacturer ID EF
FlashROM Device ID 14
FlashROM Type NEX(NX25P16)
Region Unset
Vendor Resets Available 4
User Resets Available 5
RPC Scheme RPC II
Interleaved DMA Not Supported
Command queuing Not Supported
Overlap operation Not Supported
IORDY Supported
IORDY may be disabled Not Supported
LBA Supported
DMA Supported
Multiword DMA mode 2
PIO mode 4
Ultra DMA Mode 2
Minimum Multiword DMA transfer cycle time per word 120 ns
Manufacturer¡¦s recommended Multiword DMA transfer cycle time 120 ns
Minimum PIO transfer cycle time without flow control 240 ns
Minimum PIO transfer cycle time with IORDY flow control 120 ns
Major version number ATA/ATAPI-4
SMART feature set Not Supported
Security Mode feature set Not Supported
Removable Media feature set Not Supported
Power Management feature set Not Supported
Burst Rate 20,73 MB/S
Interleaved DMA Not Supported
Command queuing Not Supported
Overlap operation Not Supported
IORDY Supported
IORDY may be disabled Not Supported
LBA Supported
DMA Supported
Multiword DMA mode 2
PIO mode 4
Ultra DMA Mode 2
Minimum Multiword DMA transfer cycle time per word 120 ns
Manufacturer¡¦s recommended Multiword DMA transfer cycle time 120 ns
Minimum PIO transfer cycle time without flow control 240 ns
Minimum PIO transfer cycle time with IORDY flow control 120 ns
Major version number ATA/ATAPI-4
SMART feature set Not Supported
Security Mode feature set Not Supported
Removable Media feature set Not Supported
Power Management feature set Not Supported
Burst Rate 22,53 MB/S

No one? =\

Can you dump the firmware on your hd and send me a copy?:flower: