Trouble with NEC ND-3500A in Plumax external enclosure

vbimport

#1

I bought this drive from this guy narro on ebay and it came installed in a
Plumax PM-525U2-PCS external drive enclosure. I’m using the Win XP operating system and everything should be fine with plug n play and all but it doesn’t work for me. The whole rig is detected and installed as a ‘USB mass storage device’. A ‘CD ROM’ drive is added, but it doesn’t work for even reading CDs or DVDs let alone burning. I was thinking maybe the idiot installed it in the enclosure incorrectly so I thought about removing the drive from the enclosure but I can’t figuere out how to do it. If anybody knows how to do it can you try to explain it to me. I’m eager to use this thing.


#2

You might need to update the firmware on the Prolific chipset in the enclosure. This website has the most recent firmware and ROMWriter for the B and C chipsets, which are the only ones that can be updated.

http://member.newsguy.com/~siccos/PL3507%20Firmware.htm

Also, you might want to look through this thread:

http://club.cdfreaks.com/showthread.php?t=119149

This has a lot of good info on updating the Plumax enclosures. You will mainly see info on the USB2.0/Firewire case, which I have, but it should help.

When you update the Plumax firmware, use ROMWriter 2.0.4. Then, once you reboot the drive, use version 2.2.0 to verify the update.


#3

Hello, and welcome to the forum!

You may wish to consult this thread: [thread]119149[/thread]


#4

Hmm, that thread really hasn’t helped. Have you ever heard of the drive being detected as _JEC DRD(RS JD)3100AC USB DEVICE as a component under the USB mass storage device? In the state its in it won’t read or write. I tried it on a friends computer and exactly the same thing happened. I tried to flash the ‘firmware’ but it isn’t working out. I get the ‘cannot find or connect to device’ mesage.


#5

bump


#6

Possibly the jumper pin is not set correctly on the drive?
Remove the drive from the enclosure and set it to master, then reinstall.


#7

Interesting… DealSonic claims this enclosure hosts a Cypress chip. :confused:

lordvr, you maybe better open the enclosure and check this up. :slight_smile:


#8

I didn’t notice that…I thought that one was also Prolific. :o


#9

How do you open it up?