Trouble reading CDRWs

vbimport

#1

I have a PX-708A (firmware v1.04), and am using Windows XP and Nero InCD 4.1.0.0. I have no problems reading/writing CD-Rs or DVD+Rs, and the drive diagnostic tests fine (jumpering the two middle jumpers). Here’s the problem:

I format a CDRW (UDF) using InCD, and then copy files onto the CDRW by dragging them in Windows Explorer. Then, I eject the cd and re-insert it. When I try to read from the same cd, I have problems. When I copy the same files back to the hard drive, it takes a very long time (5 minutes when writing took 50 secs). Then, I get a dialog box stating that an internal error has occured.

I tried the same thing using MRW. Again writing goes smoothly. When I try to read the files back, Explorer will take a long time and eventually hang.

I am using Verbatim DataLifePlus Ultra Speed (16-24x) RW discs. This has happened with 3 different discs (same type)

Is my drive bad? Is my copy of InCD or Windows messed up? Has anyone else had similar problems?


#2

Make sure you have the latest version of InCD. Older versions had major issues like the ones you are describing.


#3

Ahead has released InCD v4.1.5.7 today if you want to try it out… Please report back if this fixes your problem!


#4

inCD version 4 ugggghhh. I never had any problems using InCD version 3XX but inCD 4 has finally made me swear off packet writing. I have tried every version of InCd 4 except this latest one and they were all buggy and wouldnt work right.


#5

Well the latest version does have a very large list of bugfixes. Check here. It maybe worth to check out this latest version…


#6

Well, I solved my problem, and I’m writing this to help anyone else who might encounter a similar situation.

The first thing I need to make clear is that in the original post I noted that the drive had problems reading cd-rws that were just written. I’ve since confirmed that the problem was in the writing, not the reading, as the cd-rws written in this drive couldn’t be read in other drives either.

Anyway, after further troubleshooting on my own, I called Plextor tech support. The support person was very nice and spent quite a bit of time with me over the phone. What he told me was that the drive has two lasers: one for all cd operations and one for all dvd operations. Since the drive tested fine with the internal self-test and could read/write cd-rs with no problem, then the problem wasn’t the drive. He suggested a couple of options, including disabling the IMAPI cd writing service and upgrading InCD.

Neither of these options proved fruitful, so I decided to try swapping the drive (with the same model). Since then, everything has worked perfectly. The original drive apparently had a problem writing to cd-rw media, but was fine with cd-rs. Plextor tech support turned out to be dead wrong. I know that packet-writing sofware can be buggy so everyone’s first inclination is to blame the sofware, but for once InCD wasn’t to blame here.

Anyway, the problem is solved. Thanks to everyone for their suggestions and time.


#7

Thank you greg99 for reporting back. It’s always good and helpful to hear what the problem was.