Trouble installing BenQ 1620

vbimport

#1

Not sure if this is the correct forum, but if anybody could help it would be greatly appreciated…

I bought a retail BenQ 1620 from TigerDirect and it just arrived. I’ve been trying to install it in my aging PC and am having trouble. I have never owned a burner of any type. Nor have I had a DVD drive of any type in this computer. I first of all wanted to see if I could view a DVD movie, but can’t get that to work. When I try to install InterVideo WinCinema that came with the drive, I get the following error message: “This is not a qualified Machine”. Sonic RecordNow installed fine and updated itself to version 7.21.

I tried to update the 1620’s firmware…it came with B7C9 and I tried to update to B7P9. When I do this, I get the error: “No Device Found”.

The 1620 shows up in My Computer and I can explore it okay. As far as media, the only thing I’ve been able to play are CD’s. I have tried other troubleshooting measures, but I’ll refrain from listing to keep this from getting too long.

Here are my system specs:

Dell XPS T600 w/ PIII 600mhz
Intel SE440BX-3 motherboard
3dfx Voodoo3 3000D 16MB AGP video card
128MB RAM
Windows 98SE

On IDE primary: LG CRD-8400B CD-ROM master & Seagate STT20000A tape drive slave
On IDE secondary: BenQ 1620 master. I installed using the IDE cable that came with the BenQ.
For some reason when I bought this computer it came with a Promise Ultra ATA 66 PCI IDE controller. My hard drive is connected to that.

If you need more info, let me know. Thanks!


#2

can u tell us exactly how does your drive appear in your device mannager


#3

Both the LG and the BenQ show up in the CDROM section of device manager. More specifically, the BenQ shows up correctly as a “BenQ DVD DD DW1620”. It indicates “The device is working properly”.


#4

BenQ 1620 minimum system requirement is PIII-800Mhz. With your PIII-600Mhz, you WILL be able to watch DVDs and burn but only limited to 8x (sometimes 12x). And I would say 128MB of RAM is pretty low resource, not quite enough. If you would like to upgrade, I would suggest adding up to 256 or better 512MB of RAM.

Try to update:

Some people here found that the IDE cable that comes with the drive is not the best one. Try to swap with the existing cable from your comp, or better get a new one.
Btw, did you try uninstalling Sonic RecordNow. It might conflict other drivers.


#5

The retail box that came with my DW1620 indicates a CPU minimum of PIII 550MHz.

I just updated Windows 98SE before I came back to check this thread. I did the critical updates and updated DirectX to 9.0C.

I went back and unhooked the IDE cable from my old CD-ROM and hooked it into the BenQ. This left me with the BenQ as primary master and the tape drive as primary slave…and nothing on the secondary IDE.

Last night I did try to install InterVideo WinCinema BEFORE I tried to install Sonic RecordNow. I still got the same “This is not a qualified machine” error from WinCinema.

Still having the same problems. Might look into updating the BIOS.

If anybody has any ideas, I’m all ears. Thanks.


#6

Chad T, when you tried to upgrade firmware, did you select the BenQ drive to upgrade in the flash program?
I have had intermittant problems with Intervideo WinDVD on my 2.4 GHZ laptop, but no problems with Cyberpower Power DVD, installed on my desktops’ (one a 700 P III).
I do have more Ram than you in each machine, and am running XP pro on all systems.


#7

Just downloaded software from Dell.com and flashed my BIOS from version A04 to most current version A11. Still having same problems.


#8

When I double-click on B7P9.exe to update the firmware it gives the 3 warnings, then I click OK. After that, it immediately says “No Device Found” with an “OK” button. I then click the OK button and it brings up DW Flash Tool ver. A-05 and has “My Compuer” listed. Strange thing is there is NOTHING under My Computer. If I click directly on My Computer it says “No drive selected”. But the drive shows up perfectly through Windows’ My Computer. Weird stuff.


#9

You were right. My retail purple box also says that. However my OEM I/O Magic box says PIII or Athlon 800Mhz (1.2 Ghz recommended). :confused: hmm…


#10

After hearing dishinit say a different player worked on his system, I decided to try that. I went to download.com and randomly picked a player…Hotwire Movie Player. It works!!! I am watching a DVD movie right now and it is playing fine. Still some issues though:

  1. Don’t understand why I can’t update the BenQ’s firmware.

  2. Don’t understand why WinCinema won’t install/work.


#11

It might not be the case, but worth a try… can you check whether DMA is enabled http://club.cdfreaks.com/showpost.php?p=637974&postcount=2.

The last thing I would do is to “remove” the BenQ in Device manager and restart. Windows will reinstall it again.


#12

DMA is enabled.

Also, removed the drive from Device Manager and restarted Windows. It reinstalled the drive. Verified once again that DMA is enabled and it is. Still having same errors and same problems.

I also decided to try loading a different version firmware…B7K9…same errors and problems.


#13

Try updating the firmware with windows running in SAFE mode.


#14

Tried updating firmware in safemode…still won’t work.


#15

Chad T, What flash program are you using?
If not “WinDWflash”, then get it from BenQ “Unofficial” firmware page along with proper .cvt firmware file.
Try flashing with a newer B7xx firmware using a .cvt firmware file to flash with.
Make sure there is no media in your drive & that you have selected the benQ drive to flash in drive select window in WinDWflash.
Let us know what happens.


#16

Per above, I am using DW Flash Tool…whatever comes with the firmware file when downloaded from BenQ global. I don’t know how to do a manual install with CVT files.

Starting to think about returning this drive…but still open to ideas.


#17

Okay, disable the onboard drive controller using the bios menus.
Hook everything into the Promise IDE controller card.
If your computer came with the extra IDE controller, then there’s a very good reason for it.

This computer came from the age when UDMA was new and onboard IDE were prone to incompatibilities, quirks, and poor performance. That onboard IDE needs to be set on “disabled” in hardware for both IDE channels to free up IRQ’s 14 and 15 and to “unconfuse” Windows.

For Windows 98, the Promise controller software drivers are worth a try. You should notice a difference (good or bad) if you install the UDMA 66 drivers into Windows.


#18

Chad T,
The DW flash tool is the official BenQ flasher.
The WinDWflash tool flashes .cvt files.
Look at the top of the BenQ forum, find the “Unofficial BenQ DVD Rewriter Firmware Page” thread, follow the link, download the WinDWflash utility and a BenQ B7xx firmware .cvt file newer than your own.
Run the flash utility, loading the .cvt file you want. Make sure no media in drive and benQ drive selected in drive identification. Flash the drive & reboot.
If this does not work, I’d seriously consider danielwritesback solution as this may be the crux of the problem.


#19

Sounds like your system is abit outdated. May need to upgrade.


#20

Chad T,

WinCinema Manager software is used to control the interaction between a WinDVD remote control and WinDVD. Failure to load could possibly be caused by lack of support for Win98SE. More and more newer software requires WinXP to operate. Since you don’t have the remote control, this software wouldn’t work for you anyway. Even if it did load, I would still uninstall it and use WinDVD without it. :slight_smile:

At Q2. How Do I Install Firmware Updates and why do I need them? on the BenQ site, the instructions for Win98 specifically state that installation is to be done in MS-DOS Mode. Try locating the firmware upgrade in an easily accessible place (i.e., root C drive) and see if it will successfully update in DOS.