Trouble Flashing Reverse ATA Firmware

I am trying to set my ND-6650A DVD writer to slave status with Liggy’s Reverse ATA Firmware so my Toshiba Satellite A45-S120 can detect the drive.
I am using a USB enclosure and I can’t find a DOS bootdisk anywhere with the necessary USB CD/DVD drivers.

I have tried every downloadable ISO within the first 100 sites on a Google search that purportedly can load USB CD drives. I’ve had no success. (search terms : USB DVD bootdisk)
Does anyone here know what I need and where I can find it? :confused:

You will need a slimline adapter and a desktop PC. USB enclosures are not the best solution for flashing.

:sad: Okay, I bought a slimline adapter. I hooked it up to my desktop. I created a bootdisk on floppy (Win98). I put the reverse ATA files on CD. I booted the PC and chose CD-ROM support. I ran 6650boot – it took a couple of seconds to display a message that no ND-6650A drives were found. I tried twice – first with the Reverse ATA files in a Liteon CDROM drive attached to channel 0 as Master, then again with the Reverse ATA files in the ND6650A drive attached to channel 1 as a Master. Both gave the same results.
The Bios detects the drive and the boot disk detects it. Why doesn’t the firmware package detect it?
What am I doing wrong?
:o

i can not speak for the satellite A45 notebook but i do know from experience this method will work.

i did this method as a curiosity on a 6750a drive that had optical read issues so i did not really care if i screwed it up in the process. this method was performed on a tecra 9000.

  1. find or get a second interface adapter (small connector between the drive and mainboard)…this presumes of course the A45 has an interface adapter!!!

  2. if it does and you get a second one…solder a connection between pins 45 and 47

  3. once this is done the drive 6750a when connected WILL be recognised at boot up correctly…clearly this is the end of the story or you can do THIS if you’re commited or curious about reverse flashing.

  4. once the drive is in… reboot using a bootdisk or cd rom boot disk into pure dos…

  5. it is much easier IF you have already downloaded the files and placed them in easy to get to folders on your hard drive like: C:flash or something easy to type from a dos command.

  6. execute your commands according liggys files and instructions pointing them to the flash folder.

  7. remove the modifed interface adapter and replace it with your original one and reboot.

  8. you will find now upon boot up your drive has been reversed and without all the hassle of using a desktop etc…

  9. the only rub is you need a second interface adapter to modify which presumes your machine uses one in the first place. if not…this method obviously doesn’t work.

I have never soldered before. All the computers in my house run Win XP or Vista Beta thus the drives are formatted in NTFS. So I would have trouble running Liggy’s prog from a hard drive in DOS.
How do you tell if a laptop has an interface adapter?
Anyway, I’m all setup to do it with a slimline adapter on my desktop. I just need more detailed instructions.
Should I use an earlier version of DOS? Should I try it without CD support and copy the Reverse ATA files onto a separate floppy? What did I do wrong?

Well I tried again – this time with the same Win98 DOS boot disk and Liggy’s Reverse ATA files on a second floppy. No success.
I’m just about ready to give up and use the ND-6650A in a USB enclosure. It is not what I wanted when I paid $85 bucks but if I can’t get it to work . . .c’est la vie! I could have gotten a much better external burner for less.

Make sure that the 6650 is attached to your secondary IDE controller.
Please check if the drive is detected in Binflash on your desktop PC. In case it is, I might have a different solution within a few weeks.

creating an xp boot dos disk is easy.

  1. connect your usb floppy dirve

  2. insert a floppy disk

  3. open windows explorer program

  4. go to the letter which is the floppy drive

  5. right mouse click on the floppy drive letter

  6. choose format

7.select: "create an MS-DOS startup disk

there you have it. now you have boot disk for windows xp pro or home

now

the way to tell if you have an interface adapter on your cd drive is to remove the cd rom from the machine and look at the back of the drive to see if there is a connecter sticking out of the back end. if yes it should be attached with 2 screws.

Yes it is detected by Binflash.
I have tried both IDE channels. They are listed as 0 and 1. I’m guessing here but 1 is probably secondary. Anyway I tried both.
I’m looking forward to your alternative solution.
Thanks! :slight_smile:

:doh: The startup disk created with these instructions is not going to detect NTFS formatted drives or partitions.

If you’re still willing to beta test something new, please drop me a PM with your email address.

It sounds like I got exactly the same problem. I use an IDE adapter but when I boot the drive is not recognized by the reverese script. However necflash in dos mode does recognize the drive.

Where you able to find a solution for the problem.

I want to change back the 6650A drive to master mode. It is currently on slave mode with a 2.42 bios.

I think we were trying the Windows bootcode flasher.

I am desperate, as it seems nothing to works:

My 6650A is connected to an secondary IDE Adapter to a PC. The interface is wired to shortcut pin 45 and 47.
Bios recognizes the drive as slave on second controller.
In windows with Sandra from Sisoft the CDROM drive is recoginzed as master on controller 1 (0 being the first controller).
My harddisk is master on controller 0.
Windows in System reports the CDROM as 0 (0). I am not where to see on which controller it is reported.
When I start bootflash from the master package the drive is listed, however I cannot change it to master Message: This bootcode will not work with your drive! I do not know for what reason it does come up.

Typing to change the the CDROM BIOS from 2.42 to a 1.x version doesn’t work with NECWINFlash as it says: Probably mixing up master and slave firmware… ID from drive 8c, ID from firmware 87

I would highly appreciate any help, what I may do wrong.
I need to change the drive to a master as my laptop only recognizes master drives.

Thanks
Helmut