Trouble flashing firmware

vbimport

#1

Just installed my NEC 3520A and I can’t flash my firmware. I’ve tried to flash my firmware with the binflash utility but as soon as I hit the FLASH button it freezes. I’ve also tried to official firmware(3.04) and it gives me a flash error in the beginning of the flash as well. What’s going on? Did I just ruin my new dvd burner? :sad:


#2

I would go here and pick a firmware. A lot of people have had trouble with 3.04. I have superb results with 1.UF and can recommend it. Make sure you follow the rules and are careful.

http://www.micheldeboer.nl/firmware/3520.html

http://club.cdfreaks.com/showthread.php?t=139533


#3

Well, I’ve tried flashing with 1.UG but it freezes at the beginning of the flash. Did I do something wrong? All I did was start the .exe and hit the FLASH button but it freezes.


#4

bump


#5

Is your drive internal on cable with the slave/master settings correctly jumpered?


#6

Correctly jumpered? I’m guessing so. It’s the only drive on that particular ide controller. I assume the jumper was set to master by default. The drive’s current firmware is the NEC 1.04, but I’m having trouble flashing to LD 1.UG or even the NEC 3.04. as the binflash utility keeps on freezing.


#7

I would look at the drive jumpers and make sure it is correctly set. I have flashed my NECs many times and they always work when the drives are set up correctly. Other than that I’m stumped unless somehow the file is bad. You don’t have odd IDE drivers do you?
Nvidia and VIA drivers can cause problems with optical drives.


#8

I checked my nec drive and it’s set to master. The nec drive’s jumper should be set to master if the previous drive’s jumper setting was master, right? If so, then yes, my jumper settings are correct. Concerning the IDE drivers, It’s an ATI board, thus ATI IDE drivers, so I guess the answer is no? Maybe when the binflash utility first locked up, that may be why I can’t flash it now?

p.s. I think this thread is in the wrong forum and should be placed in the NEC specific drive subforum.


#9

bump

Is there no one who can help me out? One of the reasons why I actually bought a 3520a instead of a 1620 or dvr-109 is because of the firmware. :iagree:


#10

This is tough. I would remove all drives from your system except the HD and the NEC. Then set the HD on one cable all by itself and the NEC on the other at the end of the cable as master. Boot to BIOS and make sure it sees the NEC, then to Windows (XP right?). Then try the flash. If Binflash fails try the official NEC firmware. I suspect something is causing the problem in your system.


#11

Alright, the only drives in my system are the NEC and HD. I don’t really get what you mean when you say “set the HD on one cable all by itself and the NEC on the other at the end of the cable as master”. The HD is on one IDE channel set as master and the NEC is on another IDE channel and set as master.

I would try your suggestion, but I have a problem with windows data corruption =/


#12

Your setup is right. Let us know.