Trouble decrypting disks with Buffalo BRUHD-PU3


#1

When trying to decrypt any of my UHD Blu-Ray disks with DeUHD using this portable drive I get an error saying that DeUHD does not support this drive. This drive is listed as “highly recommended” on the DeUHD supported drives page.

Both my desktop and laptop are having the same problem. Both are running Windows 10 1709.

Here’s an example of what I get on the status tab for my drive. Each disk I’ve tried is on the supported list, and produces the same results.

Summary for drive [H:] (DeUHD 1.0.1.5)
Drive BUFFALO Optical Drive BU11
Vendor Specific Info: O000300KFZHBTG1023

Disc media: UHD-4K (UHD 4K)
Video UHD-4k label: LOGANLUCKYUHD_UPK75
Media is AACS protected!
Removed AACS copy protection!
Disc is opened.
Error Info: DeUHD does not support your Blu-ray drive.

Here’s an example of an entry in DeUHD.log. Again, all similar entries for different disks.

 1.0.1.5 2018-01-10 
 
0: H 
 
19: LOGANLUCKYUHD_UPK75
 
22: MD5 90ECB05FE149D24EA3D293B7384E3AEE
 
22: SHA1 EF09E9388AA515DBECFC03E05499269DDD0EF40A
 
31: Got Temp path
 
31: Got path End
 
31: Open Disc 
 
32: Analysis support 
 
32: net error 2
 
32: net error: 2

#2

You may have to e-mail them as I don’t know who has this drive. Out of interest, see if the disc is actually decrypted. Navigate to the BDMV\Stream folder on the disc and see if MediaInfo gives you any info on an M2TS.


#3

I already checked if the disk was actually being decrypted and it wasn’t, sadly.

I’ve sent an email off to their support. We’ll see how long it takes them to get back to me. I’m not a paying customer yet, since I don’t want to drop $239 before I know this software will work in my environment.

If/when I hear back from them, I’ll update this post.


#4

Strange. I just ripped a disc with this drive a couple of days ago. Would you happen to know which firmware is on your drive? Maybe Buffalo silently patched the hole in their drive?


#5

I can’t seem to find any indication of what firmware might be on the drive in the device manager. AnyDVD reports the full name of the drive as BUFFALO OPTICAL DRIVE BU11 O000300KFZHBTG1023


#6

In Device Manager --> DVD/CD-Rom Drives --> Right Click on your Drive --> Properties --> Details Tab --> Property Drop Down --> Hadware Ids.

You should then see on the first line the FW # as the last few digits, like follows:

  • SCSI\CdRomPIONEER_BD-RW___BDR-211M1.02
  • SCSI\CdRomASUS____BW-16D1HT_______3.00
    SCSI\CdRomHL-DT-STBD-RE__BH16NS55_1.02

#7

The device manager doesn’t list anything that looks like a firmware revision.

USBSTOR\CdRomBUFFALO_Optical_Drive___BU11
USBSTOR\CdRomBUFFALO_Optical_Drive___
USBSTOR\CdRomBUFFALO_
USBSTOR\BUFFALO_Optical_Drive___B
BUFFALO_Optical_Drive___B
USBSTOR\GenCdRom
GenCdRom

#8

What about this free tool?

http://www.vso-software.fr/products/inspector/inspector.php


#9

So Arusoft made some change on their end and now DeUHD appears to work, until I actually try to play video off the disk. The DeUHD status window says the disk has been decrypted, but none of the m2ts files will play n MPC-HC or VLC. Additionally, mediainfo can’t make heads or tails of them.

I think it might be successfully decrypting at least some blocks. My Logan Lucky disk behaves exactly as if I were trying to use it without DeUHD, with blank results from mediainfo and VLC and MPC-HC throwing errors that they cannot read the file. However when I point VLC or MPC-HC to the m2ts on Arrival they both straight up crash, telling me they encountered a different problem.

One more thing: VSO Inspector reports the drive firmware as version BU11. I can’t find any information online about firmware for this drive, so I have no idea if that is some new firmware or not.


#10

Hi. I still haven’t plugged my drive into my Windows box yet to get the full name from the system but I distinctly remember MakeMKV reporting BU10 as the version. (I haven’t tried VSO Inspector.) So, yeah, you might have a patched drive. :frowning:


#11

I have the same problem, have specially purchased the Buffalo BRUHD-PU3-BK drive from Japan with firmware BU11, what should I do now?

Summary for drive [D:] (DeUHD 1.0.1.5)
Drive BUFFALO Optical Drive BU11
Vendor Specific Info: O000300KZ0HBTF3827

Disc media: UHD-4K (UHD 4K)
Media is AACS protected!
Removed AACS copy protection!
Disc is opened.
Error Info: DeUHD does not support your Blu-ray drive.

UHD official drives:
Buffalo BRUHD-PU3(external, USB, highly recommended)


System specifications of DeUHD users
#12

Download the 1.02 firmware, which does work, and see if you can flash it. If it works, great! If not, see if you can get a refund, I suppose. I’m sure there’s a way to hack the drive and flash whatever firmware you want. The problem is finding someone with the skills and the tools to figure out how to flash it.


#13

Unfortunately, I do not know out how to flash it. :cold_sweat:

Also, the firmware can i not read, is not even clear what firmware it is, it always comes the reference to BU11.

Where can I get the download here for firmware 1.02 ?

I think I had ever tried the “alleged” firmware 1.02, behind was still there BU11 :sweat_smile:


#14

Hi. The BRUHD-PU3 1.02 FW is here. It’s basically a Windows executable that you run once. It is in Japanese, though. You’ll probably want to take your phone and use Google Translate to do a translation of the screen. In any event, I’m guessing the flash will fail, but it can’t hurt to try.


#15

“email from DeUHD get”

Hi, we are fixing this problem, please wait for some time.
Thanks for your patience.


support@deuhd.ru


#16

hola te han dado alguna solucion los de DuHD


#17

any luck with this? I waited for over a month to get this Buffalo driver from Japan and am now SUPER disappointed that it doesn’t work. I guess I am jut lucky that i didn’t buy the full version of deUHD yet, as i was about to. I get this same note from DeUHD:

Summary for drive [D:] (DeUHD 1.0.1.7)
Drive BUFFALO Optical Drive BU11
Vendor Specific Info: O000300KZKHBTE2656

Disc media: UHD-4K (UHD 4K)
Video UHD-4k label: DUNKIRK
Media is AACS protected!
Removed AACS copy protection!
Disc is opened.
Error Info: DeUHD does not support your Blu-ray drive.

I would love to hear if there are any updates or anything. Kinda upset because they still have this listed as the “highly recommended drive”, which is why i paid a lot and waited to get it from Japan. Let me know. Thanks!


#18

I have the same problem.
I purchased bruhd-pu3 with bu11 version from japan as deuhd recommend this drive.
When does deuhd fix this problem ?


#19

I emailed the DeUHD support email with the issue and got this as a reply today:

“Hi, there is something wrong with the latest Buffalo BRUHD-PU3 from Japan and we are fixing this problem.
Please wait for some time, I will let you know when it is fixed. Thanks!”


#20

Thanks alot.
I am waiting for fixing this problem.