TRNCTED.FLENMES.MK in XBMC

vbimport

#1

this problem i am having seems to be specific to ImgBurn burned discs in XBMC.

i have tried burning many discs, using many file system combinations (including matching the settings in Nero with ImgBurn,) and the result is always the same. discs burned with ImgBurn, viewed in XBMC, display with the the file names truncated.

as i tried to display in my title, the file names will be displayed in all uppercase / shortened. if there are multiple folders that start with the same characters as well it will display with a 1, 2, 3, etc. added to the end.

file names appear normal in Windows & on my 360 on all discs.

(Nero burned discs display file names correctly in XBMC if that wasn’t implied also…)


#2

There’s an (non)issue with the Joliet file system and some file system parsers bomb out and hence revert to ISO9660.

ISO9660 is of course limited to 8.3 filenames (by default) and uppercase.

You could try changing the ISO0660 restrictions to allow longer filenames and the ascii character set.

It’s fixed for 2.4.0.0 so don’t worry.


#3

i tried upping the ISO9660 to level 2 and level X (wasn’t sure if it was relevant…) but it made no difference.


#4

Obviously that wouldn’t fix the Joliet issue but if xbmc is parsing the ISO9660 filesystem ‘as-is’ then it should display the longer filename.

You can double check the longer names are working by looking at the iso/disc in IsoBuster or something.

Assuming the ISO9660 filesystem shows long names in that program, for xbmc to be displaying shorter ones (and with numbers on the end to make them unique), it must be making those names up itself.


#5

I’ve got a friend of mine checking it out on his xbox but initial tests have not turned anything up. It’s displaying the Joliet file names just fine - names are limited to 64 characters of course though.

Is there a specific version of xbmc that you’re using that I should be checking it against?

He says default settings in ImgBurn and just changing ‘File System’ to ‘ISO9660 + Joliet’ is working fine on his.

His xbmc is ‘XBMC-2.0.1-FINAL-FAT-T3CH’ - which I’m sure means a lot more to you than it does to me!


#6

guess it just must have been my carelessness when testing and checking the file system and the character length of files (probably something like i used the default settings, then tried again with + Joliet, but used a file with a name that was too long…)

at any rate, i just did another burn using ISO9660 + Joliet + UDF, and set both ISO9660 & Joliet to level X and XBMC displayed the file names perfectly :slight_smile:

and not that it matters anymore (i sincerely appreciate your help LUK!) i have XBMC SVN 2007-10-07 (7th of October 2007) rev10457 installed.

thanks again! :slight_smile:


#7

The log window in ImgBurn will tell you when filenames have been truncated/modified due to file system restrictions so keep an eye on it :slight_smile: