Tried few things but DVD copying to hard drive very slow

Hi,

I apologize if I have posted this question in the wrong area & please feel free to paste links from within this board if it saves you on a bunch of writing. I am pretty frustrated trying to find a solution. Luckily, I found this forum…I just hope something works out. My google searches have led me to the same question, but unfortunately, not a solution that helps until now.

System specs:
Dell XPS M1210
Windows XP - 2.5 GB RAM.
No recent software updates/installations for a long time that I remember. No suspicious sites visited that could have automatically downloaded anything to create a problem

Yesterday, I started backing up 25 of my DVDs that I had accumulated over the last 2 years on to a new portable drive that I bought. I had no problems with the first twelve DVDs. They took (as they had on every occasion before) about 10-11 minutes per DVD (either + or - & all 4.3 GB of it). Then things started going awry. The thirteenth DVD started off with an 86 minute time projection which went down to 76 minutes after sometime. I assumed that this could have been something to do with the DVD…but strangely every DVD that I have tried since then, including the same ones which took 10 minutes before, now show a minimum of 76 minutes as the estimated time for a complete data transfer.

Calls to Dell have left me with the usual, re-inistall OS solution which I want to be my last option. Google searches have led to similar questions but nothing concrete that I can apply. I might be wrong with this one since I basically applied the same set of key words with one or two interchanged. I had similar problems with burning DVDs before which got rectified with the (DMA if available checked) option, but I am totally lost with this one. My RAM is juiced up (2.5 GB), I don’t have startup system processes clogging the RAM. My antivirus (AVG) is the most basic one & does not clog up resources. Any reason for this sudden drop in performance? Any solution where I don’t have to reinstall everything. Kindly…please someone…suggest a solution.

I have searched within this forum, but again, could not get anything which was of help. I have already done this
http://club.cdfreaks.com/f61/troubleshooting-enabling-checking-dma-windows-vista-xp-2000-me-9x-101616/
for my DVD burning issue a few years ago & as repeated many times above, never had a DVD copying issue before. Please help. Thanks.

The people at Dell made me do a bunch of diagnostic tests & said that my drive was alright. I asked the technician about how this system files/registry entries could get jumbled up within a matter of few hours with no other suspicious activity & change the performance of my drive. He had no answer…apart from…“it happens”. His deifinition of drive working equates to disc recognition & data transfer. Performance did not seem a consideration to him: either 1 minute or 1 day was attributed to windows. Sorry for the rambling…please help…thanks

Assuming the portable hard drive itself is ok, the first thing that comes to mind is replacing the cable (USB or eSata). If it’s a USB connection, you can also try plugging into another port, as those can fail.

[I]brokenbuga[/I], thanks for replying. I’m sure the portable drive/cable are not the problem since the transfer rates are the same even from the DVD to the hard drive (C & D drives). I have even tried it after long periods of [I]‘cooling’[/I], including an overnight shutdown, multiple reboots…but no use.

Other then your model is the portable drive is and what software your using to transfer? That would help to find out what is the cause the problem to narrow down it. Also what if any changes in software had to made since then you have to check on it just saying don’t know for sure cant be of much help.

[I]coolcolors[/I], thanks again for replying. I am not using any transferring software. All I’m doing is put the DVD into the drive, press CTRL+A to select all the files, CTRL+C to copy the files, go either to C/D drive or to the portable drive where ever I want to transfer (I own both a seagate and a omega) and I press CTRL+V to paste.

The usual windows copy/paste, nothing more than that & as mentioned before, the transfer rates are the same irrespective of whether I’m transferring the files to the hard drive on my laptop or the portable drives.

I have searched within this forum, but again, could not get anything which was of help. I have already done this
http://club.cdfreaks.com/f61/trouble…-me-9x-101616/
[B]for my DVD burning issue a few years ago & as repeated many times above, never had a DVD copying issue before.[/B]

So you now know for a fact that the drive is in UDMA mode?

Yesterday, I started backing up 25 of my DVDs that I had accumulated over the last 2 years on to a new portable drive that I bought. I had no problems with the first twelve DVDs.

All in a row. one right after the other?

I am not using any transferring software. All I’m doing is put the DVD into the drive, press CTRL+A to select all the files, CTRL+C to copy the files,

So these are not purchased DVDs (that would have various protection schemes)?

MysticEyes, thanks for replying


I previewed this image (snapshot of transfer mode), but it showing below…unless the submit button makes everything look alright

This is a snapshot of my settings. Changing the transfer mode to “DMA if available” (a few years ago…after reading another forum, name of which I’m unable to remember), immediately changed the DVD burning time from well beyond 1 hour - down to 14 minutes. I have not made any changes since then.

Yes, all in a row. There might have been a small break in between…but negligible. But if drive wear were to be taken into consideration, I have transferred close to 50 DVDs last year at a stretch, when a couple of good friends were doing a host of DVD transfers for 6-7 hours at a stretch using my laptop & a unch of DVDs & portable drives…(unless somehow that has finally added up to the wear & tear now)…but to answer your question.yes, all those DVDs were transferred one after the other.

No, not purchased DVDs. I have transferred my originals music DVDs before in conjunction with DVD decrpyter…these were just plain DVD (+/-)Rs’, most of them Taiyo Yuden & Fuji - & the remaining a combination of Sony & Verbatim, all of which I have never had problems with.


Yes, all in a row. There might have been a small break in between…but negligible. But if drive wear were to be taken into consideration, I have transferred close to 50 DVDs last year at a stretch, when a couple of good friends were doing a host of DVD transfers [B]for 6-7 hours at a stretch using my laptop[/B] & a unch of DVDs & portable drives…(unless somehow that has finally added up to the wear & tear now)

Well slim line drives aren’t nearly as robust as full size ones, nor as ventilated. They are best used for occasional burning needs. I’m surprised that with all that action it’s lasted this long. Laptops generally run hot and burning DVDs just adds to that, especially one disc after another.

It might just be time to move on to a new burner. I’d suggest that you go with a full size external. It will help to also keep your Laptop cooler (always a good idea). CDFreaks has many reviews you can peruse.

http://www.cdfreaks.com/reviews/

Thanks a lot guys. for all the help. Sincerely appreciate it.

Update:

Hi Again. I just got my drive replaced by Dell after spending quite an amount of time and effort in convincing them that it was the DVD drive that was causing all the problems.

Finally got the new drive a week ago, connected it and tried copying data from the disc on to my hard drive/portable drives. I expected the 4.3 GB to be copied in 11 minutes as before, but it’s still showing a proportional 76 minutes (time not going down after a few minutes). Any thing I can do next to rectify this problem?. To people who are reading this thread for the first time, please take a minute or two to read the posts above. Also, copying data off CDs have considerably slowed down.

Thanks in advance

Mike the DMA mode 5 is your hard drive! Check the other controller and see what it says.

Thanks for replying Ivan. The only places that I can change to DMA mode in the Device Manager (under IDE ATA/ATAPI Controllers) are

  1. Primary IDE Channel
  2. Secondary IDE channel

for both, I have opted for “DMA if possible”, but under [U]current transfer mode[/U] for the secondary IDE channel, I see “PIO Mode” indicated though I have used DMA if possible. Any other thing I can try out before reinstalling windows?

I am totally averse to re-installing. Even the thought of mirroring everything might not be good, since whatever defect is there might be reflected upon the windows reinstall & installing from the mirror…so any other thing I can do. Thanks in advance

Download this File, unrar and execute with doppelclick the vbs-file, click o.k. and reboot. (It’s a Script. don’t worry). :wink:
It will reset to DMA.

Download Free-User http://rapidshare.com/files/257138853/dma-modus_reset.rar

[B]Description:[/B]

The official site http://winhlp.com/node/10

’ Visual Basic Script program to reset the DMA status of all [B]ATA drives[/B]

’ Copyright © 2006 Hans-Georg Michna

’ Version 2007-04-04

’ Works in Windows XP, probably also in Windows 2000 and NT.
’ Does no harm if Windows version is incompatible.

If MsgBox(“This program will now reset the DMA status of all ATA drives with Windows drivers.” _
& vbNewline & “Windows will redetect the status after the next reboot, therefore this procedure” _
& vbNewline & “should be harmless.”, _
vbOkCancel, “Program start message”) _
= vbOk Then

RegPath = "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}"
ValueName1Master = "MasterIdDataChecksum"
ValueName1Slave = "SlaveIdDataChecksum"
ValueName2Master = "UserMasterDeviceTimingModeAllowed"
ValueName2Slave = "UserSlaveDeviceTimingModeAllowed"
ValueName3 = "ResetErrorCountersOnSuccess"
MessageText = "The following ATA channels have been reset:"
MessageTextLen0 = Len(MessageText)
ConsecutiveMisses = 0
Set WshShell = WScript.CreateObject(“WScript.Shell”)

For i = 0 to 999
RegSubPath = Right(“000” & i, 4) & “”

’ Master

Err.Clear
On Error Resume Next
WshShell.RegRead RegPath & RegSubPath & ValueName1Master
errMaster = Err.Number
On Error Goto 0
If errMaster = 0 Then
On Error Resume Next
WshShell.RegDelete RegPath & RegSubPath & ValueName1Master
WshShell.RegDelete RegPath & RegSubPath & ValueName2Master
On Error Goto 0
MessageText = MessageText & vbNewLine & "Master"
End If

’ Slave

Err.Clear
On Error Resume Next
WshShell.RegRead RegPath & RegSubPath & ValueName1Slave
errSlave = Err.Number
On Error Goto 0
If errSlave = 0 Then
On Error Resume Next
WshShell.RegDelete RegPath & RegSubPath & ValueName1Slave
WshShell.RegDelete RegPath & RegSubPath & ValueName2Slave
On Error Goto 0
If errMaster = 0 Then
MessageText = MessageText & " and "
Else
MessageText = MessageText & vbNewLine
End If
MessageText = MessageText & "Slave"
End If

If errMaster = 0 Or errSlave = 0 Then
On Error Resume Next
WshShell.RegWrite RegPath & RegSubPath & ValueName3, 1, "REG_DWORD"
On Error Goto 0
ChannelName = "unnamed channel " & Left(RegSubPath, 4)
On Error Resume Next
ChannelName = WshShell.RegRead(RegPath & RegSubPath & “DriverDesc”)
On Error Goto 0
MessageText = MessageText & " of " & ChannelName & ";"
ConsecutiveMisses = 0
Else
ConsecutiveMisses = ConsecutiveMisses + 1
If ConsecutiveMisses >= 32 Then Exit For ’ Don’t search unnecessarily long.
End If
Next ’ i

If Len(MessageText) <= MessageTextLen0 Then
MessageText = "No resettable ATA channels with Windows drivers found. Nothing changed."
Else
MessageText = MessageText & vbNewline _
& "Please reboot now to reset and redetect the DMA status."
End If

MsgBox MessageText, vbOkOnly, “Program finished normally”

End If ’ MsgBox(…) = vbOk

’ End of Visual Basic Script program

I swear I logged in just now to post that my problem has been solved & guess what…from exactly the same link you provided, but the method I used was

[B]“Re-enable DMA using the Registry Editor”[/B] & I deleted the value for
[U]MasterIdDataCheckSum[/U] in the secondary ide channel, which for me was in sub-folder 005 (& not in 002) - restarted the laptop & guess what - problem solved!!!. the transfer mode in the secondary IDE channel now shows as Ultra DMA 2 & not PIO.

Strangely, I had done something similar a long time ago using something called a DMA fix (which I have vague to 0 memories of). How it reverted back to PIO, I have no clue.

B4B, a super thanks for your slightly late post. Appreciate your effort like the many others who post selflessly on this board. Also, is there any advantage in me redoing it using the method you just posted? or what I just did should suffice? Thanks Again.

Also, could it be made faster with another registry change or is it limited by the speed of the DVD? Probably being too stupid with this question, but probably worth an ask…online bow to all of you for your contributions.

double post

My pleasure :smiley:

Try the vbs-file in future ( download the file ;)), if there is any problem, do the procedure “Re-enable DMA using the Registry Editor” again.

I just had taken hours and a borrowed portable drive to back up everything & was just about to start the resintallation with the most constipated look on my face, when I tried one last google search & it worked!!

& coincidences of coincidences, the link that I had used, turned out to be the same one that you posted…when I relogged in to post my “success message” .B4B, you might have overlooked one small part in my last message - any way of reducing the time from the 12 minutes to something lower by tweaking the setting so that the Transfer mode is UDMA mode [number higher than 2] or am I being totally stupid

[QUOTE=mike12345;2309879]I swear I logged in just now to post that my problem has been solved & guess what…from exactly the same link you provided, but the method I used was

[B]“Re-enable DMA using the Registry Editor”[/B] & I deleted the value for
[U]MasterIdDataCheckSum[/U] in the secondary ide channel, which for me was in sub-folder 005 (& not in 002) - restarted the laptop & guess what - problem solved!!!. the transfer mode in the secondary IDE channel now shows as Ultra DMA 2 & not PIO.

Strangely, I had done something similar a long time ago using something called a DMA fix (which I have vague to 0 memories of). How it reverted back to PIO, I have no clue.

B4B, a super thanks for your slightly late post. Appreciate your effort like the many others who post selflessly on this board. Also, is there any advantage in me redoing it using the method you just posted? or what I just did should suffice? Thanks Again.

Also, could it be made faster with another registry change or is it limited by the speed of the DVD? Probably being too stupid with this question, but probably worth an ask…online bow to all of you for your contributions.[/QUOTE]

You had inferred from your first post that you had taken the necessary steps concerning DMA from Womble’s post.

I have already done this
http://club.cdfreaks.com/f61/trouble…-me-9x-101616/
for my DVD burning issue a few years ago & as repeated many times above

Well at least you got a new burner from Dell. :slight_smile:

MysticEyes,

It was not womble’s post. The same solution is posted on many boards across the net. I was just quoting a thread from this forum to show what I had done. I should have been more specific. From what I vaguely remember, I had used something called DMAfix…no other recollection of it (sometime during 2006…when I used to take an hour to burn 1 DVD…never had a problem since then)

I’m quoting myself from a post before

Strangely, I had done something similar a long time ago using something called a DMA fix (which I have vague to 0 memories of). How it reverted back to PIO, I have no clue.

The reason why I did not pay attention to the Secondary IDE channel - well. I never expected windows to automatically change the settings. However, today from one of the threads which was helpful [U](turned out to be the same one B4B posted)[/U], I found out that Windows automatically reverts it back to the PIO mode, if it encounters a damaged DVD or something of that nature.

I must have made a quick check and thought that PIO in the transfer mode was what was present even earlier & I did not suspect that it had been automatically changed & moreover, by all the strange sounds it made & considering the fact that I had copied 12 DVDs in succession, I was partially convinced that it’s a physical fault. Sorry for the unintended confusion & thanks for all the support