Tried everything to get NWN to work with my Sony CRX145E

vbimport

#1

Hi guys, I bought NWN the day it came out and I still can't play it due to SecuRom not being supported by my drive (I only have the burner).

I made an image using latest version of CloneCD with "Game" profile selected. And using Daemon Tools 3.16 to mount the image, and it doesnt work. Turned on SecurRom emulation, still doesnt work. (I know its copy protection because if I use an .exe crack it works. But I dont want to have to use cracks)

I have tried creating an image with Regenerate Data sectors ticked and unticked. Subchannel Data for Data and Audio checked and unchecked. And with all other combinations between.
I've also tried using the "Hide CDR Media" option even though im not even using a cdr (just in case).

Can anyone suggest anything for me to try? I cant work out what's going wrong. I'm sure my drive should be able to read subchannel data when creating the image.

Any help or comments at all are welcome. I'm at my wits end here to get this game to work.
Thank you


#2

Did you use a low read speed when making the image?

Reading Subchannel Data from Data Tracks with Plextor CD-ROMs, Sony CD-ROMs, Sony CD-Writers CR-X120E, CR-X140E/S, CR-X145E/S, CR.X160E, Hewlett Packard CD-Writers 8200i, 8210i, 9100i, 9110i, 9200i, 9210i, 9300i, 9310i, 9500i, 9600i will always enable Fast Error Skip, too. You might need to reduce the read speed for reliable results!
I would suggest 4x reading. Also, when playing the back-up from your CD-writer you have to enable ‘Hide CDR Media’ in the CloneCD tray.


#3

debuya, are you saying that you can’t play the original cd from your cdrw drive?


#4

philamber: That’s correct yes.
So I figured if I ripped an image of it and mounted it in daemon tools I could get it to work. So far no such luck.

G@M3FR3@K: Thanks for the advice I will try ripping an image with the slower speed. I wont be burning it to a cd since I already have the original play disc. Like I said above, im trying to get it to work in Daemon Tools


#5

If the original cd won’t run, the problem must either be with your original cd or with your system. Making an image and mounting it with dt won’t fix the problem.

The securerom protection , nasty though it may be, won’t prevent you from playing with the original cd 3 from your writer.


#6

I just found this out the hard way by purchasing a new cd drive. And NWN still doesnt work :eek:

So i’m not sure where to go from here. What other settings on my pc might be stuffing up the SecuRom security?


#7

I suspect that it’s more likely that your original cd is bad. Try it on another system and if it doesn’t work there, take it back to where you bought it for exchange.


#8

Yep it works on another system.

I’m doing a clean Windows reinstall today, to see if that fixes the problem. Sigh
Thanks for your help


#9

Sorry guys - Debuya is correct: the original NWN won’t work correctly on a number of drives. I too purchased NWN (Australian release) at the same time that I got WC3. I have two drives in my system:

Sony DDU1621 DVDROM
Liteon 24102B CDRW

NWN comes on three discs. AFAIK only disc 3 is protected (using the same version of SecuROM as WC3 I believe). Both disc 2 (unprotected) and disc 3 (SecuROM new) gave me ‘unable to read from disc’ errors during installation. We are talking original, pressed discs here.

The only way I got it installed in the end was by manually copying the contents of disc 2 to a folder on my HD (using my Sony DVDROM, yep the same one that refused to read the disc during the installation), and when asked for disc 2 to be inserted I pointed it to the HD folder. I also has to do a minimal install so that disc 3 wasn’t required during installation.

Once this was done and the game was installed on my HD I then followed a suggestion from the BioWare ‘self-help’ forums which said to manually copy certain directories from disc 3 to the NWN directory on the HD and then alter one of the .INI files to make NWN load the data from HD rather than disc 3 in the CD drive (ie faking a full installation of NWN). Easier said than done - neither of my drives were able to reliably read the necessary files from disc 3, so when I was copying them over (using Windows Explorer) it would error out on certain files with ‘unable to read from disc’ errors. I finally resorted to copying the files from my second PC over the network - this worked. This second PC has an Acer 12x8x32 CDRW (not sure of exact model, can find out if you want) which had no troubles reading the files from disc 3.

I’m lucky that I have the second PC to do this with - many people don’t and would be stuck with a totally unusable game if their drives couldn’t read it. As you can probably tell I’m not too happy with Infogrammes’ decision to use this new SecuROM for NWN. If it prevents people who have legitimately purchased the product from using it, it is broken as far as I’m concerned. Pity it’s such a good game :slight_smile:

Given that disc 2 is not apparently protected and I still had problems with it it sort of seems like a faulty CD - but then the Acer wouldn’t have been able to read it. I can at least partly understand why disc 3 would fail on some burners (even though I don’t agree with it) if it is using SecuROM new. It could be that the SecuROM check routines that are run by the NWN installer are broken and fire up in the wrong places (ie when disc 2 is in the drive), causing the check to fail as disc 2 is not protected. This could explain why I can read the contents of disc 2 from the same drive using Explorer but not during the install itself. Someone has pointed out in the BioWare forums that the SecuROM protection routines in NWN may be broken and polling the CD drive at unexpected intervals during the game itself, causing the stuttering & jerking that many people are seeing ingame. If this is the case it could explain some of the above problems… of course it could all be totally cr*p, but I’ll reserve judgement until I hear more from others.

In the meantime you can work around the inability to install NWN by doing what I did, as long as you have easy access to a drive which can actually read disc 3. Let me know if you want further details of the procedure, or look it up in the BioWare forums (http://nwn.bioware.com/forums/).

Regards,

Jacob


#10

Hmmm. Great protection this one. Hard to copy and hard to play even from the original.:a Wonder what marketing genius figured out this one.:rolleyes: E minus for customer relations.:Z

Also sounds as though it’s hot-wired by the ini file to only play from the drive it’s installed from which may explain some people’s failures to back it up successfully (i.e. they just didn’t test it from the correct drive which could easily occur if the game were installed from a daemon tools stealth drive to test the integrity of the image but the ini file wasn’t then edited to point to the drive from which the back-up copy is to be tested).


#11

did u make a successful backup of NWN or WC3 with the sony crx145e?