Transfer Mode Downgrade

vbimport

#1

Hi All :slight_smile:

I got an annoying problem with my nForce4 chipset: usually I don’t reboot very often, but now I’m forced to reboot after burning 4-5 DVDs… this is because WinXP downgrades my BenQ DW 1620pro from UDMA2 to PIO-mode, which makes working impossible while burning (not to mention the bad burning quality cos of permanent buffer underruns).

The nForce driver reports “transfer mode has been downgraded due to excessive errors”. I replaced cabling, etc. I think this is a hardware incompatiblity. I already read that other users here have the same prob, but no solutions were given.

Maybe there is a way to disable this downgrading?

Thanks,
CyberDevil


#2

Most people advice against using nForce IDE drivers. Microsoft IDE drivers seem to be the most stable IDE drivers available, you should give them a try.


#3

Thanks for the tip, I used Microsoft Drivers before, too… but nForce drives offer a significant performance boost considering hard drive access… therefore I would like to continue using them… if possible. (that’s why I’m looking for a way to disable that downgrading)


#4

Uninstall the ide channel under windows device manager(primary or secondary).Restart the computer and let windows xp install again the driver.
Try also the registry edit.(this should stop forever the downgrade option of windows xp)
start-run-regedit-navigate to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\000X

look in each 000X for “MasterIdDataCheckSum” or “SlaveIdDataCheckSum”
right click and delete them.

0000 is the IDE master controller (nothing to tweak here)
0001 is the primary IDE channel
0002 is the secondary IDE channel

microsoft says about this problem:
http://www.microsoft.com/whdc/device/storage/IDE-DMA.mspx
solutions:
http://www.overclockers.com/tips839/
http://www.neowin.net/forum/lofiversion/index.php/t19007.html