Total Failure/Malfunction of 3 drives- HELP!

vbimport

#1

Though I FEEL like a newbie, I don’t think this question’s in that category, but out of respect for my first attempt, I put it here anyway. PLEASE HELP! This one’s killing me!!! Nobody on the Net seems to have this problem; spent HOURS on this!

I started w/ an I/O Magic 16X writer (actually BenQ 1260x) to replace my 2nd CDRW. The drive worked as a CDROM, but no writing was possible. Wouldn’t format DVDRW or CDRW discs, from multiple vendors. Nero Burning ROM wouldnt write to DVD+R (Maxell) media, either. Flashing firmware failed, but the drive continued to work the same. Assumed defective, and returned it.

Ensured latest chipset drivers from VIA installed (4-in-1). Latest video(Nvidia) drivers, since someone said that may relate . VIA IDE Tool says IDE bus is running DMA at ATA66. Have switched cables, using both ATA33 and ATA66. Deactivate antivirus s/w when formatting. Shut down as many TSR’s as I can prior to attempts. None of these things changes ANYTHING.

Replaced it w/ an Emprex 16x (rebadged BTC 1016IM). Identical behavior. Worked as CDROM only (I don’t own any DVDs…quit laughing!). Flashed to latest f/w successfully; no help. Used media that was on compatibility list for drive (including detailed “code #'s”). Tried DVD-R 8x and 4-10x CDRW disks. Same deal; no positive response. Sony DVD+RW (1-4x) locks machine up on all drives (wasn’t on list of 1st two drives, though).

Thought my luck just sucked, so bought Pioneer DVR-A08XLA. F/w is 1.14. You guessed it; same behavior.

Nero error message when trying to format DVDRW or CDRW disk: “Error writing the disc in E:\ Please confirm that the disc is compatible with the drive and is not scratched or damaged.” Nothing on Nero’s site addresses it adequately. All discs I’ve tried are brand new, and I’ve tried different ones in each pack. NOTE: My old CDRW on my Win98SE machine has NO PROBLEM formatting the same CDRW discs (Roxio). I had no problems with my LiteON and BTC CDRWs I was using before (one removed, LiteON remains,but disconnected while troubleshooting new DVD writer).

The only “driver” I don’t like the looks of is NTIdrvr.sys. This was installed by NTI’s DriveBackup! 3.x. I CANNOT get rid of it, and NTI hasn’t responded. Renaming it to “.BAK” makes WinXP “lose” the drive, so I tried removing NTI s/w completely (and cleaned the registry w/ jv16 powertools, but NTIdrvr.sys remains).

System:

AMD Athlon 2200XP, 1GB PC2700 DDR, Albatron KX400-8XV Motherboard (VIA KT400 chipset), Maxtor ATA/133 drives (1=60GB Master, 1=40GB Slave).

WinXP Pro, SP1a

Presently: Pioneer DVR-A08XLA only drive on 2ndary IDE interface; “Master”

Software: Nero FULL Edition v6.6x; latest updates as of 12/12/04 on all components. No DVD playing/authoring/etc. s/w on machine.

Who out there can solve THIS ONE??? My problems are always “the one’s nobody’s seen.” It’s a gift. ;o)

Any help would be GREATLY APPRECIATED!!!

CJ


#2

is DMA enabled on your IDE controllers ?
also try these steps


#3

Regarding the NTIdrvr.sys file… have you tried deleting/renaming it in “Safe Mode” or throught the Command Prompt? Also, you could try turning “System Restore” off. - Right click “My Computer” -> Properties -> System Restore

*Note - turning off System Restore will delete all restore points! Do so at your own risk!

Other Ways:

Safe Mode:

  • Restart computer
  • press/hold F8 (I am pretty sure thats it)
  • Choose - Start Windows in Safe Mode

Command Prompt:

  • Ctrl-Alt-Delete [Opens Task Manager] -> Kill explorer.exe [End Process button]

  • The task bar disappears, click the “Application Tab”

  • Click [New Task button] -> type “cmdwithout quotes -> press [enter key]

  • Command Prompt window opens.

  • Change to the directory where NTIdrvr.sys is located - for example if it is in c:\windows\system32 - type “cd c:\windows\system32without the quotes and press [enter].

  • Your prompt should look like:

C:\Windows\System32>

  • Type “ren NTIdrvr.sys what_ever_you_want_to_rename_it_towithout quotes-> press [enter]

  • close the Command Prompt window

  • do Ctrl-Alt-Delete -> Use Task Manager to shutdown and restart the system.


Whether NTIdrvr.sys is the source of your problem, or not, I do not know.
Good Luck!


#4

oh, and never forget when all else fails to try this ->


#5

Hi Ghosters & Skith,

Thanks to your both for the input. You guys are good! As stated in my original message, the IDE buses both have DMA enabled, and are using the ATA/66 speed (maximum available) on the secondary IDE interface (Reported by VIA’s IDE Tool).

Ghosters, I followed your link’s instructions, w/ the exception of separately assigning IRQs to each device, which I fear may create more problems than it corrects, particularly for this newbie. No help, and no change in behavior upon retesting.

Skith: WinXP allows me to move/delete the file, but “killing it” makes WinXP “lose” the drive (vanishes in Device Mngr). I’ve already contacted NTI, and their (poor) answer thus far indicates that it is not known to cause problems. Don’t know how to “get back to the WinXP default” w/o doing a complete re-setup (which I may have to do, but it’s not my first choice). I’ll continue that endeavor, but I don’t think it’s going to “do it” for me. It’s “TIED INTO” the registry in a BIG WAY.

I’ve cleaned out NTI entries from the registry as of today, as well.

Ghosters, your sledge hammer picture “SAYS IT ALL!”

Any other ideas, my friends? I’m no closer to solving it. :o(

CJ


#6

when the drive disappears use the following

  1. Click Start, click Run, type regedit and click OK.

  2. Browse to the following location:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}

  1. Right-click on both the Upperfilters and Lowerfilters registry values and choose Delete/Ok. If you find only one of the Upperfilters or Lowerfilters values, delete just the one.

  2. Close the registry editor and restart the machine.


#7

Hi Ghosters,

I found the UpperFilters only. However, the registry key corresponds to all of these files:

GEARAspiWDM
InCDPass
NTIDrvr

There are still 27 entries in the registry that “tie” to NTIDrvr

There are 19 entries in the registry that “tie” to GEARAspiWDM

Deleting Gear Software’s driver I’m uncertain about; haven’t had time to research them enough. You probably know what it is; care to tell me?

Killing InCDPass will further cripple Nero, won’t it?

Before this newbie crashes his machine, I thought I’d double-check: Do you maintain that I should delete the UpperFilters entry?

Thanks again for all of your help.


#8

hmm, this may be a long shot, but you could try re-installing the NTI backup program software and uninstalling it again. I have had this work with (other) programs, granted I did not go messing with the registry. Mabey you could use some sort of tool to see what NTI does to the reg. when it is installed.

As for the INCDPass - INCD is Nero’s packet writing software (it is suppose to make a optical disc work like a floppy drag/drop). Your best bet may be to completely uninstall NERO, run their “clean tool” (can download it from their support section), run it, and reinstall nero. I would not reinstall INCD (packet writing software can supposedly cause all sorts of problems).

I hope you find your answer, good luck!


#9

Well, I discovered the addition of an ASPI layer caused Device Manager to show my secondary IDE interface as a SCSI device! (since ASPI was developed for SCSI, this wasn’t totally unexpected). Removing it and hoping to have it reinstall it upon reboot resulted in WinXP LOSING the entire secondary IDE! Nero doesn’t “like” the ASPI layer, claiming (in Infotool) that it’s corrupted (which I sincerely doubt). Switching to Nero’s built-in ASPI makes it say everything’s fine, but when you go back in, the system’s reverted to the so-called “corrupted” Adaptec redistributable version! UGH!

Either way, not only did it never enable the DVDRW drive, it never allowed even formatting a disk.

I’ve since removed Nero, for multiple sources on the Web say the 6.x series has turned into a bug farm, which my experience proved out.

I’m now looking at having to completely rework XP by running “setup.”

…any ideas prior to my doing so??


#10

I fixed it, and for the benefit of others reading this thread, here’s the “big secret”:

Using the Intel or VIA Bus Mastering drivers results in problems, so I found out after investing countless hours.

That is, IF YOU WANT YOUR DVD-R/RW DRIVE TO WORK, USE THE DEFAULT WinXP Bus Mastering drivers! (Just the opposite of what would be expected). My issue was w/ WinXP SP1, so I don’t know about Win9x/Me/2k, but if you’re stuck, it’s worth a try.

Thanks to all of you for your help. :slight_smile:


#11

Now go back and get the I/O Magic BenQ and you will be fine :wink:


#12

BenQ has their own little “firmware issues” (converting from OEM to “Retail,” etc.), and the Pioneer is HIGHLY rated. For all the sweat & blood, I’m finally gonna value my time @ >50 cents/hr and stay w/ what’s working WELL now. :iagree: